Microsoft Excel

Herbers Excel/VBA-Archiv

mit excel-Formel filtern

Betrifft: mit excel-Formel filtern von: Rainer
Geschrieben am: 13.09.2014 11:01:28

Hallo Excel-Spezialisten,

folgendes Problem habe ich:
Ich habe eine Excel-Arbeitsmappe mit 2 Tabellenblättern. In Tabelle1 sind 3 Spalten enthalten (Auftragsnr, Kunde, Betrag). Ich möchte in Tabelle 2 über eine Excel-Formel aus Tabelle1 alle Einträge übertragen, die in der Spalte 'Kunde' die Ausprägung "Kunde1" enthalten.

Wie kann ich das über eine Excel-Formel lösen?

https://www.herber.de/bbs/user/92607.xls

Beste Grüße
Rainer

  

Betrifft: AW: mit excel-Formel filtern von: Hajo_Zi
Geschrieben am: 13.09.2014 11:03:11

Hallo Rainer,

http://www.excelformeln.de/formeln.html?welcher=28

GrußformelHomepage


  

Betrifft: AW: mit excel-Formel filtern von: Rainer
Geschrieben am: 13.09.2014 11:09:17

Hallo Hajo,

danke für den Link. Das sieht komplex aus. Ich überlege gerade, wie ich das auf mein Beispiel übertragen kann. Kannst du mir da helfen?

Beste Grüße
Rainer


  

Betrifft: AW: mit excel-Formel filtern von: Hajo_Zi
Geschrieben am: 13.09.2014 11:16:26

die Beschreibung ist doch eindeutig, man muss nur ;1 ersetzen durch ;Zeile()
Ich bin auch nicht der Formelmensch.

Gruß Hajo


  

Betrifft: AW: mit excel-Formel filtern von: Rainer
Geschrieben am: 13.09.2014 11:45:15

hi Hajo,

ich krieg es mit dieser formel leider nicht hin..

trotzdem danke für deine hilfe.

VG
Rainer


  

Betrifft: AW: mit excel-Formel filtern von: Hajo_Zi
Geschrieben am: 13.09.2014 11:53:06

Hallo Rainer,

es ist nicht meine Formel.

Tabelle2

 A
1Auftragsnr
260127830
360129800
460131250
560622550
660625160
760625400
860114360
960626300
1060626760
1160127560
1260128480
1360627270
14 

verwendete Formeln
Zelle Formel Bereich N/A
A2:A14{=WENN(ISTFEHLER(INDEX(Tabelle1!A:A;KKLEINSTE(WENN(Tabelle1!$B$2:$C$19=$E$1;ZEILE($2:$19));ZEILE()-1)));"";INDEX(Tabelle1!A:A;KKLEINSTE(WENN(Tabelle1!$B$2:$C$19=$E$1;ZEILE($2:$19));ZEILE()-1)))}$A$2 
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.14 einschl. 64 Bit



Gruß Hajo


 

Beiträge aus den Excel-Beispielen zum Thema "mit excel-Formel filtern"