Microsoft Excel

Herbers Excel/VBA-Archiv

Formel mit Anzahl_wenn

Betrifft: Formel mit Anzahl_wenn von: Lemmi
Geschrieben am: 01.10.2014 16:12:33

Hallo zusammen,

ich habe 5 Spalten in dem ich unter der Tabelle ein Vorgabewert habe.
Ist der Vorgabewert überschritten so soll die Anzahl ermittelt werden.
Dies habe ich in der Tabelle soweit umgesetzt.

Nun möchte ich wissen wieviel Zeilen betroffen sind in dem der Vorgabewert überschritten ist.

Da die max. Anzahl der Spalten nicht gleich der max. Anzahl der Zeilen sein muss habe ich noch keine Idee wie hier die Formel aussehen kann.

Die Beispieldatei stellt hier nochmals alles da. Das Ergebenis muss 4 sein.

https://www.herber.de/bbs/user/92933.xlsx

Gruß
Lemmi

  

Betrifft: mit ZÄHLENWENN() ... von: neopa C (paneo)
Geschrieben am: 01.10.2014 16:20:51

Hallo lemmi,

...

 =ZÄHLENWENN(F8:F12;">"&F15)
und Formel kopieren nach rechts.


Gruß Werner
.. , - ...


  

Betrifft: AW: mit ZÄHLENWENN() ... von: Lemmi
Geschrieben am: 01.10.2014 17:20:08

Hallo Werener,

"ZÄHLENWENN....." hatte ich ja schon in der Datei!

Ich benötige die Anzahl der Zeilen in der mindest 1x der Vorgabewert überschritten worden ist.
Das Ergbnis muss 4 sein!

Zur Zeit werden nur die übererschrittenden Werte der Spalten gezählt!
Diese Anzahl ist ist zur Zeit max.3.


Gruß
Lemmi


  

Betrifft: jetzt hab ich meine Brille wieder auf ... von: neopa C (paneo)
Geschrieben am: 01.10.2014 17:59:01

Hallo lemmi,

... sorry, ich war vorhin offensichtlich völlig neben mir :-(

Mit folgender Formel kannst Du es auch ohne Hilfsspalte ermitteln:

=SUMME(N(HÄUFIGKEIT((F8:J12>F15:J15)*(ZEILE(F8:F12));ZEILE(A8:A12))>0))

Gruß Werner
.. , - ...


  

Betrifft: aber die nicht richtig geputzt ... von: neopa C (paneo)
Geschrieben am: 01.10.2014 18:20:32

Hallo Lemmi,

... ein zusätzlicher Test hat gerade ergeben, dass dies nicht immer zum richtigen Ergebnis führt.

Ziehe meinen Beitrag also erst einmal wieder zurück.


Gruß Werner
.. , - ...


  

Betrifft: als MATRIXFormel ohne Hilfspalte ... von: neopa C (paneo)
Geschrieben am: 01.10.2014 18:36:09

Hallo noch einmal,

... nun sollte es richtig sein:

 EFGHIJ
6 Spalte 1Spalte 2Spalte 3Spalte 4Spalte 5
7      
8 18071429751664832
9 191021310611697848
10 1528-3210011560780
11 18401159781524762
12 18161549851662831
13      
14      
15 190014010001664832
164     

Formeln der Tabelle
ZelleFormel
E16{=SUMME(N(HÄUFIGKEIT(WENN(F8:J12>F$15:J$15;ZEILE(F8:F12)); ZEILE(A8:A12))>0))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: AW: als MATRIXFormel ohne Hilfspalte ... von: Lemmi
Geschrieben am: 01.10.2014 19:19:06

Hallo Werner,(neopa C (paneo)

das sieht gut aus!
besten Dank!


Gruß
Lemmi


  

Betrifft: ohne WENN = ohne Arrayformel + ohne Hilfspalte von: WF
Geschrieben am: 01.10.2014 19:27:36

Hi,

=SUMME((HÄUFIGKEIT((F8:J12>F15:J15)*ZEILE(1:5);(F8:J12>F15:J15)*ZEILE(1:5))>0)*1)-1

Salut WF


  

Betrifft: im Prinzip ist das mein 1.Vorschlag ... nur ... von: neopa C (paneo)
Geschrieben am: 02.10.2014 09:39:31

Hallo WF,

... das dort noch das -1 fehlte. Dies hatte ich dann bei mir auch ergänzt, aber bei meiner Testung erinnerte ich mich dann an Hinweise von Sepp (Burch) bei ähnlichen Formelkonstrukten, der bei derartigen Konstrukten zu der MATRXFormelvariante geraten (und nachgewiesen) hatte.
Im vorliegenden Fall dürfte jedoch die {}-freie Lösung schon ausreichend sein.


Gruß Werner
.. , - ...


  

Betrifft: AW: im Prinzip ist das mein 1.Vorschlag ... nur ... von: Josef B
Geschrieben am: 02.10.2014 21:17:15

Hallo Werner

Dein Bauchgefühl war auch diesmal richtig.

Wenn alle Werte grösser als die Vorgabe, dann ist eben die minus eins falsch.

Gruss Sepp


  

Betrifft: ein Glück, das ich etwas Bauch habe, auch ... von: neopa C (paneo)
Geschrieben am: 03.10.2014 08:34:33

Halle Sepp,


... wenn ich mir, auf Excel und Deine Aussage bezogen, manchmal einen größeren wünschen würde ;-)

Ich wünsche Dir/Euch ein schönes/goldigen Herbst-WE.

Gruß Werner
.. , - ...


  

Betrifft: AW: Formel mit Anzahl_wenn von: Peter
Geschrieben am: 01.10.2014 17:15:30

Hallo

Mit einer Matrix-Formel und einer Hilfszeile funkts.

https://www.herber.de/bbs/user/92934.xlsx


 

Beiträge aus den Excel-Beispielen zum Thema "Formel mit Anzahl_wenn"