Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Werkzeug
BildScreenshot zu Werkzeug Werkzeug-Seite mit Beispielarbeitsmappe aufrufen

Sortieren von Werten

Betrifft: Sortieren von Werten von: Bene S.
Geschrieben am: 10.10.2014 18:21:54

Hallo Zusammen,

ich habe lediglich Basiskenntnisse in Excel und habe ein Problem, welches ich einfach nicht lösen kann. Um eine schnelle Hilfe wäre ich sehr froh :).

Problem: Ich habe eine Spalte mit Referenzwerten. Die Spalten neben dieser Spalte entahlten ebenfalls diese Referenzwerte, jedoch können diese in einer anderen Reihenfolge stehen, mehrmals oder gar nicht auftauchen. Ich will die Werte in den Folgespalten so sortiert haben, dass sie an der gleichen Position wie in der Referenzspalte stehen.

Anbei ein Excel-File, Welches das Problem veranschaulicht. Hier habe ich ein Beispiel mit Soll und Ist gemacht.

https://www.herber.de/bbs/user/93108.xlsx

Ich bedanke mich schon mal für jegliche Hilfe.

Grüße Bene

  

Betrifft: AW: Sortieren von Werten von: stef26
Geschrieben am: 10.10.2014 20:52:21

Hallo Bene,
also ohne VBA und mit Hilfsspalte hätte ich ne Lösung.

Formel in I4 eintragen und nach unten ziehen.
=WENN(ZÄHLENWENN(C$4:C$13;H4)<>0;H4;"")

Die anderen Spalten entsprechend umbauen.
Ohne Hilfsspalte brauchts du ne VBA Lösung (glaub ich) da müssten die Profis ran.

Was ich aber nicht verstehe ist, du schreibst dass die Werte auch doppelt vorkommen könnten?
Wie soll dann das soll aussehen ?

Gruß
Stefan


  

Betrifft: AW: Sortieren von Werten von: Bene S.
Geschrieben am: 10.10.2014 21:17:21

Hallo Stefan,

danke für die schnelle. Es funktioniert otptimal. Ja es können doppelte Werte in den Spalten vorkommen. Die Spalten stehen für Arbeitsplätze in einer Produktion und die Zahlen für Werkstücke. Es kann also vorkommen, dass das selbe Werkstück während seines Produktionsprozesses mehrmals über den selben Arbeitsplatz muss.

Ich denke, die Zahl (Werkstück) doppelt in einer Zelle erscheinen zu lassen ist nicht möglich oder?
In meinem Beispiel ist z.B. in Spalte 1 die Zahl 5 zweimal vetreten. Es wird aber durch die Formel nicht dargestellt, dass diese zweimal existiert. Dies habe ich in meiner Frage weggelassen, da ich der Auffassung bin, dass das nicht möglich ist. Oder gibt es eine Möglichkeit?

Vielen Dank für deine Hilfe.

Grüße Bene


  

Betrifft: AW: Sortieren von Werten von: stef26
Geschrieben am: 10.10.2014 22:50:36

Hi,
du könntest die dir Anzahl der Werkzeuge Anzeigen lassen.

=WENN(ZÄHLENWENN(C$4:C$13;H5)<>0;ZÄHLENWENN(C$4:C$13;H5);"")

D.h. wenn Werkzeug 2 einmal vorhanden, dann erscheint in der Zeile von 2 eine 1(Anzahl)
Ist das Werkzeug "5" 3x vorhanden, dann erscheint eine 3 in der Zeile "5"

:-)
Stefan


  

Betrifft: AW: Sortieren von Werten von: Bene S.
Geschrieben am: 10.10.2014 23:15:32

Hey,

:) super, genau das habe ich gesucht! Vielen vielen Dank. Ich muss mich mal mehr mit Excel beschäftigen. Ich glaube es lohnt sich ;)

Viele Grüße
Bene


  

Betrifft: in einer Zelle von: KlausF
Geschrieben am: 13.10.2014 21:20:09

... und wenn es in einer Zelle stehen soll, dann in I4 eingeben
=WENN(ZÄHLENWENN(C$4:C$13;$B4)>1;$B4 & " *" & ZÄHLENWENN(C$4:C$13;$B4);WENN(ZÄHLENWENN(C$4:C$13; $B4)<>0;$B4;""))

Gruß
Klaus


  

Betrifft: AW: in einer Zelle von: Bene S.
Geschrieben am: 14.10.2014 22:39:12

Hallo,

danke für eure Hilfe. Echt super. Ich habe jedoch ein weiterführendes Problem mit der Tabelle. Ich will zusätzlich zu den sortierten Werten, die mit iherer Anzahl in der Zelle erscheinen, gewisse Eigenschaften diese Werte mit nehmen. Die Eigenschaft sind in der Tabelle mit Buchstaben ausgedrückt.

Anbei wieder ein Beispiel mit Ist und Soll, das das Problem veranschaulicht.

https://www.herber.de/bbs/user/93170.xlsx

Ich bedanke mich schonmal für jegliche Hilfe.


 

Beiträge aus den Excel-Beispielen zum Thema "Sortieren von Werten"