Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMENPRODUKT mit variablen Beding. aus Teilergeb.

Betrifft: SUMMENPRODUKT mit variablen Beding. aus Teilergeb. von: MarcoK
Geschrieben am: 30.10.2014 10:32:45

Guten Morgen liebe Excel Profis,

ich habe bereits eine Weile vergeblich die Excel Foren durchforstet, um eine Lösung meines Excel Problems zu finden. Daher versuche ich mal mit diesem Beitrag mein Glück. Ich versuche die Lösung, dich ich suche, auch relativ einfach zu beschreiben, da ich mit zwei Tabellenblätter mit großen Datenmengen arbeite und genau diese Lösung benötige.
Hier mein Beispiel:
Ich habe zwei Tabellenblätter.
In den Zellen A1:A30 stehen in beiden Tabellenblättern die Datumsangaben 01.04.14-30.04.14.
Im Tabellenblatt2 steht zusätzlich in den Zellen B1:B30 die Zahlenwerte 1-30, also B1=1 bis B30=30.
Nun muss ich im Tabellenblatt1 einen Filter auf die Datumswerte einbauen und in einer beliebigen Zelle (beispielsweise Zelle B2) soll die Summe der Zellen aus Tabellenblatt2 B1:B30 dargestellt werden, die mit den gefilterten Datumswerten aus dem Tabellenblatt1 übereinstimmen.
Filtere ich als einfaches Beispiel also im Tabellenblatt1 die Datumswerte 01.04.14 und 02.04.14, soll mir die Summe aus Tabellenblatt2 B1:B30 dargestellt werden, die mit den Datumswerten im Tabellenblatt2 A1:A30 übereinstimmen. Ergebnis also = 3.

Ich hoffe, dass jemand eine schlaue Idee hat, die nicht auf einer VBA Programmierung beruht.

Tausend Dank für Eure Hilfe vorab!

  

Betrifft: AW: SUMMENPRODUKT mit variablen Beding. aus Teilergeb. von: fcs
Geschrieben am: 30.10.2014 13:38:21

Hallo Marco,

hole dir Per Formel mit SVERWEIS die Werte zu den Datumswerten aus Tabelle2 in eine Zusätzliche Spalte in Tabelle1.
Beipielformel B4:

=WENNFEHLER(SVERWEIS(A4;Tabelle2!$A:$B;2;FALSCH);0)

Summe	18
	
Datum	Wert Tab2 
03.04.2014	3
06.04.2014	6
09.04.2014	9
Mit der Funktion TEILERGEBNIS kannst du dann die Summe sichtbaren Werte im gefilterten Bereich ermitteln:
=TEILERGEBNIS(9;B3:B33)

Die Zelle mit der Summe sollte dann aber oberhalb oder unterhalb der gefilterten Daten sein.

Gruß
Franz


  

Betrifft: AW: SUMMENPRODUKT mit variablen Beding. aus Teilergeb. von: Marco Kriescher
Geschrieben am: 30.10.2014 15:56:34

Hallo Franz,
vielen Dank für die Antwort.
Genau das wollte ich ja nicht tun. Meine Datei hat jetzt bereits 13MB und ich müsste dann zusätzlich ca. 30 Spalten einbauen, die ich in der Ansicht nicht benötige. Sie sollten halt nur zur Berechnung der Summenzeile (Teilergebnis) hinzugezogen werden. Die Berechnung bei der Filterung würde mit den zusätzlichen Spalten leider viel zu lange dauern. :-(
Trotzdem vielen Dank.


  

Betrifft: AW: SUMMENPRODUKT mit variablen Beding. aus Teilergeb. von: fcs
Geschrieben am: 31.10.2014 08:42:02

Hallo Marco,

lade mal eine Beispieldatei mit einem Teil der Daten hier hoch, personenbezogene Daten ggf. anonymisieren. Dann kann mal mit ein paar Funktionen Testen.

Gib in einem Blatt auch an, wie das Ergebnis in Tabelle1 aussehen soll.

Gruß
Franz


 

Beiträge aus den Excel-Beispielen zum Thema "SUMMENPRODUKT mit variablen Beding. aus Teilergeb."