Microsoft Excel

Herbers Excel/VBA-Archiv

exakte Zahl auslesen

Betrifft: exakte Zahl auslesen von: Gisela
Geschrieben am: 16.11.2014 10:40:42

Hallo, ich habe folgendes Problem:
Beispiel
in Zelle A20 steht das zu untersuchende Feld, C13 bezeichnet die zu suchende Zahl... mittels
=WENN($C$13="";0;ZÄHLENWENN(A20;"*"&$C$13&"*"))
versuche ich in B20 0 oder 1 auslesen zu lassen.
Wenn in A20 nun beispielsweise "924,678 (2),56" steht
und ich nach 24 suche gibt er mir trotzdem den Wert 1 aus, da er 924 auch als 24 interpretiert.
Wie kriege ich ihn dazu, dass er nur 24 als GANZE Zahl innerhalb einer Zelle richtig interpretiert, also nicht 246 oder 924? Er muss hierbei aber auch ,24, oder 24 (blank) als 24 erkennen, nur eben halt nicht andere Zahlen als exakt 24.
Danke!
Gisela

  

Betrifft: mittels WECHSEL() eien ... von: neopa C (paneo)
Geschrieben am: 16.11.2014 11:34:43

Hallo Gisela,


... die Du evtl. noch erweitern musst, wenn Du noch andere Trennzeichen als die bisherigen in den Zellen zu stehen hast. Übrigens ergibt meine Formel auch Deine eine eins wenn in A20 anstelle 924,678 (2),56 die Zeichenfolge 924,678 (24),56 steht. Ich ging davon aus, dass das so gewollt ist. Oder?

=ISTZAHL(FINDEN("!"&C$13&"!";WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(" "&A20&" ";" ";"!");",";"!");";";"!");"(";"!");")";"!")))+0

Gruß Werner
.. , - ...


  

Betrifft: AW: mittels WECHSEL() eien ... von: Gisela
Geschrieben am: 17.11.2014 12:57:40

Hallo Werner,

hat super geklappt, vielen Dank!
Noch eine kleine Frage: Wie kann ich den Suchbegriff mit Klammer vor und nach exkludieren?
Also beispielsweise Suchbegriff) oder (Suchbegriff ok, aber (Suchbegriff) halt nicht.

Beste Grüsse
Gisela


  

Betrifft: für mich momentan noch nicht eindeutig ... von: neopa C (paneo)
Geschrieben am: 17.11.2014 13:28:37

Hallo Gisela,

... zeig doch mal zwei/drei Beispiele auf, was genau jetzt Deine Zielstellung ist.

Gruß Werner
.. , - ...


  

Betrifft: Das könnte auch so aussehen, ... von: Luc:-?
Geschrieben am: 17.11.2014 18:52:21

…Gisela,
falls du das wirklich so meinst/beabsichtigst:

 ABCD
19Wert | Fmln →…lt Gisela…lt neopa…lt Luc
20924,678 (2),56100
2124,678 (2),57111
22924,678 (2),024100
2324,678 (2),245111
2424,678 (2),24112
25924,678 (2),245100
26924,678 (2),24111
27924,678 (24),56110
28924,678 24),57111
29924,678 (24,58111
Meine Formel (mit UDFs!) würde dann wie folgt lauten:
D20[:D29]:=SUMMENPRODUKT(--(Splint(MaskOn(WECHSELN(A20;"("&C$13&")";"");"num"))=""&C$13))
Wie du sicher bemerkst, ermittle ich so die Anzahl des Auftretens des SuchBegriffs im jeweiligen Wert (auch zwecks TestKontrolle). Das kannst du aber auch auf WAHR/FALSCH- bzw 1/0-Ausgabe ändern.
Gruß, Luc :-?


  

Betrifft: AW: exakte Zahl auslesen von: Gisela
Geschrieben am: 17.11.2014 20:46:55

Hallo Team,

ich habe bisher folgende Formel:
=ISTZAHL(FINDEN("!"&C$13&"!";WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(" "&A19&" ";" ";"!");","; "!");"/";"!");"(";"!");")";"!"))) +0
Wenn in C13 also bespielsweise 213 steht, findet er /213 ,213 ;213 (213 213) etc., aber leider auch (213): dies ist eine Mengenangabe, die nichts mit dem eigentlichen Suchbegriff zu tun hat und immer die gleiche Syntax aufweist. Da 213 ohne Klammern VORNE und DAHINTER aber auch ein Suchbegriff sein kann, muss ich das differenzieren.
(213) soll 0 geben
alle anderen, auch (213;...) (213,...) (...,213) etc. aber 1.
Ich hoffe ich habe mich jetzt verständlich ausgedrückt.

Beste Grüsse
Gisela


  

Betrifft: AW: exakte Zahl auslesen von: Gisela
Geschrieben am: 17.11.2014 20:53:32

hab vergessen, das Kontrollkästchen zu aktivieren:

Hallo Team,

ich habe bisher folgende Formel:
=ISTZAHL(FINDEN("!"&C$13&"!";WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(" "&A19&" ";" ";"!");","; "!");"/";"!");"(";"!");")";"!"))) +0
Wenn in C13 also bespielsweise 213 steht, findet er /213 ,213 ;213 (213 213) etc., aber leider auch (213): dies ist eine Mengenangabe, die nichts mit dem eigentlichen Suchbegriff zu tun hat und immer die gleiche Syntax aufweist. Da 213 ohne Klammern VORNE und DAHINTER aber auch ein Suchbegriff sein kann, muss ich das differenzieren.
(213) soll 0 geben
alle anderen, auch (213;...) (213,...) (...,213) etc. aber 1.
Ich hoffe ich habe mich jetzt verständlich ausgedrückt.

Beste Grüsse
Gisela


  

Betrifft: dann einfach die vorhandene Formel kürzen, denn... von: neopa C (paneo)
Geschrieben am: 18.11.2014 08:26:05

Hallo Gisela,

... so wie Du jetzt schreibst, kannst Du Dir zweier WECHSEL() sparen.

=ISTZAHL(FINDEN("!"&C$13&"!";WECHSELN(WECHSELN(WECHSELN(" "&A20&" ";" ";"!");",";"!");";";"!")))+0

Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "exakte Zahl auslesen"