Formel Suchen mit Sternchen

Bild

Betrifft: Formel Suchen mit Sternchen
von: Heinz
Geschrieben am: 03.06.2015 07:42:21

Guten Morgen Liebe Excellenten,
eine schnelle Frage am Morgen.
Ich versuche mit der Formel 'Suchen' festzustellen,
ob einen String in einer Zelle vorhanden ist.
Eigentlich ist nur 'ob' wichtig, an welcher Stelle ist egal.
In der Spalte A, Zelle A2, A3, A4 usw, steht z.B.
Whisky; Bier; Limo; Radler;
Bier;
Radler; Whisky; Bier;
LimoM
Das Suchwort steht z.B. in der ersten Zeile der Spalte B (also B1): Whisky
Mit Suchen("*Whisky*";A2;1) kann ich suchen lassen -> funkt
Aber kann ich auch den Suchtext zusammensetzen: Sinngemäß "*"&B1&"*"?
Ich freue mich auf Eure Lösungen.
Heinz

Bild

Betrifft: AW: Formel Suchen mit Sternchen
von: Hajo_Zi
Geschrieben am: 03.06.2015 08:00:22
hallo Heinz,
warum nicht nur "Whisky" das soll doch nur enthalten sein?


Bild

Betrifft: für SUCHEN(); Suchstring immer ohne Wildcards ...
von: der neopa C
Geschrieben am: 03.06.2015 08:26:57
Hallo Heinz,
... bei Nutzung z.B. der Funktion VERGLEICH() kannst Du =ISTZAHL(VERGLEICH("*"&B1&"*";A:A;)) einsetzen.
Weiteres dazu, sieh auch mal hier: http://www.online-excel.de/excel/singsel.php?f=154
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Formel Suchen mit Sternchen
von: UweD
Geschrieben am: 03.06.2015 08:44:41
Hallo

Tabelle1

 AB
1 Whisky
2Whisky; Bier; Limo; Radler;Wahr
3Bier; 
4Radler; Whisky; Bier;Wahr
5LimoM 

verwendete Formeln
Zelle Formel Bereich N/A
B2=WENNFEHLER(FINDEN($B$1;A2)>0;"")  
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.03 einschl. 64 Bit


Gruß UweD

Bild

Betrifft: AW: Formel Suchen mit Sternchen
von: Klexy
Geschrieben am: 03.06.2015 10:07:41
Die Sternchen sind in deinem Fall überflüssig, denn die Funktion SUCHEN bezieht sich immer auf einen Teilstring in einem anderen String (also Spalte A).
In deiner alten Formel kriegst du wegen den Sternchen als Ergebnis immmer 1. Wenn du aber die Sternchen weglässt, kriegst du in der 3. Zeile den Wert 9, weil der Whisky mit dem neunten Zeichen des durchsuchten Strings anfängt.
Die Formel für deinen Bedarf lautet also:

=Suchen($B$1;A2;1)

Um die hässlichen Fehlermeldungen bei den Zeilen ohne Whisky zu vermeiden, so:
=WENN(ISTFEHLER(SUCHEN($B$1;A2;1));"";SUCHEN($B$1;A2;1))

die ;1 am Ende der Suchfunktion kannst du in diesem Fall auch weglassen.

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formel Suchen mit Sternchen"