Dynamisches Diagramm nach Datumseingabe

Bild

Betrifft: Dynamisches Diagramm nach Datumseingabe
von: NicNac75
Geschrieben am: 19.08.2015 08:23:27

Hallo Excel-Cracks,
ich lege mir gerade an einer Herausforderung die Karten und komme so recht nicht weiter. Daher bitte ich um Eure Hilfe:
Ich würde gerne ein Diagramm erstellen, welches sich dynamisch anpasst. Die Grundidee mit Namensvergabe und Funktion BEREICHVERSCHIEBEN ist mir nach ein bisschen googlen grundsätzlich klar. Wenn es nur darum geht, das Diagramm bei neuen Werten in der Basisliste zu erweitern, klappt das auch gut.
Nun würde ich aber gerne dem Anwender meines Sheets ermöglichen, dass er ein Startdatum und ein Enddatum eingibt und das Diagramm dann nur den gewählten Zeitraum abbildet (die Basisdaten bestehen aus nach Datum zeilenweise abgelegten Daten).
Ich habe leider noch keine richtige Idee, wie ich die Formel im Namensmanager dazu richtig wähle (oder kann ich das auch direkt über BEREICHVERSCHIEBEN erreichen?).
Stehe auf dem Schlauch - hat jemand eine Idee für mich?
Vielen Dank vorab.

Bild

Betrifft: AW: Dynamisches Diagramm nach Datumseingabe
von: Matthias
Geschrieben am: 19.08.2015 14:50:12
Hallo NicNac
Prinzip:
Du erstellst mittels Formeln den deinen Bereich vom eingegebenen Startdatum bis Enddatum (Zelle der Formel beispielhaft "D1").
Rauskommen muss am Ende z.B. dieses Ergebnis: Tabelle1!A10:M30
Im Namens-Manager kannst du dann einen Bereich vergeben:

Name: BeispielnameXY
Bezieht sich auf: =INDIREKT(Tabelle2!$D$1)
Im Diagramm -> Daten auswählen -> Bearbeiten:

Reihenwert: ='Arbeitsmappenname.xlsm'!BeispielnameXY
Damit wären sowohl dein Bereich dynamisch angelegt, als auch dein Diagramm.
---------
Als Formeln für den ersten Schritt würde ich mit Vergleich arbeiten, etwa so:
ZelleA2: =VERGLEICH(Startdatum;$B$42:$B$407;0)+41

Von B42 bis B407 sind alle Basisdaten aufgelistet, deren Zeile möchte ich gern haben. Da ich aber nur die Position innherhalb der Matrix bekomme, muss ich noch +(Startzeiele der Matrix -1) rechnen.
Selbiges für das Enddatum.
Daraus mache ich dann meinen Bereich den ich für das Diagramm brauche:
ZelleD1 ="Tabelle1!B"&A2&":D"&B2
Ergebnis: "Tabelle1!B50:D85"

Ich weis es nicht die elganteste Lösung da ich kein Profi bin, aber sie hat mir bislang gute Dienste geleistet.
lg Matthias

Bild

Betrifft: AW: Dynamisches Diagramm nach Datumseingabe
von: NicNac75
Geschrieben am: 19.08.2015 15:16:54
Hallo Matthias,
danke, dass klingt einleuchtend. Die Lösung über INDIREKT und VERGLEICH hatte ich nicht auf dem Schirm. Werde auf diesem Weg mal weitertesten.
Danke für die Hilfestellung.
NicNac

Bild

Betrifft: AW: Dynamisches Diagramm nach Datumseingabe
von: NicNac75
Geschrieben am: 19.08.2015 17:01:27
Hallo Matthias,
funktioniert perfekt. Nochmals 1000 Dank!

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Dynamisches Diagramm nach Datumseingabe"