Microsoft Excel

Herbers Excel/VBA-Archiv

Zuordnung abhängig von Wochentag und Uhrzeit


Betrifft: Zuordnung abhängig von Wochentag und Uhrzeit von: florianpv
Geschrieben am: 25.10.2017 14:24:28

Liebes Excel-Forum,

ich brauche Eure Hilfe. Ich habe eine Spalte mit allen Tagen und Viertelstunden des Jahres 2018. In einer weiteren Spalte ist das jeweilige Datum als Wochentag hinterlegt und entsprechend mit 1 für Mo bis Fr bzw. 0 für Sa und So gekennzeichnet.

Ich brauche eine Funktion die über das Datum mit Uhrzeit in Spalte D aus den Spalten G und H die Wochentage ermittelt und in Spalte E mit einer 1 für Montag bis Freitag und Samstag sowie Sonntag mit einer 0 ausgibt. Allerdings soll auch an den Tagen Montag bis Freitag nur von 08:15 bis 20:00 eine 1 stehen und sonst auch eine 0.

In den Spalten A und B ein fertiges Beispiel: https://www.herber.de/bbs/user/117208.xlsx

Ich hoffe jemand kann mir helfen. Vielen vielen Dank!

LG Florian

  

Betrifft: AW: Zuordnung abhängig von Wochentag und Uhrzeit von: florianpv
Geschrieben am: 25.10.2017 15:29:08

Ich bin mittlerweile über eine Hilfsspalte schon weitergekommen. Ich bin jetzt soweit, dass neben den Tagen mit den Viertelstunden aus Spalte D in Spalte E schon jeweils eine 1 bzw. eine 0 für die Kennzeichnung des Wochentages steht.

Jetzt fehlt mir nur noch eine Funktion um die Einsen, die außerhalb von 08:15 bis 20:00 an den Tagen Montag bis Freitag stehen mit Nullen zu ersetzen.

Kann mir jemand weiterhelfen? Danke!

LG Florian


  

Betrifft: AW: nun dann dafür ... von: ... neopa C
Geschrieben am: 25.10.2017 15:37:06

Hallo flrian,

... nutze folgende Formel:

=((REST(D2;1)<"8:15"/"24:00")+(REST(D2;1)>5/6)=0)*(REST(D2;7)>1)
Gruß Werner
.. , - ...


  

Betrifft: AW: Zuordnung abhängig von Wochentag und Uhrzeit von: yummi
Geschrieben am: 25.10.2017 15:54:46

Hallo Florian,

probier mal, müsste ohne hilfszeile auskommen

=WENN(TAG(D1)<5;1;WENN(STUNDE(D1)<8;0;WENN(STUNDE(D1)=8;WENN(MINUTE(D1)>=15;1;0);WENN(STUNDE(D1) _
<=20;1;0))))

Gruß
yummi


  

Betrifft: AW: etwas verwirrend ... von: ... neopa C
Geschrieben am: 25.10.2017 15:33:55

Hallo Florian,

... Du schreibst: "Ich habe eine Spalte mit allen Tagen und Viertelstunden des Jahres 2018"
Warum sollen diese dann erst noch aus Deinem Datumslisting in Spalte G erzeugt werden?

Die ungewollten Zeitangaben kannst Du mit folgender Hilfsspaltenformel ermitteln:

=(REST(D2;1)<"8:15"/"24:00")+(REST(D2;1)>5/6) =0 
und Formel (mit Doppelklick auf die rechte untere Zellecke) nach unten kopieren. Dann den Autofilter für diese Spalte aktivieren und nach FALSCH filtern. Die so gefilterten Zeilen markieren und löschen. Autofilter wieder aufheben.

Die 1 für die Wochentage kannst Du nun in dieser Spalte mit folgender Formel ermitteln:
=(REST(D2;7)>1)*1

Gruß Werner
.. , - ...


Beiträge aus den Excel-Beispielen zum Thema "Zuordnung abhängig von Wochentag und Uhrzeit"