Microsoft Excel

Herbers Excel/VBA-Archiv

Summe Summenprodukt nur einmal


Betrifft: Summe Summenprodukt nur einmal von: Lisa
Geschrieben am: 01.10.2019 14:24:34

Guten Tag zusammen,
ich summiere mit zwei Kriterien mittels
=SUMMENPRODUKT((A2:A1000=A2)*(C2:C1000=C2);H2:H1000)

Ich kopiere die Formel die Zeilen nach unten.
Solange die Bedingungen passen, soll aber nur einmal das Ergebnis angezeigt werden.

Hat jemand eine Idee?

Liebe Grüße Lisa

  

Betrifft: AW: Summe Summenprodukt nur einmal von: ChrisL
Geschrieben am: 01.10.2019 14:30:03

Hi Lisa

=WENN(ZÄHLENWENNS(A$2:A2;A2;B$2:B2;B2)=1;SUMMEWENNS(H:H;A:A;A2;B:B;B2);"")

Anstelle Summewenns geht natürlich auch Summenprodukt.

cu
Chris


  

Betrifft: AW: Summe Summenprodukt nur einmal von: Lisa
Geschrieben am: 01.10.2019 14:34:24

Hallo Chris, vielen Dank klappt perfekt.

Liebe Grüße Lisa


  

Betrifft: Bitte um das Datenbeispiel von: Jean Gitanes
Geschrieben am: 01.10.2019 16:01:04

Hallo Lisa,

ich versuche seit geraumer Zeit die Lösung nach zu vollziehen.

Kannst Du bitte ein Datenbeispiel (erfundene Daten) anzeigen, das die Aufgabenstellung deutlich macht?

Gruß

Jean


  

Betrifft: AW: Bitte um das Datenbeispiel von: ChrisL
Geschrieben am: 01.10.2019 17:06:36

Hi Jean

Ich weiss nicht, ob Lisa hier noch einmal vorbei schaut.

Spalte H + I ergeben das gleiche Resultat, was ohne WENN(ZÄHLENWENN;;) nicht der Fall gewesen wäre.
https://www.herber.de/bbs/user/132315.xlsx

Im Prinzip hätte man auch eine "Daten-Gruppierung" (z.B. mit Pivot oder PowerQuery) machen können.

cu
Chris


  

Betrifft: AW: Danke von: Jean Gitanes
Geschrieben am: 01.10.2019 19:00:42

Hallo Chris,

vielen Dank für die Daten. Diese machen das Problem nun klar.
Ich danke Dir für Deine Hilfen.

Gruß
Jean


  

Betrifft: AW: ergänzend zu den Angaben von Chris ... von: neopa C
Geschrieben am: 01.10.2019 17:48:46

Hallo Jean,

... im vom Chris angegebenen Beispiel bedürfte es ZÄHLENWENNS() in der Formel nicht wirklich, weil seine Datenwerte in Spalte A und B sortiert sind. Dann reicht auch eine Formel wie z.B. untenstehend in K2.

ZÄHLENWENNS() in der Formel ist jedoch sinnvoll, wenn die Daten in Spalte A und B bzw. in untenstehenden Beispiel die Daten in Spalte A und C nicht nach diesen sortiert sind/wären (zuerst nach Spalte C, dann nach Spalte A), wenn man "doppelte" Ergebnisdarstellungen vermeiden will.

Allerdings eine Pivotauswertung würde auch ich einer derartigen Formelauswertung vorziehen, weil einfacher, unabhängig davon ob Sortierung vorliegt oder nicht und vor allem im Ergebnis übersicjhtlicher.

Arbeitsblatt mit dem Namen 'Tabelle1'
 ACHIJK
1Tex11Tex1_XWerte Erg_1Erg_2
2Text1_1Text_A1 2121
3Text1_1Text_A2   
4Text1_1Text_A3   
5Text1_1Text_A15   
6Text1_1Text_B4 4242
7Text1_1Text_B5   
8Text1_1Text_B16   
9Text1_1Text_B17   
10Text1_2Text_B6 1313
11Text1_2Text_B7   
12Text1_2Text_C8 1717
13Text1_2Text_C9   
14Text1_3Text_A12 1212
15Text1_3Text_B10 2121
16Text1_3Text_B11   
17Text1_4Text_A13 2727
18Text1_4Text_A14   
19      

ZelleFormel
J2=WENN(ZÄHLENWENNS(A$2:A2;A2;C$2:C2;C2)=1;SUMMEWENNS(H:H;A:A;A2;C:C;C2);"")
K2=WENN(A2&C2=A1&C1;"";SUMMEWENNS(H:H;A:A;A2;C:C;C2))
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Gruß Werner
.. , - ...


  

Betrifft: Vielen Dank.. von: Jean Gitanes
Geschrieben am: 01.10.2019 19:08:48

Hallo Werner,

mit den letzten beiden Beiträgen ist der Sachverhalt nun klar.
Vielen Dank für die Hilfen und die ergänzenden Formeln.

Gruß

Jean


  

Betrifft: AW: bitteschön owT von: neopa C
Geschrieben am: 02.10.2019 10:01:31

Gruß Werner
.. , - ...


Beiträge aus dem Excel-Forum zum Thema "Summe Summenprodukt nur einmal"