Microsoft Excel

Herbers Excel/VBA-Archiv

Dynamische Liste mit Text (Kürzel)

Betrifft: Dynamische Liste mit Text (Kürzel) von: suited9
Geschrieben am: 13.10.2020 10:02:37

Tag zusammen

Siehe Beispieldatei. https://www.herber.de/bbs/user/140849.xlsx

Basis-Sheet "nicht erledigt total" ist mehrere tausend Zeilen lang, und wird in der Zukunft noch etwas grösser (aktuell reicht bis 5000 locker).

Ziel ist es am Ende eine Formel einzutragen, welche im Sheet "nicht erledigt abc" die jeweiligen Standorte/Strassen lückenfrei ausweisen kann gemäss übereinstimmendem Kürzel aus dem Basis-Sheet.

Die Formel (das Kürzel) für weitere Sheets kann ich manuell anpassen.

Habe mit einigen AGGREGAT-Formeln rumprobiert, bin jedoch nicht wirklich erfolgreich gewesen.

Danke für jegliche Hilfe & Gruss

Betrifft: AW: Dynamische Liste mit Text (Kürzel)
von: SF
Geschrieben am: 13.10.2020 10:22:36

Hola,

=WENNFEHLER(INDEX('nicht erledigt total'!B:B;AGGREGAT(15;6;ZEILE('nicht erledigt total'!$B$2:$B$5000) /('nicht erledigt total'!$A$2:$A$5000="abc");ZEILE(A1)));"")

Gruß,
steve1da

Betrifft: AW: Dynamische Liste mit Text (Kürzel)
von: suited9
Geschrieben am: 13.10.2020 10:38:10

Funktioniert genau so wie erwartet, besten Dank!