Spalten vergleichen

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
Bild

Betrifft: Spalten vergleichen
von: Helmut
Geschrieben am: 21.09.2003 20:06:59

Ich möchte in einem Arbeitsblatt in zwei Spalten (A+B) mir Zahlenkolonnen einkopieren und feststellen, welche Zahlen aus Spalte A nicht in Spalte B enthalten sind und diese in Spalte C darstellen.
Ich habe keine Kenntnisse, wie ich das bewältigen kann.
Vielleicht kann mir jemand einen Ansatz mitteilen.
Vielen Dank im Voraus.
Helmchen

Bild


Betrifft: AW: Spalten vergleichen
von: Ramses
Geschrieben am: 21.09.2003 20:32:41

Hallo

vielleicht hilft das ja schon mal

Tabelle1
 ABC
1aa 
2bb 
3cc 
4ded
5ea 
6ff 
7gg 
8hgh
Formeln der Tabelle
C1 : =WENN(ZÄHLENWENN($B$1:$B$8;A1)>0;"";A1)
C2 : =WENN(ZÄHLENWENN($B$1:$B$8;A2)>0;"";A2)
C3 : =WENN(ZÄHLENWENN($B$1:$B$8;A3)>0;"";A3)
C4 : =WENN(ZÄHLENWENN($B$1:$B$8;A4)>0;"";A4)
C5 : =WENN(ZÄHLENWENN($B$1:$B$8;A5)>0;"";A5)
C6 : =WENN(ZÄHLENWENN($B$1:$B$8;A6)>0;"";A6)
C7 : =WENN(ZÄHLENWENN($B$1:$B$8;A7)>0;"";A7)
C8 : =WENN(ZÄHLENWENN($B$1:$B$8;A8)>0;"";A8)
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
Gruss Rainer

Bild


Betrifft: AW: Spalten vergleichen
von: Beni
Geschrieben am: 21.09.2003 20:37:27

Hallo Helmut,
lasse dieses Makro laufen und werden die Werte die in B nicht enthalten sind in C dargestellt.
Gruss Beni


Sub Spalten_vergleichen()
intLastRow = Cells(Rows.Count, 1).End(xlUp).Row
For i = 1 To intLastRow
    Wert = i
    Dim lRow As Long
 lRow = Cells(Rows.Count, 3).End(xlUp).Row + 1
Set C = Columns(2).Find(Wert, LookIn:=xlValues, LookAt:=xlWhole)
If C Is Nothing Then Cells(lRow, 3).Value = Wert
Next i
End Sub



Bild


Betrifft: AW: Spalten vergleichen
von: Ramses
Geschrieben am: 21.09.2003 20:43:15

Hallo

müsste es nicht heissen

Wert = Cells(i,1)

Sonst suchst du doch nur die Werte von 1 bis intLastRow,... aber nicht die Werte aus Spalte A

Gruss Rainer


Bild


Betrifft: AW: Spalten vergleichen
von: Beni
Geschrieben am: 21.09.2003 20:53:19

Hallo Rainer,
kann man, muss aber nicht, weil ich bei intLastRow schon auf 1 hinweise.
Gruss Beni

intLastRow = Cells(Rows.Count, 1).End(xlUp).Row


Bild


Betrifft: AW: Spalten vergleichen
von: Ramses
Geschrieben am: 21.09.2003 21:02:45

Hallo

das meine ich ja:

Wenn in Zelle A1 z.B. "1263" steht, dann suchst du ja explicit nach dem Wert der Varibalen "i" (Beginn der Schleife:

For i = 1 to intLastRow
Wert = i
...
Set C = Columns(2).Find(Wert, LookIn:=xlValues, LookAt:=xlWhole)


und nicht nach dem tatsächlichen Inhalt von A1.


Gruss Rainer


Bild


Betrifft: AW: Rainer, du hast recht
von: Beni
Geschrieben am: 21.09.2003 21:45:51

Hallo Rainer,
Du hast recht, ich bin darüber gestoppert, weil der Wert der ZeilenNr entsprach.
Danke für den Tip
Gruss Beni


Bild


Betrifft: AW: Spalten vergleichen
von: Josef Ehrensberger
Geschrieben am: 21.09.2003 20:48:49

Hallo Helmut,

als Formellösung könntest du als Formel in "C1"

=WENN(ISTFEHLER(VERGLEICH(B1;$A$1:$A$100;0));"";B1)

versuchen.

Formel in "C1" schreiben und nach unten ausfüllen.

Gruß Sepp


Bild


Betrifft: =WENN(ISTFEHLER(VERGLEICH(B1;$A$1:$A$100;0));B1;""
von: Josef Ehrensberger
Geschrieben am: 21.09.2003 21:02:48

Sorry falsche formel kopiert!

=WENN(ISTFEHLER(VERGLEICH(B1;$A$1:$A$100;0));B1;"")

Gruß Sepp


Bild


Betrifft: Bedingte Formatierung
von: Josef Ehrensberger
Geschrieben am: 21.09.2003 21:09:52

Hallo nochmal,

du könntest die Zahlen in Spalte "B" auch durch
Bedingte Formatierung kennzeichnen.

Formel: =ISTFEHLER(VERGLEICH(B1;$A$1:$A$100;0))

Gruß Sepp


Bild


Betrifft: AW: Spalten vergleichen
von: Franz Pölt
Geschrieben am: 21.09.2003 22:11:55

Hallo Helmut,

wahr es vielleicht das, was du wolltest :-)

Excel Jeanie HTML
Formeln der Tabelle
C1 : {=WENN(ZEILE()>ANZAHL2(B$1:B$10);0;KKLEINSTE(WENN(ISTZAHL(VERGLEICH(A$1:A$10;B$1:B$10;0)*1);999;A$1:A$10);ZEILE()))}
C2 : {=WENN(ZEILE()>ANZAHL2(B$1:B$10);0;KKLEINSTE(WENN(ISTZAHL(VERGLEICH(A$1:A$10;B$1:B$10;0)*1);999;A$1:A$10);ZEILE()))}
C3 : {=WENN(ZEILE()>ANZAHL2(B$1:B$10);0;KKLEINSTE(WENN(ISTZAHL(VERGLEICH(A$1:A$10;B$1:B$10;0)*1);999;A$1:A$10);ZEILE()))}
C4 : {=WENN(ZEILE()>ANZAHL2(B$1:B$10);0;KKLEINSTE(WENN(ISTZAHL(VERGLEICH(A$1:A$10;B$1:B$10;0)*1);999;A$1:A$10);ZEILE()))}
C5 : {=WENN(ZEILE()>ANZAHL2(B$1:B$10);0;KKLEINSTE(WENN(ISTZAHL(VERGLEICH(A$1:A$10;B$1:B$10;0)*1);999;A$1:A$10);ZEILE()))}
C6 : {=WENN(ZEILE()>ANZAHL2(B$1:B$10);0;KKLEINSTE(WENN(ISTZAHL(VERGLEICH(A$1:A$10;B$1:B$10;0)*1);999;A$1:A$10);ZEILE()))}
C7 : {=WENN(ZEILE()>ANZAHL2(B$1:B$10);0;KKLEINSTE(WENN(ISTZAHL(VERGLEICH(A$1:A$10;B$1:B$10;0)*1);999;A$1:A$10);ZEILE()))}
C8 : {=WENN(ZEILE()>ANZAHL2(B$1:B$10);0;KKLEINSTE(WENN(ISTZAHL(VERGLEICH(A$1:A$10;B$1:B$10;0)*1);999;A$1:A$10);ZEILE()))}
C9 : {=WENN(ZEILE()>ANZAHL2(B$1:B$10);0;KKLEINSTE(WENN(ISTZAHL(VERGLEICH(A$1:A$10;B$1:B$10;0)*1);999;A$1:A$10);ZEILE()))}
C10 : {=WENN(ZEILE()>ANZAHL2(B$1:B$10);0;KKLEINSTE(WENN(ISTZAHL(VERGLEICH(A$1:A$10;B$1:B$10;0)*1);999;A$1:A$10);ZEILE()))}
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download   Servus aus dem Salzkammergut Franz

 Bild

Beiträge aus den Excel-Beispielen zum Thema " Spalten vergleichen"