Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
312to316
312to316
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Spalten vergleichen

Spalten vergleichen
21.09.2003 20:06:59
Helmut
Ich möchte in einem Arbeitsblatt in zwei Spalten (A+B) mir Zahlenkolonnen einkopieren und feststellen, welche Zahlen aus Spalte A nicht in Spalte B enthalten sind und diese in Spalte C darstellen.
Ich habe keine Kenntnisse, wie ich das bewältigen kann.
Vielleicht kann mir jemand einen Ansatz mitteilen.
Vielen Dank im Voraus.
Helmchen

10
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Spalten vergleichen
21.09.2003 20:32:41
Ramses
Hallo

vielleicht hilft das ja schon mal

AW: Spalten vergleichen
21.09.2003 20:37:27
Beni
Hallo Helmut,
lasse dieses Makro laufen und werden die Werte die in B nicht enthalten sind in C dargestellt.
Gruss Beni


Sub Spalten_vergleichen()
intLastRow = Cells(Rows.Count, 1).End(xlUp).Row
For i = 1 To intLastRow
Wert = i
Dim lRow As Long
lRow = Cells(Rows.Count, 3).End(xlUp).Row + 1
Set C = Columns(2).Find(Wert, LookIn:=xlValues, LookAt:=xlWhole)
If C Is Nothing Then Cells(lRow, 3).Value = Wert
Next i
End Sub

AW: Spalten vergleichen
21.09.2003 20:43:15
Ramses
Hallo

müsste es nicht heissen

Wert = Cells(i,1)

Sonst suchst du doch nur die Werte von 1 bis intLastRow,... aber nicht die Werte aus Spalte A

Gruss Rainer
Anzeige
AW: Spalten vergleichen
21.09.2003 20:53:19
Beni
Hallo Rainer,
kann man, muss aber nicht, weil ich bei intLastRow schon auf 1 hinweise.
Gruss Beni

intLastRow = Cells(Rows.Count, 1).End(xlUp).Row
AW: Spalten vergleichen
21.09.2003 21:02:45
Ramses
Hallo

das meine ich ja:

Wenn in Zelle A1 z.B. "1263" steht, dann suchst du ja explicit nach dem Wert der Varibalen "i" (Beginn der Schleife:

For i = 1 to intLastRow
Wert = i
...
Set C = Columns(2).Find(Wert, LookIn:=xlValues, LookAt:=xlWhole)

und nicht nach dem tatsächlichen Inhalt von A1.

Gruss Rainer
AW: Rainer, du hast recht
21.09.2003 21:45:51
Beni
Hallo Rainer,
Du hast recht, ich bin darüber gestoppert, weil der Wert der ZeilenNr entsprach.
Danke für den Tip
Gruss Beni
Anzeige
AW: Spalten vergleichen
21.09.2003 20:48:49
Josef Ehrensberger
Hallo Helmut,

als Formellösung könntest du als Formel in "C1"

=WENN(ISTFEHLER(VERGLEICH(B1;$A$1:$A$100;0));"";B1)

versuchen.

Formel in "C1" schreiben und nach unten ausfüllen.

Gruß Sepp
=WENN(ISTFEHLER(VERGLEICH(B1;$A$1:$A$100;0));B1;""
21.09.2003 21:02:48
Josef Ehrensberger
Sorry falsche formel kopiert!

=WENN(ISTFEHLER(VERGLEICH(B1;$A$1:$A$100;0));B1;"")

Gruß Sepp
Bedingte Formatierung
21.09.2003 21:09:52
Josef Ehrensberger
Hallo nochmal,

du könntest die Zahlen in Spalte "B" auch durch
Bedingte Formatierung kennzeichnen.

Formel: =ISTFEHLER(VERGLEICH(B1;$A$1:$A$100;0))

Gruß Sepp
AW: Spalten vergleichen
21.09.2003 22:11:55
Franz Pölt
Hallo Helmut,

wahr es vielleicht das, was du wolltest :-)

Excel Jeanie HTML
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige