Herbers Excel-Forum - das Archiv

Uhrzeitabfrage

Bild

Betrifft: Uhrzeitabfrage
von: Torben
Geschrieben am: 29.09.2003 23:59:57
Hallo ich habe ein kleines Problem und habe mittlerweile schon gigantische Formeln erstellt, bin bis jetzt aber noch zu keiner lösung gekommen.

Und zwar wird mit einer Excel Tabelle Tag und Nacht gearbeitet. In eine Zelle soll ein Datum geschrieben werden, das abhängig ist, ob es vor oder nach 0 Uhr dort steht, das bedeutet. Wenn es z.B. 01.10.03 22:59 ist, dann soll Excel auf das Datum das in der Zelle ausgegeben wird 2 Tage dazurechnen, wenn es aber der 02.10.03 00:34 ist, dann soll excel nur 1 Tag dazurechnen. Das ganze soll ab 18 Uhr und bis 8 Uhr funktionieren.

Es wär toll, wenn mir jemand helfen könnte

Gruß Torben

Bild

Betrifft: AW: Uhrzeitabfrage
von: PeterW
Geschrieben am: 30.09.2003 00:29:24
Hallo Torben,

da wirst du mit Formeln nicht zum Erfolg kommen. Falls du mit einer VBA-Lösung leben kannst (und nur so ist mas m.E. lösbar) wären genauere Informationen nötig. Wo wird was wie eingegeben? Am einfachsten wäre es mit einer Beispieltabelle.

Gruß
Peter
Bild

Betrifft: AW: Uhrzeitabfrage
von: Björn B.
Geschrieben am: 30.09.2003 00:43:44
Hallo Torben,

angenommen in Zelle A1 steht =JETZT(), dann lautet die entsprechende Formel in Zelle A2
=WENN(STUNDE(A1)>=18;A1+2;WENN(STUNDE(A1)<8;A1+1;"")). Das Ergebnis zwischen 8 und 18 Uhr ist "", also bislang nicht vorhanden. Du kannst ggf. die "" durch eine weitere Formel ersetzen, falls ein Wert ausgegeben werden soll.

Hilft Dir das weiter?

Gruß
Björn
Bild

Betrifft: AW: Uhrzeitabfrage
von: PeterW
Geschrieben am: 30.09.2003 00:47:40
Hallo Björn,

bin nicht der Fachmann für Formeln aber wird Jetzt() nicht bei jeder Berechnung in der Tabelle neu berechnet?

Gruß
Peter
Bild

Betrifft: AW: Uhrzeitabfrage
von: Torben
Geschrieben am: 30.09.2003 08:45:45
Schönen Dank! Mein Problem scheint gelöst!
Bild

Betrifft: @Peter und @Torben
von: Björn B.
Geschrieben am: 30.09.2003 20:11:07
@Peter,

ja da hast Du recht, Jetzt() ist halt immer "Jetzt", sobald Excel neu berechnet.


@Torben,

gern geschehen und danke für die Rückmeldung.

Gruß
Björn
 Bild