Fehlerzelle finden

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
MsgBox
Bild

Betrifft: Fehlerzelle finden
von: Martin
Geschrieben am: 19.11.2003 12:27:26

Hallo zusammen

könnt ihr mir weiterhelfen. Ich habe eine Tabelle mit 5 Spalten. In jeder Zelle der Tabelle steht entweder A, B oder R. Der Buchstaben "A" darf in einer Zeile nur einmal geschrieben sein. Das möchte ich nun mit einem Makro überprüfen. Die Lösung, die ich gefunden habe, ist:

Cells.Find(What:="A").Activate
a1: If ActiveCell.Interior.ColorIndex = 3 Then
GoTo a2
Else
With Selection.Interior
.ColorIndex = 3
.Pattern = xlSolid
.PatternColorIndex = xlAutomatic
End With
End If
Cells.FindNext(After:=ActiveCell).Activate
GoTo a1
a2: MsgBox "Fertig"
End Sub

Mit diesem Makro war ich aber gezwungen, die Tabelle abzusuchen, ob in einer Zeile mehr als eine Zelle eingefärbt war. Ich möchte aber lieber ein Makro, das mir nur die Zeile einfärbt, in der mehr als ein "A" vorkommt.

Bild


Betrifft: bedingte Formatierung
von: ChrisL
Geschrieben am: 19.11.2003 12:36:53

Hi Martin

Sowas geht relativ einfach über Format/bedingte Formatierung.

A1:D1 markieren
Formel ist:
=COUNTIF($A1:$D1,"A")>1
=ZÄHLENWENN($A1:$D1;"A")>1

Zellen runterziehen.

Siehe Anhang.
https://www.herber.de/bbs/user/2024.xls

Gruss
Chris


Bild


Betrifft: AW: bedingte Formatierung
von: Martin
Geschrieben am: 19.11.2003 12:52:45

Ah, so einfach. Herzlichen Dank.
Martin


Bild

Beiträge aus den Excel-Beispielen zum Thema " Fehlerzelle finden"