Fomeln in Macros

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
Bild

Betrifft: Fomeln in Macros
von: Michael
Geschrieben am: 21.11.2003 12:16:07

Hallo,

ich hab wieder mal ein kleines Problem, in meinem Code soll eine Formel ausgeführt werden, wie muss die Aussehen?
Der Recorder ist da leider auch keine grosse Hilfe


Private Sub CommandButton1_Click()
Range("B3").Select
    ActiveCell.FormulaR1C1 = "Brutto"
    Range("B4").Select
    ActiveCell.FormulaR1C1 = "=WENN(E21="";"";E21*116%)"
    Selection.AutoFill Destination:=Range("B4:B30"), Type:=xlFillDefault
    Range("B4:B30").Select
End Sub


bei FomulaR1C1 soll die Formel ausgeführt werden

Gruss aus München
Bild


Betrifft: AW: Fomeln in Macros
von: Nayus
Geschrieben am: 21.11.2003 12:39:33

Hi,
Nachfolgend das korrigierte Makro.
Achtung: Du benutzt relative Bezüge, das heißt Deine Zelle, die Du vergleichst,
ändert sich beim Kopieren. Weiß' nicht, ob Du das so willst.


Private Sub CommandButton1_Click()
    Range("B3").Select
    ActiveCell.FormulaR1C1 = "Brutto"
    Range("B4").Select
    ActiveCell.FormulaR1C1 = "=WENN(R[17]C[3]="""","""",R[17]C[3]*116%)"
    Range("B4").Select
    Selection.AutoFill Destination:=Range("B4:B30"), Type:=xlFillDefault
    Range("B4:B30").Select
End Sub


Gruß,
Nayus


Bild


Betrifft: AW: Formeln in Macros nachhaken ?
von: Michael
Geschrieben am: 21.11.2003 13:58:59

Hallo,

wie kommt es zu diesen Zellbezeichnungen

(R[17]C[3]
für E21, kann ich irgendwie nicht nachvollziehen, meine Formeln sind leider nicht ganz so einfach, es kommen noch mehrere Zellbezüge, auch absolut, darin vor. Daher müsste ich mir die Umsetzung der Zelladressen verdeutlichen.

Gruss


Bild


Betrifft: AW: Fomeln in Macros
von: Willie
Geschrieben am: 21.11.2003 12:41:42

Hallo Michael
Hier einwenig abgeändert dein Marko
Gruß Willie aus BaWü


Private Sub CommandButton1_Click()
    Cells(3, 2).Value = "Brutto"
   
    If Cells(21, 5).Value <> "" Then
    Cells(4, 2).Value = CDbl(Cells(21, 5)) * 1.16
    End If
    'Hier geht es mit deinem AutoFill weiter.....
End Sub



Bild


Betrifft: AW: Fomeln in Macros
von: Michael
Geschrieben am: 21.11.2003 14:17:43

Hallo Willi,

kannst Du mir diese Formel nochmal übersetzen

=WENN(E21="";"";E21*($G$12+100)%)

leider sind die Formeln nicht ganz so einfach, ich muss die Eingabe von Formeln in Makros verstehen lernen. In weiteren Formeln kommen noch mehr Zellbezüge auch absolute drin vor.

Gruss


Bild


Betrifft: AW: Fomeln in Macros
von: Willie
Geschrieben am: 21.11.2003 21:00:12

Hallo Michael ich war ne weile weg! Hier kommt der Rest übersetzt hoffe ich habe
dir geholfen! Gruß Willie


Sub hilfMichael()
    'Cells(3, 2).Value = "Brutto"
   
    If Cells(21, 5).Value <> "" Then
    Cells(12, 7).Value = (CDbl(Cells(21, 5)) + 100)/100
    End If
    'Hier geht es mit deinem AutoFill weiter.....
End Sub



Bild


Betrifft: AW: Fomeln in Macros
von: Michael
Geschrieben am: 21.11.2003 13:18:25

Hallo,

werde beide Varianten mal ausprobieren, das ich keine festen Bezüge habe ist gewollt, denn in Spalte E sollen Werte eingegeben werden und die Ergebnisse der Formel sollen in Spalte B erscheinen.
Da es aber für die Werte die sich in Spalte B ergeben sollen, verschiedene Formeln gibt,
zB. Brutto nach Netto, Brutto - Skonto, sollen die entsprechenden Formeln durch das Makro ausgefüllt werden, will heissen 4 Makros mit CommandButton für 4 verschiedene Rechenoperationen.

Gruss



Bild

Beiträge aus den Excel-Beispielen zum Thema " Zelleninhalt splitten in Spalte mit leeren Zellen"