Microsoft Excel

Herbers Excel/VBA-Archiv

summe trotz #NV einträgen

Betrifft: summe trotz #NV einträgen von: alexander
Geschrieben am: 24.08.2004 22:03:15

wie kann ich eine spalte addieren in der auch #NV erhalten sind (als ergebnis einer sverweis(...;0)funktion )?
das liebste wäre mir, dass er statt #NV eine 0 als ergebnis der nicht vergebenen sverweisfunktion bringt ...
bitte keine vba lösungen ...
1000 dank!

  


Betrifft: AW: summe trotz #NV einträgen von: andreas e
Geschrieben am: 24.08.2004 22:06:15

Hallo,

das o statt NV im sverweis kannst folgendermassen machen:

=wenn(istfehler(DeinSverweis);0;DeinSverweis)

summe ohne Fehlerwerte geht auch:

für summe des Bereichs A1 : B3 zB so:

B6 : {=SUMME(WENN(ISTZAHL(A1:B3);A1:B3))}

Enthält Matrixformel:
Umrandende { } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!

gruß
andreas e
http://www.skripteundaufgaben.de


  


Betrifft: AW: summe trotz #NV einträgen von: Boris
Geschrieben am: 24.08.2004 22:47:39

Hi Andreas,

wenn sich mal aus irgendeinem Grund die #NV nicht vermeiden lassen sollten, dann kann man die Summe auch ohne Arrayformel berechnen (im Beispiel aus den Spalte A und B):

=SUMMEWENN(A:B;"<1E+307")

Ignoriert werden auch alle anderen Fehlerwerte (wie z.B. #WERT!, #DIV/0! etc.)

Grüße Boris


  


Betrifft: danke Boris wieder was gelernt ! oT von: andreas e
Geschrieben am: 24.08.2004 22:53:44




  


Betrifft: offtopic *g* von: ExceL
Geschrieben am: 24.08.2004 22:57:21

Hi Boris

bezogen auf deine Postings
"Buchtipps für VBA (Excel bzw. Office)"

Das beste Excel-Buch auf dem Markt, 24. Juni 2004
Rezensentin/Rezensent: Rezensentin/Rezensent aus Esslingen
Das MS Excel 2003, Formeln und Funktionen ist ein sehr gutes Buch, dass
ich bei meiner täglichen Arbeit mit Excel anwenden kann um erfolgreich
Funktionen von Excel zu anzuwenden. Besonders der Aufbau des Buches hat
mich begeistert, da ich es optimal als Nachschlagewerk verwenden kann.
Auch inhaltlich hat mich das Buch überzeugt. Die Formeln und Funktionen sind durch
Beispiele ergänzt,sodass auch Einsteiger sehr gut mit diesem Buch
zurecht kommen können. Die beigefügte CD hilft mir um die Formeln bei
meiner täglichen Arbeit anzuwenden. Das Buch habe ich auch einige Kollegen
als sehr empfehlenswert empfohlen. Die waren beim Lesen total begeistert. Das Preis-Leistungsverhältnis ist
einsame spitze und der Lerneffekt ist groß, da das Buch
ausschließlich auf Formeln und Funktionen eingeht Da ich geschäftlich
viel mit Makros zu tun habe, kann ich auch das EXCEL-VBA-Kompendium von
Herrn Held empfehlen. Die beiden Bücher haben mein vorhandenes Excel-Wissen
erweitert und mich zum Excel-Profi gemacht.
Kaufempfehlung: Für Excel gibt es kein besseres Buch auf den Markt!!

Viel Spaß beim Lernen!

*g*

Gruß
Christian


  


Betrifft: Woher stammt dieses Märchen...??????? von: Boris
Geschrieben am: 24.08.2004 23:02:38

Hi Chris,

...denn von den Gebrüdern Grimm kenn ich das nicht...?!?

Grüße Boris


  


Betrifft: AW: Woher stammt dieses Märchen...??????? von: ExceL
Geschrieben am: 24.08.2004 23:07:12

*LOL*

da gibt es noch ein paar Lobgesänge

http://www.amazon.de/exec/obidos/ASIN/3826681274/ref=ase_heldoffice-21/028-9311724-9350931

hmmm

werde ich jetzt eigentlich prozentual beteiligt
bei dieser werbung
für BH

Gruß
Christian


  


Betrifft: Der Link geht nicht...:-((((( oT von: Boris
Geschrieben am: 24.08.2004 23:08:22




  


Betrifft: willst du nicht das er geht :-))))))))__ot von: ExceL
Geschrieben am: 24.08.2004 23:12:25




  


Betrifft: AW: Der Link geht nicht...:-((((( oT von: P@ulchen
Geschrieben am: 24.08.2004 23:13:19

bei mir schon...vielleicht sperrt ja Deine Firewall automatisch alles, was B.H. betrifft ;-))) ???



Gruß aus Leipzig
P@ulchen


  


Betrifft: *lol* von: ExceL
Geschrieben am: 24.08.2004 23:14:45

hier

versuch
das
http://www.amazon.de/exec/obidos/ASIN/3826681274/028-9311724-9350931


  


Betrifft: Das ist in der Tat so... von: Boris
Geschrieben am: 25.08.2004 00:07:53

Hi P@ulchen, hi Chris,

der Link führt bei mir immer zu nem Error: kann die Seite nicht laden...
Scheint tatsächlich am Link-Inhalt zu liegen...;-)

Grüße Boris


  


Betrifft: AW: summe trotz #NV einträgen von: alexander
Geschrieben am: 24.08.2004 22:11:41

supppper - 1000 dank an andreas !!!!!!!!!!!!!!!!!!