Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema TextBox
BildScreenshot zu TextBox TextBox-Seite mit Beispielarbeitsmappe aufrufen

bedingte Formatierung auf Hyperlink anwenden

Betrifft: bedingte Formatierung auf Hyperlink anwenden von: Ines
Geschrieben am: 30.08.2004 12:36:43

Ich möchte einen Hyperlink nur dann sichtbar machen, wenn in A1 ein gewisser Text steht, ansonsten soll der Hyperlink einfach in weißer Schrift geschrieben sein, und somit nicht sichtbar sein.

Doch irgendwie haut das nicht hin.

Hatte jemand schon ähnliches Problem, das er dann gelöst hat?

LG
Ines

  


Betrifft: AW: bedingte Formatierung auf Hyperlink anwenden von: Boris
Geschrieben am: 30.08.2004 12:55:43

Hi Ines,

Zelle mit dem Hyperlink markieren, Bedingte Formatierung - Formel ist:
=A1<>"gewisser Text"
und Schriftfarbe weiss.

Allerdings bleibt der Hyperlink dennoch aktiv - daher würde ich es über die Funktion HYPERLINK() lösen:

=WENN(A1<>"gewisser Text";"";HYPERLINK("http://www.xlforum.herber.de";"Klick"))

Grüße Boris

P.S.: Dass die Formel hier als Hyperlink "erkannt" wird, liegt an der Forumssoftware und lässt sich wohl auch leider nicht maskieren. Also: Nicht irritieren lassen.


 

Beiträge aus den Excel-Beispielen zum Thema "bedingte Formatierung auf Hyperlink anwenden"