Microsoft Excel

Herbers Excel/VBA-Archiv

Handelt es sich um eine Zahl?

Betrifft: Handelt es sich um eine Zahl? von: Martin Krams
Geschrieben am: 31.08.2004 17:08:30

Hallo,

ich möchte gerne Überprüfen ob eine bestimmte Zelle eine Zahl ist oder nicht.


=WENN(B1=Zahl;"Keine Zahl";"Eine Zahl")


Da muss es doch ne einfache Möglichkeit geben?

Martin

  


Betrifft: AW: Handelt es sich um eine Zahl? von: Wolfgang
Geschrieben am: 31.08.2004 17:14:50

Hi Martin,

Also deine Formel geht bei mir nicht, höchstens so:

=WENN(ISTZAHL(A1);"ZAHL";"Keine ZAHL")

was soll man da noch einfacher machen können ?

Gruß
Wolfgang


  


Betrifft: AW: Handelt es sich um eine Zahl? von: Reinhard
Geschrieben am: 31.08.2004 17:18:47

Hi Martin,
=WENN(ISTZAHL(A1);"Eine Zahl";"Keine Zahl")
oder auch (*g Boris)
=GROSS2(RECHTS("keine Zahl";10-ISTZAHL(A1)))
Gruß
Reinhard


  


Betrifft: oder so von: Reinhard
Geschrieben am: 31.08.2004 17:22:21

=LINKS("K";1-ISTZAHL(A1))&"eine zahl"
Gruß
Reinhard


  


Betrifft: Sehr schön...;-)) von: Boris
Geschrieben am: 31.08.2004 17:29:08

Hi Reinhard,

und nochmal 2 Zeichen weniger ;-)
=TEIL("Keine Zahl";1+ANZAHL(A1);99)

Grüße Boris


  


Betrifft: AW: Sehr schön...;-)) von: Reinhard
Geschrieben am: 31.08.2004 17:58:21

Hallo Boris,
=TEIL("Keine Zahl";1+ANZAHL(A1);99)
=WAHL(TYP(A1);"";"K")&"eine zahl"
*gg schon klar was kommt, A1 besteht immer aus Matrix, Fehlerwet und sowas...
Mir egal, Hauptsache kürzer :-)
Gruß
Reinhard


  


Betrifft: Wär doch gelacht... von: Boris
Geschrieben am: 31.08.2004 18:50:05

Hi Reinhard,

...wenn man das nicht noch um 2 Zeichen verkürzen könnte ;-))

=RECHTS("Keine Zahl";8+TYP(A1))

Liefert sogar bei Fehlerwerten ein korrektes Ergebnis. Ausgenommen bleibt die LEERE Zelle...

Grüße Boris


  


Betrifft: AW: Wär doch gelacht... von: P@ulchen
Geschrieben am: 31.08.2004 22:07:59

Martin traut sich wahrscheinlich gar nicht mehr, was zu sagen... ;-))



Gruß aus Leipzig
P@ulchen


  


Betrifft: AW: Wär doch gelacht... von: ypsilon
Geschrieben am: 31.08.2004 22:11:48

...ich würde es ja noch wesentlich kürzer hinbekommen *grins*
allerdings gäbe es dann ein paar zeilen code mehr :-(
cu Micha


  


Betrifft: AW: Wär doch gelacht... von: Reinhard
Geschrieben am: 31.08.2004 23:34:45

Hi Paulchen,
ups, Martin? *grübel* wer war denn das, egal *g ich finde mich Klasse dass ich gegen Boris Becker sehr übertrieben gesehen mal nen Satz gewonnene habe :-))
Dass dann, als er als er aus der Wäschekammer wiederkam, sein AOL abschaltete und sich auf mich konzentrierte, mir die Bälle das Toupet vom Kopf rissen und ich nur noch 0:7 O.7 Sätze hatte war klar.
Ich war mal als Schüler bei TGS Rödelheim in der Tischtennisabteilung, damals spielten sie Bundesliga, einmal war einmal einer der Bundesligaleute auch da und spielte mit mir, und, ich gewann *noch immer freu*
Klar, hätte er sich sich konzentriert hätte ich null Chance gehabt, (naja zu Null nicht, hab auch meinen Stolz, so 5 Punkte hätte ich mir gemopst) aber egal, ich darf wahrheitsgemäß sagen, schon als Schüler habe ich Bundesligaspieler im Tischtennis bezwungen *kicher*
Ansonsten ist es einfach so, mein Level ist so dass ich Kleinigkeiten schon per vba erledigen kann, aber Formeln, grad Arrayformeln von Boris, ich lese da die Frage, mir absolut unklar wie man das mit Formeln lösen könnte, meistens mit vba wüßte ich Wege, dann kommt Boris mit ner Lösung die klappt, mich aber immer ne halbe stunde kostet, die Lösung zu kapieren.
Auf so eine Lösung zu kommen, sehe ich bei mir in den nächsten 3 Jahren für ausgeschlossen.
Lieben Gruß nach Leipzich *g
Reinhard


  


Betrifft: AW: Wär doch gelacht... von: P@ulchen
Geschrieben am: 01.09.2004 07:37:27

Hi Reinhard,

mir geht es so ähnlich...ich brauch auch immer mehr Zeit, um Boris (zugegebenermaßen geniale) Formeln überhaupt zu kapieren, als wenn ich eine VBA-Lösung schreibe.

Ich habe Boris beim Forumstreffen Ende Juli mal gefragt, wie er denn zB. seine berühmt-berüchtigten Arrayformeln erstellt. Er hat es mal kurz erklärt...und ich habe beschlossen, mich weiter mit VBA-Lösungen zu beschäftigen ;-))
Man könnte ja bei Fragen, wo eine Formellösung gewünscht wird, auch antworten:
"Frag Boris, meine Formel ist eh zu lang..."



Gruß aus Leipzig
P@ulchen


 

Beiträge aus den Excel-Beispielen zum Thema "Handelt es sich um eine Zahl?"