Microsoft Excel

Herbers Excel/VBA-Archiv

Zellinhalt prüfen

Betrifft: Zellinhalt prüfen von: Dominic
Geschrieben am: 03.09.2004 13:06:30

Hallo beisammen!

Kann mir jemand helfen?
Ich möchte mit VBA ermitteln ob im markierten bereich (eine Spalte) wie viele verschiedene Werte eingetragen wurden, ohne eine Schleife zu verwenden. Z.B.:

Germany
U.K.
USA
Brazil

soll den Wert 4 ergeben aber

Germany
Germany
Germany
Germany

soll den Wert 1 ergeben.

Gruß
Dominic

  


Betrifft: =HÄUFIGKEIT(Daten;Klassen) oT von: Karl-Otto Reimann
Geschrieben am: 03.09.2004 13:21:06




  


Betrifft: AW: Zellinhalt prüfen von: Bert
Geschrieben am: 03.09.2004 13:32:50

Spezialfilter ohne Duplikate in Verbindung mit Teilergebnis(3;Matrix)

Bert


  


Betrifft: AW: Zellinhalt prüfen von: HermannZ
Geschrieben am: 03.09.2004 13:46:24

Hallo Dominic,

oder so,

Text
 AB
393Germany4
394U.K. 
395USA 
396Brazil 
397  
398  
399Germany1
400Germany 
401Germany 
402Germany 
403Germany 
404  
Formeln der Tabelle
B393 : {=SUMME(WENN(A393:A396="";0;1/ZÄHLENWENN(A393:A396;A393:A396)))}
B399 : {=SUMME(WENN(A399:A403="";0;1/ZÄHLENWENN(A399:A403;A399:A403)))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hermann


  


Betrifft: AW: Zellinhalt prüfen von: Udo
Geschrieben am: 03.09.2004 13:55:01

"Ich möchte mit VBA ermitteln ob im markierten bereich...."

Udo


  


Betrifft: tolle Antwort... von: P@ulchen
Geschrieben am: 03.09.2004 14:17:20

...hätte mich gewundert, wenn von Dir mal ein Lösungsansatz käme...

siehe auch hier: https://www.herber.de/forum/messages/477974.html

Paulchen


  


Betrifft: AW: tolle Antwort... von: Udo
Geschrieben am: 03.09.2004 14:25:46

Was gehts dich eigentlich an, Langeweile?

Udo


  


Betrifft: AW: Zellinhalt prüfen von: Dominic
Geschrieben am: 03.09.2004 15:21:08

Danke an alle!


 

Beiträge aus den Excel-Beispielen zum Thema "Zellinhalt prüfen"