Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn mit mehr als 8 Bedingungen

Betrifft: Wenn mit mehr als 8 Bedingungen von: Stephan
Geschrieben am: 03.09.2004 13:06:35

Hallo Miteinander,

habe folgendes Problem wie krieg ich eine Wenn-Formel hin mit mehr als 8 Bedingungen? Funktioniert das überhaupt?
Untenstehend ist meine Formel:
=WENN(H71=2;"S+B int";WENN(H71=3;"S+B ext";WENN(H71=4;"Bosch Nü";WENN(H71=5;"Bosch Im";WENN(H71=6;"Bosch Ba";WENN(H71=7;"Bosch Ch";WENN(H71=8;"Bosch Ho";WENN(H71=9;"Tyco Be";wenn(H71=10;"Tyco Ha";wenn=H71=11;"Sumida Ch";""))))))))
Total habe ich etwa 25 abfragen in der Formel.

Danke.
Gruss Stephan

  


Betrifft: AW: Wenn mit mehr als 8 Bedingungen von: PeterW
Geschrieben am: 03.09.2004 13:10:13

Hallo Stephan,

leg dir eine Referenzliste an und mach das mit dem Sverweis.

Gruß
Peter


  


Betrifft: AW: Wenn mit mehr als 8 Bedingungen von: HermannZ
Geschrieben am: 03.09.2004 13:38:50

Hallo Stephan,

vieleicht so??

Text
 AB
3885Bosch Im
3892S+B int
390  
Formeln der Tabelle
B388 : =WENN(A388="";"";WAHL(A388-1;"S+B int";"S+B ext";"Bosch Nü";"Bosch Im";"Bosch Ba";"Bosch Ch";"Bosch Ho";"Tyco Be";"Tyco Ha";"Sumida Ch"))
B389 : =WENN(A389="";"";WAHL(A389-1;"S+B int";"S+B ext";"Bosch Nü";"Bosch Im";"Bosch Ba";"Bosch Ch";"Bosch Ho";"Tyco Be";"Tyco Ha";"Sumida Ch"))
B390 : =WENN(A390="";"";WAHL(A390-1;"S+B int";"S+B ext";"Bosch Nü";"Bosch Im";"Bosch Ba";"Bosch Ch";"Bosch Ho";"Tyco Be";"Tyco Ha";"Sumida Ch"))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hermann


  


Betrifft: AW: Wenn mit mehr als 8 Bedingungen von: Stephan
Geschrieben am: 03.09.2004 13:56:20

Vielen Dank, es klappt!
Ich habe Hermann's Vorschlag integriert, der erschien mir für mein Problem am dienlichsten.
Wünsche Euch Helfer, noch ein schönes Wochenende.

Gruss Stephan


  


Betrifft: AW:Danke für die Rückantwort. oT von: HermannZ
Geschrieben am: 03.09.2004 13:59:50

...


 

Beiträge aus den Excel-Beispielen zum Thema "Wenn mit mehr als 8 Bedingungen"