Microsoft Excel

Herbers Excel/VBA-Archiv

wenn fml mit 8 Bedingungen ( 4xZahl , 4xWort)

Betrifft: wenn fml mit 8 Bedingungen ( 4xZahl , 4xWort) von: rene
Geschrieben am: 09.09.2014 02:50:11

Hallo zusammen ,

was ist an dieser fml falsch

=IF(D2="Feiertag"; 10; IF(D2="Krank"; 8; IF(D2="Überstunden"; 5; IF(D2="Urlaub"; 4)))) &IF(D2="20:00":"23:59"; 3; IF(D2="12:00":"16:00"; 2; IF(D2="7:00":"11:59"; 6; IF(D2="4:00":"6:59"; 1; 0))))

die Fml soll in F stehen und in D geb ich nur Zahlen 7:00,14:00 oder 22:00 usw ein . An freien Tagen wird U für Urlaub , Üh für Überstd, K für Krank oder F für Feiertag stehen .

danke schonmal
Gute Nacht
lg rene

  

Betrifft: AW: wenn fml mit 8 Bedingungen ( 4xZahl , 4xWort) von: Bernd
Geschrieben am: 09.09.2014 03:05:58

Hi,

verstehe ich nicht ganz. Wenn an freien Tagen, z.B.: nur U oder Üh steht, warum ist dann bei Deiner Formel Urlaub und Überstunden ausgeschrieben?

lg Bernd


  

Betrifft: AW: wenn fml mit 8 Bedingungen ( 4xZahl , 4xWort) von: rene
Geschrieben am: 09.09.2014 08:02:05

Hallo Bernd,

was letztendlich für Worte in der Tabelle stehen , hängt davon ab , ob diese Formel funktioniert . wenn die fml mit dem mix wort zahl nicht zurecht kommt , dann wird halt aus den Worten Zahlen .

Das hängt ganz daran ,was oder warum diese Formel nicht geht, bzw was ich verändern muss, damit sie geht.

gruß rene


  

Betrifft: AW: wenn fml mit 8 Bedingungen ( 4xZahl , 4xWort) von: hary
Geschrieben am: 09.09.2014 08:22:10

Moin rene
Eine andere Moeglichkeit.



Tabelle1

 AB
1Überstunden5
2Krank8
3Urlaub4
420:00:23:593
512:00:16:002

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
B1:B5=SVERWEIS(LINKS(A1;2);{"12".2;"20".3;"Fe".10;"Kr".8;"Üb".5;"Ur".4};2;1)  =VLOOKUP(LEFT(RC[-1],2),{"12",2;"20",3;"Fe",10;"Kr",8;"Üb",5;"Ur",4},2,1)

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary


  

Betrifft: AW: wenn fml mit 8 Bedingungen ( 4xZahl , 4xWort) von: rene
Geschrieben am: 09.09.2014 09:00:55

Hallo hary,

mit meinem Anfänger wissen und dem Aufbau meiner Datei geht im Moment nur Spalte F( vllt auch noch G dazu, dann teil ich die Bedingungen auf und greife dann mit F:G auf dem 2.Tabellenblatt auf die Daten zu)

Grundsätzlich , was ist an der Formel falsch?
hätte ich das & nach der 7. Bedingung setzen müssen?
sind die""falsch oder die ;0 am Ende vor den vielen))))? '( wobei ich gar nicht weiß , was diese 0 zu bedeuten hat, aber alle schreiben so.

gruß rene


  

Betrifft: AW: wenn fml mit 8 Bedingungen ( 4xZahl , 4xWort) von: hary
Geschrieben am: 09.09.2014 09:19:57

Moin
Die 0(Null) ist der Rueckgabewert wenn nix zutrifft.
Versuch mal so.Wenn nix zutrifft wird nix in die zelle eingetragen.
=IF(D2="20:00:23:59"; 3; IF(D2="12:00:16:00"; 2; IF(D2="7:00:11:59"; 6; IF(D2="4:00:6:59"; 1;"")))) &IF(D2="20:00:23:59";3;IF(D2="12:00:16:00";2;IF(D2="7:00:11:59";6;IF(D2="4:00:6:59";1;""))))
gruss hary


  

Betrifft: AW:Sry, war falsche Formel von: hary
Geschrieben am: 09.09.2014 09:24:25

Moin nochmal
hatte die falsche Formel erwischt.
=IF(D2="Feiertag"; 10; IF(D2="Krank"; 8; IF(D2="Überstunden"; 5; IF(D2="Urlaub"; 4;"")))) &IF(D2="20:00:23:59";3;IF(D2="12:00:16:00";2;IF(D2="7:00:11:59";6;IF(D2="4:00:6:59";1;""))))
gruss hary


  

Betrifft: AW: AW:Sry, war falsche Formel von: rene
Geschrieben am: 09.09.2014 09:55:07

Hallo hary,

die Formel enthält einen Fehler , sagt es mir.

ich ziehe die Fragen zurück , muss noch ein wenig lernen und dann verstehe ich's auch

bin immer sehr schnell dabei , hier Fragen zu stellen , ohne erstmal ausgiebig zu recherchieren , sorry

trotzdem vielen Dank erstmal und schön das es Euch gibt( für fast unlösbare Notfälle:) ;))
gruß rene


  

Betrifft: AW: AW:Sry, war falsche Formel von: hary
Geschrieben am: 09.09.2014 10:01:35

Moin
Also bei mir kein Fehler,hab das deutsche Excel und fuer dich nur Wenn durch If ersetzt.



Tabelle2

 DE
2Krank8
312:00:16:002
47:00:11:596
5Urlaub4

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
E2:E5=WENN(D2="Feiertag"; 10; WENN(D2="Krank"; 8; WENN(D2="Überstunden"; 5; WENN(D2="Urlaub"; 4;""))))&WENN(D2="20:00:23:59";3;WENN(D2="12:00:16:00";2;WENN(D2="7:00:11:59";6;WENN(D2="4:00:6:59";1;""))))  =IF(RC[-1]="Feiertag", 10, IF(RC[-1]="Krank", 8, IF(RC[-1]="Überstunden", 5, IF(RC[-1]="Urlaub", 4,""))))&IF(RC[-1]="20:00:23:59",3,IF(RC[-1]="12:00:16:00",2,IF(RC[-1]="7:00:11:59",6,IF(RC[-1]="4:00:6:59",1,""))))

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary


  

Betrifft: den Fehler findet man, wenn man ... von: Matthias L
Geschrieben am: 09.09.2014 10:56:56

Hallo

den Fehler findet man, wenn man ...
... den Formelassistent benutzt.
Der zeigt Dir dann auch die Funktionsargumente an!

Was soll denn hier rauskommen?
IF(D2="20:00":"23:59"




Besser wäre gewesen, Du hättest mal mit eigenen Worten ausgedrückt was Du wann und warum zurückgeben willst.
Ich vermute hier einfach, Du wolltest prüfen ob eine eingetragene Zeit
in einem bestimmten Zeitintervall liegt.

Gruß Matthias


  

Betrifft: AW: den Fehler findet man, wenn man ... von: rene
Geschrieben am: 09.09.2014 11:55:38

Hallo Matthias ,

kann erst heute Abend antworten , geh dann zur Arbeit

gruß rene


  

Betrifft: AW: den Fehler findet man, wenn man ... von: rene
Geschrieben am: 10.09.2014 03:01:31

Hallo Matthias ,

mache einen Kalender wo ich nur noch Anfangs und Endzeit , Pause Beginn und Ende der Arbeit eingebe.

Spalte F ist die Zuordnung
1 bedeutet Frühschicht
2 spätschicht
3 Nachtschicht
4 Urlaub
usw

D ist Arbeitsbeginn

also
Wenn in D2 eine Uhrzeit zwischen 12:00 bis 16:00 steht , dann schreib in F eine 6 ; Wenn in D2 eine Uhrzeit zwischen 20:00 bis 23:59 steht , dann schreib in F eine 3 ; usw usw insgesamt 8 Bedingungen , wobei 4 in Worten gehalten sind, aber die Spalte D so formatiert ist, daß ich die Zeitzahl erhalte , zb Spalte AF2 Formel = D2 , dann steht die händisch eingegebene Uhrzeit 6:00 in AF2 als Zahl 0,25 für die weitere Verarbeitung bzw Automatisierung .


den sogenannten Formel Assistenten gibt es nicht bei meiner Excel App fürs Smartphone

Gute Nacht
gruß rene


  

Betrifft: Zeit im Zeitfenster von: Matthias L
Geschrieben am: 10.09.2014 04:10:05

Hallo

Hier nochmal als Ansatz

 DEFG
1ZeitStartzeitEndzeit 
214:00:0020:00:0023:59:593
312:00:0015:59:59

Formeln der Tabelle
ZelleFormel
G2=WENN(UND(D2>=E2;D2<=F2);1;WENN(UND(D2>=E3;D2<=F3);3;""))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Für die anderen Zeiten dann analog.

Gruß Matthias


  

Betrifft: AW: Zeit im Zeitfenster von: rene
Geschrieben am: 10.09.2014 10:21:48

Hallo Matthias ,

das kann ich so nicht umsetzen , habe ja 8 Bedingungen und kann pro tag nur einzeilig.
Wenn man das auf einem eigenen Tabellen blatt baut und F die Eingabe in D mit dieser Liste vergleicht , könnte es gehen .

Sag mir bitte NUR , ob sowas geht und welche Formeln dazu nötig wären , will das selbst versuchen , lern ja dabei sehr viel

Vielen Dank , das wäre echt klasse , freu mich schon auf Feierabend

gruß rene


  

Betrifft: Einzeílig ... von: Matthias L
Geschrieben am: 10.09.2014 11:56:23

Hallo

Ok, pro Tag nur einzeilig.

 CDE
1DatumEingabeWert
210.09.2014U4
311.09.2014K8
412.09.201420:00:001
513.09.2014Ü5

Formeln der Tabelle
ZelleFormel
E2=WENN(D2="FT"; 10; WENN(D2="K"; 8; WENN(D2="Ü"; 5; WENN(D2="U"; 4;""))))&WENN(UND(D2>=0,83;D2<=1);1;WENN(UND(D2>=0,5;D2<=0,67);3;""))
C3=C2+1
E3=WENN(D3="FT"; 10; WENN(D3="K"; 8; WENN(D3="Ü"; 5; WENN(D3="U"; 4;""))))&WENN(UND(D3>=0,83;D3<=1);1;WENN(UND(D3>=0,5;D3<=0,67);3;""))
C4=C3+1
E4=WENN(D4="FT"; 10; WENN(D4="K"; 8; WENN(D4="Ü"; 5; WENN(D4="U"; 4;""))))&WENN(UND(D4>=0,83;D4<=1);1;WENN(UND(D4>=0,5;D4<=0,67);3;""))
C5=C4+1
E5=WENN(D5="FT"; 10; WENN(D5="K"; 8; WENN(D5="Ü"; 5; WENN(D5="U"; 4;""))))&WENN(UND(D5>=0,83;D5<=1);1;WENN(UND(D5>=0,5;D5<=0,67);3;""))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

So und nun nur noch die 2 restlichen Zeitintervalle in die Formel reinpacken.
Du wolltst ja auch selbst noch ein bisschen tüfteln ;-)

Gruß Matthias


  

Betrifft: ab 20:00 Uhr sollte ja 3 sein von: Matthias L
Geschrieben am: 10.09.2014 12:42:01

Hallo

Kleine Korrektur

 DEF
1DatumZeitWert
210.09.2014Ü5
311.09.2014FT10
412.09.201420:00:003
513.09.2014U4
614.09.201415:00:002

Formeln der Tabelle
ZelleFormel
F2=WENN(E2="FT"; 10; WENN(E2="K"; 8; WENN(E2="Ü"; 5; WENN(E2="U"; 4;""))))&WENN(UND(E2>=0,83333;E2<=1);3;WENN(UND(E2>=0,5;E2<=0,66667);2;""))
F3=WENN(E3="FT"; 10; WENN(E3="K"; 8; WENN(E3="Ü"; 5; WENN(E3="U"; 4;""))))&WENN(UND(E3>=0,83333;E3<=1);3;WENN(UND(E3>=0,5;E3<=0,66667);2;""))
F4=WENN(E4="FT"; 10; WENN(E4="K"; 8; WENN(E4="Ü"; 5; WENN(E4="U"; 4;""))))&WENN(UND(E4>=0,83333;E4<=1);3;WENN(UND(E4>=0,5;E4<=0,66667);2;""))
F5=WENN(E5="FT"; 10; WENN(E5="K"; 8; WENN(E5="Ü"; 5; WENN(E5="U"; 4;""))))&WENN(UND(E5>=0,83333;E5<=1);3;WENN(UND(E5>=0,5;E5<=0,66667);2;""))
F6=WENN(E6="FT"; 10; WENN(E6="K"; 8; WENN(E6="Ü"; 5; WENN(E6="U"; 4;""))))&WENN(UND(E6>=0,83333;E6<=1);3;WENN(UND(E6>=0,5;E6<=0,66667);2;""))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


  

Betrifft: AW: ab 20:00 Uhr sollte ja 3 sein von: rene
Geschrieben am: 11.09.2014 13:49:15

Hallo Matthias ,

kurz bescheid sagen , bin noch am ausprobieren , melde mich dann

gruß rene


  

Betrifft: AW: ab 20:00 Uhr sollte ja 3 sein von: rene
Geschrieben am: 13.09.2014 02:11:49

"/tmp/upload/81821a32ed59

Hallo Matthias

falls der upload gegangen ist, ist das Problem beschrieben , ansonsten ist diese WENN Geschichte mit mehreren Bedingungen in Wort und Zahl Bedingungen fur mich erstmal gestrichen , sitze jetzt seit Nächten daran und wenn mit wort geht, nur wenn mit Zahl geht nicht. Deine Formel und auch diese sverweis sind bei mir nicht gegangen .

gruß rene


  

Betrifft: Bitte nochmals um Hilfe von: rene
Geschrieben am: 14.09.2014 23:30:13

Hallo zusammen ,

https://www.herber.de/bbs/user/92619.xls
Brauche nochmal Eure Hilfe , die schon genannten Lösungen liefen bei mir nicht.
hänge seit vielen Nächten an diesem Problem , bekomme nur die in Worten gefasste Bedingungen zum Laufen , die mit den Uhrzeiten wollen nicht funktionieren .

Hier nochmal die Aufgabe:
1 Wenn Formel in der 8 Bedingungen eine andere zahl geben sollen

- 20:00 bis 23:59
- 12:00 bis16:00
- 7:00 bis 11:59
- 4:00 bis 6:59
-Überstunden frei
- Urlaub
- Feiertag
- Krank

Die Beispiel Datei zeigt meine Versuche .
Mein Excel hat Version 97-2003

gruß rene


  

Betrifft: AW: Bitte nochmals um Hilfe von: rene
Geschrieben am: 15.09.2014 05:38:18

Guten Morgen ,

mein aktueller Stand

istIF(AND(B40>=0,83333;B40<=0,9999)3;IF(B40>=0,5;2;IF(B40>=0,290;6;IF(B40>=0,16667;1;IF(B40="Feiertag ";10;IF(B40="Krank";8;IF(B40="Überstunden ";5;IF(B40="Urlaub ";4;0))))))))~f~

nur geht die nicht, was ist daran falsch? glaube bin sehr nah an der Lösung , denn kurz davor hatte ich diese
~f~
istIF(B40>=0,83333;3;IF(B40>=0,5;2;IF(B40>=0,290;6;IF(B40>=0,16667;1;IF(B40="Feiertag ";10;IF(B40="Krank";8;IF(B40="Überstunden ";5;IF(B40="Urlaub ";4;0))))))))

und da hat es mir zum ersten mal fur die Zeitabfragen die richtige Zahl ausgespuckt , dafür aber fur"Feiertag ,Krank ,Überstunden ,Urlaub" jeweils die 3 als Ergebnis

Hat jemand einen Tipp?

gruß rene


  

Betrifft: AW: Bitte nochmals um Hilfe von: Buddy
Geschrieben am: 15.09.2014 09:07:41

Ich habs so gelöst:

1 - 20:00 bis 23:59
2 - 12:00 bis16:00
3 - 7:00 bis 11:59
4 - 4:00 bis 6:59
5 - Überstunden frei
6 - Urlaub
7 - Feiertag
8 - Krank

in Zelle B40 werden die entsprechenden Eingaben getätigt.
Folgende Formel in C40:
Wenn(Istzahl(B40);wenn(B40*24>=20;1;Wenn(B40*24>=12;2;Wenn(B40*24>=7;3;Wenn(B24*24=>4;4;"falsche Eingabe"))));wenn(B40="Überstunden frei";5;wenn(B40="Urlaub";6;Wenn(B40="Feiertag";7;Wenn(B40="krank";8;"falsche Eingabe")))))


die Zahlenangaben habe ich mit 24 multipliziert, um
1. die Rundungsdifferenzen rauszukriegen,
2. mit den Uhrzeitangaben besser klarzukommen. Rechnet Uhrzeiten in entsprechende Dezimalzahlen um.

Bei mir funktioniert's.
Ich arbeite allerdings mit Excel-Version 2010.

Gruß
Buddy


  

Betrifft: AW: Bitte nochmals um Hilfe von: rene
Geschrieben am: 15.09.2014 17:15:06

Hallo Buddy,


deine Formel geht bei mir nicht , Fehler , was für einer kann ich nicht ablesen .

gruß rene


  

Betrifft: Hurra , es hat geklappt Wenn mit 8 Bed. von: rene
Geschrieben am: 16.09.2014 23:55:15

Vielen Dank nochmal an Bernd, Hary, Matthias und Buddy für eure Mithilfe .
War eine schwere Geburt für mich, habe aber viel über die wenn Formel gelernt in den vergangenen Nächten .
gruß Rene


  

Betrifft: AW: wenn fml mit 8 Bedingungen ( 4xZahl , 4xWort) von: Bernd
Geschrieben am: 12.09.2014 06:10:16

Hi,

na da hätte ich mich sicher Übernommen wie es Aussieht. Aber Du hast ja kompetente
Hilfe erhalten.

lg Bernd


 

Beiträge aus den Excel-Beispielen zum Thema "wenn fml mit 8 Bedingungen ( 4xZahl , 4xWort)"