Zählen wenn 3 Bedingungen



Excel-Version: 10.0 (Office XP)
nach unten

Betrifft: Zählen wenn 3 Bedingungen
von: Harald
Geschrieben am: 07.07.2002 - 18:10:45

Hallo Excel Forum,
mit dieser Formel rechne ich meine monatlichen Stunden aus,
=SUMMEWENN(harald!A:A;">="&A2;harald!D:D)-SUMMEWENN(harald!A:A;">"&B2;harald!D:D)
kan man dieser Formel eine dritte Bedingung hinzufügen
in A2 steht das Anfangsdatum zb 01.01.02
in B2 steht das Enddatum zb 31.01.02
in D2 steht die Arbeitszeit Zb 8,0
nun möchte ich wenn in Spalte C "Urlaub" steht nur die Urlaubsstunden im bereich A2 bis B2 summiert werden.

Vielen Dank für eure Antworten

Gruß Harald

nach oben   nach unten

Re: Zählen wenn 3 Bedingungen
von: Hajo_Zi
Geschrieben am: 07.07.2002 - 18:15:39

Hallo Harald

der Text sieht innen anderes aus als der Betreff. vielleicht hilft folgende Seit
http://www.excelformeln.de/formeln.html?welcher=273

Gruß Hajo

nach oben   nach unten

Re: Zählen wenn 3 Bedingungen
von: Harald
Geschrieben am: 07.07.2002 - 18:32:44

Hallo Hajo,
danke für deine Antwort, die Seite hatte ich schon durchgearbeitet fand aber keine Lösung.

Gruß Harald


nach oben   nach unten

Re: Zählen wenn 3 Bedingungen
von: Hans W Hofmann
Geschrieben am: 07.07.2002 - 19:44:06

Die steckt aber da drin.
Vielleicht hilft Dir ja auch die Funktion Summenprodukt weiter.
Zum Verständnis Datum ist die Zahl der sei dem 1.1.1900 vergangen Tage. Also so was wie (Datum=DATWERT("22.8.1998")) ergibt WAHR oder FALSCH was zahlenmäßig als 1 oder 0 interpretiert wird. Zur Anwendung in einer Arrayformel:
=SUMME((A1:A10=DATWERT("22.8.1998"))*1) Strg+Umschalt+Eingabe
wird die Anzahl der Tage vom 22.8.1998 in A1:A10 ermittelt.

Gruß HW

nach oben   nach unten

Re: Zählen wenn 3 Bedingungen
von: Harald
Geschrieben am: 07.07.2002 - 21:54:06

Hallo Hajo und Hans

danke für eure Hilfe ich denke ich habe die Lösung
mit einer Matrix Formel
=SUMME((st)*(MONAT(j)=1)*(JAHR(j)=2002)*((u)="urlaub"))/8

Gruß Harald


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Zählen wenn 3 Bedingungen"