Microsoft Excel

Herbers Excel/VBA-Archiv

DB: Klassen einteilen

Betrifft: DB: Klassen einteilen von: Uli
Geschrieben am: 16.09.2004 09:33:58

Hallo,

ich habe folgendes Problem und komme nicht weiter. Hoffentlich kann mir einer von Euch nen Tipp geben. Also, ...

Tabellenblatt 1 enthält mein Suchkriterium der Datenbank (Kriterien kommen mehrfach vor) und dazu 30 Spalten mit zugehörigen Zahlenwerten (teilweise auch Leerzellen).

Tabellenblatt 2 wertet die DB aus:
Spalte 1: Kriterium, das in Tab1 gesucht wird
Spalte 2,3,4: hier sollen die 30 Spalten aus Tab1 in 3 Klassen eingeteilt werden(z.B. <3;3-6;>6). Aber wie verknüpfe ich die Funktionen? Ich brauche also aus Tab1 die 30 Spalten und eine gewisse Anzahl von Zeilen.
Geht das mit VERWEIS als Matrix?

  


Betrifft: AW: DB: Klassen einteilen von: ingoG
Geschrieben am: 16.09.2004 11:31:51

Hallo Uli,

hab Dein Prob nicht ganz verstanden, aber ich hab mal versucht, einen ansatz aufzuzeigen:

https://www.herber.de/bbs/user/10954.xls


wenn Du mehr als 30 zeilen untersuchen möchtest einfach die 30 inden Formeln in einen Grösseren Wert ändern

Gruß Ingo

PS eine Rückmeldung wäre nett...


  


Betrifft: AW: DB: Klassen einteilen von: Uli
Geschrieben am: 16.09.2004 11:56:23

:-))))))

Das klappt auf Anhieb! Ich hab all meine Spaltennummern geändert und es läuft.
DANKE!!!

Für mich ist das Zauberei! Kannst Du mir vielleicht erklären, wie der Quelltext zu verstehen ist? Gelingt mir nämlich nicht so recht...

=SUMMENPRODUKT(($A2=Tabelle1!$A$2:$A$30)*ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!$B$2:$AE$2;ZEILE(Tabelle1!$A$2:$A$30)-2;0);"<3"))

Was macht bereich.verschieben?


  


Betrifft: AW: DB: Klassen einteilen von: IngoG
Geschrieben am: 16.09.2004 12:07:00

Hallo Uli,

erstmal danke für die Rückmeldung.
bereich.verschieben() ist eine normale excelfunktion, die, wie der Name schon sagt,den im ersten parameter angegebenen bereich um n Zeilen (Param2) und m spalten (param3) verschiebt.
zählenwenn arbeitet so immer nur in der aktuell betrachteten Zeile...

am besten schaust Du dir die Hilfe dazu noch einmal an.

die schlüsselfunktion bei dieser Lösung ist übrigens summenprodukt(), die wird wirklich häufig benötigt und den Gebrauch sollte man sich einmal verinnerlichen (wenn nicht schon geschehen ;-)).
(ist aber im Prinzip eine verkapselte matrixfunktion, auch vom Laufzeitverhalten her)

hierzu findest Du im Forum auch eine ganze menge beispielanwendungen.

Gruß Ingo







 

Beiträge aus den Excel-Beispielen zum Thema "DB: Klassen einteilen"