Summe bilden

Bild

Betrifft: Summe bilden von: Sascha
Geschrieben am: 11.02.2005 10:26:50

Ich habe eine Personaltabelle ("Tabelle 2004") und möchte nun in einem anderen Arbeitsblatt ("Abrechnung Reinigung") eine Formel eingeben, mit der man aus dem Arbeitsblatt Tabelle 2004 die einzelnen Quartale im Arbeitsblatt Reinigung ermitteln kann. Wie bzw. welche Formel kann ich dafür verwenden?
Die SUMMEWENN('Tabelle 2004'!$A:$A;'Abrechnung Reinigung'!A2;'Tabelle 2004'!D:F)-Funktion hat nicht funktioniert. Es wird nur die Summe der Spalte D angegeben, nicht die Summe der Spalten D bis F.

Bild


Betrifft: AW: Summe bilden von: Jan
Geschrieben am: 11.02.2005 10:55:04

Hi Sascha,

Bei Deinem Level in VBA würde ich einen VBA-Code erstellen. Du kannst aber auch für jede Spalte die SUMMEWENN-Funktion einsetzen und dann die Werte addieren oder?!

Vielleicht wäre eine Beispielmappe sinnvoll oder?!


Jan


Bild


Betrifft: SUMMEWENN über mehrere Ergebnisspalten von: Boris
Geschrieben am: 11.02.2005 11:03:25

Hi Sascha,

mit SUMMEWENN geht das so:

=SUMME(SUMMEWENN('Tabelle 2004'!$A:$A;'Abrechnung Reinigung'!A2;INDIREKT("'Tabelle 2004'!"&{"D:D"."E:E"."F:F"})))

Alternativ mit SUMMENPRODUKT:
=SUMMENPRODUKT(('Tabelle 2004'!$A1:$A100='Abrechnung Reinigung'!A2)*('Tabelle 2004'!D1:F100))

Nachteil von SUMMENPRODUKT: Es können keine ganzen Spalten referenziert werden - und die Performance ist schlechter.

Grüße Boris


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summe bilden"