Diagramm und Vergleich formel (Variabel)

Bild

Betrifft: Diagramm und Vergleich formel (Variabel) von: chris b
Geschrieben am: 15.02.2005 13:37:54

Hallo Excellianer, habe eine frage und zwar ist dies möglich ?

habe in eine Datei ein Diaramm.Der Zellbezug(Werte) ist dieser:
=Januar!$AH$4:$AH$45
aus diesen zeilen holt sich das Diagramm die Werte.

Ist es jetzt möglich in den Zellbezug abzuändern mit dieser Formel ?
=VERGLEICH(;Januar!B1:B70;-1)-42
das ergebniss wäre die Zahl "48"

UNd jetzt die Formel im Diagramm so zu ändern das die Zahl 48 eingezogen wird.
Etwas so stelel ich mir das vor:
ALT:
=Januar!$AH$4:$AH$45
Soll
=Januar!$AH$4:$AH$48

und um auf die 48 zu kommen und diese Variabel zu halten diese Formelmiteinbinden.
=VERGLEICH(;Januar!B1:B70;-1)-42
etwa so..
=Januar!$AH$4:$AH$(statt45)VERGLEICH(;Januar!B1:B70;-1)-42

P.s und noch eine frage ist es möglich mit der vergleichsformel
=VERGLEICH(;Januar!B1:B70;-1)-42
auch ein Ergebniss zu erreichen wenn in den Zellen B1 bis B70 keine Zaheln stehen ?
Also wenn der letzte wert in Zeile 35 steht das dann das ergebniss nicht #NV ist sondern 35. Danke auch hierfür !!!!!


Würde mich sehr freuen wenn mir jemand helfen kann.
Vielen Dank grüße Christian

Bild


Betrifft: AW: Diagramm und Vergleich formel (Variabel) von: Hübi
Geschrieben am: 15.02.2005 13:58:54

Hi Christian,

um dein Diagramm dynamisch zu machen, musst du mit Namen arbeiten und diese dann dynamisieren.
Hier ein Beispiel
https://www.herber.de/bbs/user/18122.xls
Schreibe in der Datentabelle was drunter und staune.

Gruß Hübi


Bild


Betrifft: AW: Diagramm und Vergleich formel (Variabel) von: chris b
Geschrieben am: 15.02.2005 14:41:29

Vielen Dank für deine Hilfe !!!!!
Ist klasse !


Bild


Betrifft: AW: eine frage dazu von: chris b
Geschrieben am: 15.02.2005 14:50:00

ist echt klasse und würde auch funktionieren.
Aber was macht diese Formel ??
Wenn ich die in eine Zelle als formel einfüge habe ich nichts davon.Vielen Danke nocheinmal
=BEREICH.VERSCHIEBEN(Tabelle1!$A$2;;;ANZAHL2(Tabelle1!$A:$A)-1;1)


Bild


Betrifft: AW: eine frage dazu von: Hübi
Geschrieben am: 15.02.2005 16:35:26

Hi Chris,

war nur mal schnell weg.

Dieser Formel ist ein Bereichsname zugewiesen, der dann im Diagramm genutzt wird.

=BEREICH.VERSCHIEBEN(Tabelle1!$A$2;;;ANZAHL2(Tabelle1!$A:$A)-1;1)
Sie dients also letztendlich nur dazu, die wirklichen Zellgrenzen des Bereichsnamen zu definieren.

Tabelle1!$A$2 ist die linke obere Ecke des Bereichs
ANZAHL2(Tabelle1!$A:$A) ermittelt die Anzahl der Einträge in Spalte A, um diese dann um 1 vermindert als neue Höhe des Bereichs zu nutzen
;1) ist die Spaltenanzahl des Bereichs (kann auch weggelassen werden)

Kannst dir ja in der Excle-Hilfe Wissens-Nachschub dazu holen. Da wirst du auch schnell verstehen, wie du z. B. einen seitlichen Versatz erzeugen kannst.
Wenn du nicht klar kommst, mache ein Beispiel und stelle es hoch.

Gruß Hübi


Bild


Betrifft: AW: eine frage dazu von: chris b
Geschrieben am: 15.02.2005 16:38:16

Hallo vielen Dank für deine riesen Hilfe.
Über ein Beispiel wäre ich trotzdem sehr dankbar !!

Ganz großen gruß christian !!!!!!!!!


Bild


Betrifft: AW: eine frage dazu von: Hübi
Geschrieben am: 15.02.2005 16:46:34

Hi Christian,

ich hatte dir doch eine Beispiel-Datei zum Diagramm gepostet.

Über ein Beispiel wäre ich trotzdem sehr dankbar !! - zu welchem Problem?

Gruß Hübi


Bild


Betrifft: AW: eine frage dazu von: chris b
Geschrieben am: 15.02.2005 17:32:18

Danke Hübi bin klar gekommen !!
Alles super danke nochmal !


Bild


Betrifft: Danke für die Antwort - erledigt o.T. von: Hübi
Geschrieben am: 15.02.2005 19:12:53




 Bild

Beiträge aus den Excel-Beispielen zum Thema "Diagramm und Vergleich formel (Variabel)"