Wie legt man eine Obergrenze fest?

Bild

Betrifft: Wie legt man eine Obergrenze fest? von: Markus
Geschrieben am: 20.02.2005 16:26:24

Hallo, ich hab folgendes Problem:

Ich benutze eine Formel um den Wert in einer Zelle festzulegen:

=WENN(B3="G";G3+1;WENN(B3="GG";G3+2;WENN(B3="BJ";G3+2;WENN(B3="GGG";G3+3;WENN(B3="R";G3;1)))))

Allerdings soll Wert nicht nicht größer als 7 werden. Sobald die Wert größer als 7 wird, soll er auf 1 zurückgesetzt werden. Wie kann ich das realisieren?

Bild


Betrifft: =wenn(deine formel>7;1;deine formel) von: ransi
Geschrieben am: 20.02.2005 16:31:30

hallo markus

vorausgesetzt deine formel funktioniert:
=wenn(deine formel>7;1;deine formel)
ransi


Bild


Betrifft: AW: Wie legt man eine Obergrenze fest? von: Reinhard
Geschrieben am: 20.02.2005 16:53:26

Hi Markus,

=WENN(B3="G";G3+1;WENN(B3="GG";G3+2;WENN(B3="BJ";G3+2;WENN(B3="GGG";G3+3;WENN(B3="R";G3;1)))))
bzw. gleichwertig
=1+(B3="G")*$G$3+(B3="GG")*($G$3+1)+(B3="BJ")*($G$3+1)+(B3="GGG")*($G$3+2)+(B3="R")*($G$3-1)

bezeichne ich als
=x
dann so:
=wenn(x>7;1;x)
Tabellenblattname: Tabelle1
   A |  B  | C | D | E | F | G | 
1|   |   G | 6 | 6 |   |   |   | 
2|   |  GG | 7 | 7 |   |   |   | 
3|   | GGG | 1 | 1 |   |   | 5 | 
4|   |  BJ | 7 | 7 |   |   |   | 
5|   |   R | 5 | 5 |   |   |   | 
6|   |   e | 1 | 1 |   |   |   | 
Benutzte Formeln:
C1:  =WENN(WENN(B1="G";$G$3+1;WENN(B1="GG";$G$3+2;WENN(B1="BJ";$G$3+2;WENN(B1="GGG";$G$3+3;WENN(B1="R";$G$3;1)))))>7;1;WENN(B1="G";$G$3+1;WENN(B1="GG";$G$3+2;WENN(B1="BJ";$G$3+2;WENN(B1="GGG";$G$3+3;WENN(B1="R";$G$3;1))))))
C2:  =WENN(WENN(B2="G";$G$3+1;WENN(B2="GG";$G$3+2;WENN(B2="BJ";$G$3+2;WENN(B2="GGG";$G$3+3;WENN(B2="R";$G$3;1)))))>7;1;WENN(B2="G";$G$3+1;WENN(B2="GG";$G$3+2;WENN(B2="BJ";$G$3+2;WENN(B2="GGG";$G$3+3;WENN(B2="R";$G$3;1))))))
C3:  =WENN(WENN(B3="G";$G$3+1;WENN(B3="GG";$G$3+2;WENN(B3="BJ";$G$3+2;WENN(B3="GGG";$G$3+3;WENN(B3="R";$G$3;1)))))>7;1;WENN(B3="G";$G$3+1;WENN(B3="GG";$G$3+2;WENN(B3="BJ";$G$3+2;WENN(B3="GGG";$G$3+3;WENN(B3="R";$G$3;1))))))
C4:  =WENN(WENN(B4="G";$G$3+1;WENN(B4="GG";$G$3+2;WENN(B4="BJ";$G$3+2;WENN(B4="GGG";$G$3+3;WENN(B4="R";$G$3;1)))))>7;1;WENN(B4="G";$G$3+1;WENN(B4="GG";$G$3+2;WENN(B4="BJ";$G$3+2;WENN(B4="GGG";$G$3+3;WENN(B4="R";$G$3;1))))))
C5:  =WENN(WENN(B5="G";$G$3+1;WENN(B5="GG";$G$3+2;WENN(B5="BJ";$G$3+2;WENN(B5="GGG";$G$3+3;WENN(B5="R";$G$3;1)))))>7;1;WENN(B5="G";$G$3+1;WENN(B5="GG";$G$3+2;WENN(B5="BJ";$G$3+2;WENN(B5="GGG";$G$3+3;WENN(B5="R";$G$3;1))))))
C6:  =WENN(WENN(B6="G";$G$3+1;WENN(B6="GG";$G$3+2;WENN(B6="BJ";$G$3+2;WENN(B6="GGG";$G$3+3;WENN(B6="R";$G$3;1)))))>7;1;WENN(B6="G";$G$3+1;WENN(B6="GG";$G$3+2;WENN(B6="BJ";$G$3+2;WENN(B6="GGG";$G$3+3;WENN(B6="R";$G$3;1))))))
D1:  =WENN(1+(B1="G")*$G$3+(B1="GG")*($G$3+1)+(B1="BJ")*($G$3+1)+(B1="GGG")*($G$3+2)+(B1="R")*($G$3-1)>7;1;1+(B1="G")*$G$3+(B1="GG")*($G$3+1)+(B1="BJ")*($G$3+1)+(B1="GGG")*($G$3+2)+(B1="R")*($G$3-1))
D2:  =WENN(1+(B2="G")*$G$3+(B2="GG")*($G$3+1)+(B2="BJ")*($G$3+1)+(B2="GGG")*($G$3+2)+(B2="R")*($G$3-1)>7;1;1+(B2="G")*$G$3+(B2="GG")*($G$3+1)+(B2="BJ")*($G$3+1)+(B2="GGG")*($G$3+2)+(B2="R")*($G$3-1))
D3:  =WENN(1+(B3="G")*$G$3+(B3="GG")*($G$3+1)+(B3="BJ")*($G$3+1)+(B3="GGG")*($G$3+2)+(B3="R")*($G$3-1)>7;1;1+(B3="G")*$G$3+(B3="GG")*($G$3+1)+(B3="BJ")*($G$3+1)+(B3="GGG")*($G$3+2)+(B3="R")*($G$3-1))
D4:  =WENN(1+(B4="G")*$G$3+(B4="GG")*($G$3+1)+(B4="BJ")*($G$3+1)+(B4="GGG")*($G$3+2)+(B4="R")*($G$3-1)>7;1;1+(B4="G")*$G$3+(B4="GG")*($G$3+1)+(B4="BJ")*($G$3+1)+(B4="GGG")*($G$3+2)+(B4="R")*($G$3-1))
D5:  =WENN(1+(B5="G")*$G$3+(B5="GG")*($G$3+1)+(B5="BJ")*($G$3+1)+(B5="GGG")*($G$3+2)+(B5="R")*($G$3-1)>7;1;1+(B5="G")*$G$3+(B5="GG")*($G$3+1)+(B5="BJ")*($G$3+1)+(B5="GGG")*($G$3+2)+(B5="R")*($G$3-1))
D6:  =WENN(1+(B6="G")*$G$3+(B6="GG")*($G$3+1)+(B6="BJ")*($G$3+1)+(B6="GGG")*($G$3+2)+(B6="R")*($G$3-1)>7;1;1+(B6="G")*$G$3+(B6="GG")*($G$3+1)+(B6="BJ")*($G$3+1)+(B6="GGG")*($G$3+2)+(B6="R")*($G$3-1))
Gruß
Reinhard
Tabelle wurde eingefügt mit Code von https://www.herber.de/forum/technik/messages/1226.html



Bild


Betrifft: AW: Obergrenze fest?Kürzere Formel von: Gert Seler
Geschrieben am: 20.02.2005 22:11:30

Hallo Marcus,
es geht auch etwas kürzer :
=WENN(ODER(B3="GG";B3="BJ");G3+2;WENN(ODER(B3>7;B3<0)1;WENN(B3="R";G3;
Wenn(B3="G";G3+1;WENN(B3="GGG";G3+3)))))
In die 2te "WENN(ODER(" Formel wurde integriert (Wenn B3 kleiner Null, dann;1)
mfg
Gert


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zelle automatisch ausfüllen"