Summewenn?

Bild

Betrifft: Summewenn? von: Sabine
Geschrieben am: 22.02.2005 11:05:29

Hallo Spezialisten,
ich will kurz mein Problem beschreiben, welches ich allein und mit der Recherche nicht lösen konnte:
Addiert werden sollten die Zellen A1 bis A10, das Ergebnis sollte in B12 erscheinen, allerdings soll in B12 nur eine Zahl erscheinen, wenn in A1-A10 Werte stehen, steht dort nichts (Zellen leer), soll auch in B12 keine Null erscheinen.
Formel oder VBA-Lösung(Function) sind willkommen.

Viele Grüße aus Sachsen

Sabine

Bild


Betrifft: AW: Summewenn? von: UweN
Geschrieben am: 22.02.2005 11:09:47

Hallo Sabine,

wie wär's damit:
WENN(SUMME(A1:A10)=0;"";SUMME(A1:A10))

viele Grüße
Uwe


Bild


Betrifft: AW: Summewenn? von: Mayk
Geschrieben am: 22.02.2005 11:10:17

Hallo Sabine,

wenn es auch unschick sein darf:
setzte in B1 die formel ein: =wenn(A1="";"X";"")
und in B12 =summewenn(B1:B10;"X";A1:A10)

Schöner geht's natürlich mit vba - aber so ist es mal auf die Schnelle eingesetzt ;-)

Gruß,
Mayk


Bild


Betrifft: AW: Summewenn? von: Mayk
Geschrieben am: 22.02.2005 11:12:12

Wer lesen kann ist klar im Vorteil... Sorry!

B12:
=wenn(summe(A1:A10)="0";"";summe(A1:A10))

hätte erst richtig lesen müssen und nicht nach dem Absenden ;-)


Bild


Betrifft: AW: Summewenn? von: Josef Ehrensberger
Geschrieben am: 22.02.2005 11:11:15

Hallo Sabine!

Entweder > Extras > Optionen > Ansicht > Haken bei "Nullwerte anzeigen" raus,
oder mit Formel.

=WENN(SUMME(A1:A10)<>0;SUMME(A1:A10);"")



Gruß Sepp

P.S.: Rückmeldung nicht vergessen!


Bild


Betrifft: AW: Summewenn? von: MichaV
Geschrieben am: 22.02.2005 11:11:58

Hi,

=WENN(SUMME(A1:A10)>0;SUMME(A1:A10);"")

geht sicherlich auch eleganter.

Gruß


Bild


Betrifft: AW: Summewenn? von: Sabine
Geschrieben am: 22.02.2005 11:54:52

Liebe Helfer,
Danke erstmal für die vielen Ideen. Mein Problem allerdings ist die Unterscheidung leere Zelle oder 0 im Bereich A1:A10 . Wenn A1:10 leer, dann auch B12 leer, steht allerdings in den Zellen A1:A10 ein oder mehrere 0 dann sollte B12=0.

Vielleicht gibt`s auch dafür eine Lösung?

Sabine


Bild


Betrifft: AW: Summewenn? von: UweN
Geschrieben am: 22.02.2005 12:06:56

Hi Sabine,

vielleicht so:
=WENN(ZÄHLENWENN(A1:A10;"")=10;"";SUMME(A1:A10))

Viele Grüße
Uwe


Bild


Betrifft: Danke Uwe! oT von: Sabine
Geschrieben am: 22.02.2005 17:08:07




 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summewenn?"