Zählprob

Bild

Betrifft: Zählprob von: Klaus
Geschrieben am: 03.03.2005 15:21:48

Moin moin :-)

Ich versuche ohne Kenntnis von VBA eine Urlaubsdatenbank zu erstellen.
Ich möchte über ein Dropdownfeld eine Auswahl von 4 Wahlmöglichkeiten anbieten.
(Beispiel: H = Halber Tag, G = Ganzer Tag, usw.)

Nun benötige ich eine Möglichkeit, das Excel mir die eingetragenen "H" in einem Monat addiert, und die Gesamtzahl ausgibt, ebenso wie die "G" usw.
Mit diesen Ergebnissen kann ich dann weiter rechnen.

Fällt einem der LeserInnen ne einfache Lösung ein ?
Freue mich auf Eure / Ihre Vorschläge.
Danke für Eure / Ihre Arbeit im voraus
MfG
Klaus

Bild


Betrifft: AW: Zählprob von: c0bRa
Geschrieben am: 03.03.2005 15:27:02

hallo...

deine funktion heisst zählenwenn(...) ;)

vergiss das dropdown feld und mach ne zelle einfach über gültigkeit (daten - gültigkeit) auf die 4 werte fix, da haste danna uch ein dropdownfeld, mit dem vorteil, dass das dropdown nur erscheint, wenn die zelle aktiv ist...

wenn deine daten z.b. in spalte C stehen, und das H oder G in zelle A1, dann:
=zählenwenn(C:C;a1)

auf die werte kannst du dann deine weiteren formeln aufbauen ;)

Das Forum lebt auch von Rückmeldungen...
c0bRa


Bild


Betrifft: ZÄHLENWENN ??? von: Kl@us-M.
Geschrieben am: 03.03.2005 15:29:42

Hi Klaus,
so etwas ?
 
 AB
1H3
2G2
3G 
4H 
5H 
Formeln der Tabelle
B1 : =ZÄHLENWENN(A1:A5;"H")
B2 : =ZÄHLENWENN(A1:A5;"G")
 



Gruss aus dem wilden Hunsrück
Klaus-Martin



Bild


Betrifft: AW: Zählprob von: Klaus
Geschrieben am: 03.03.2005 16:04:09

hmmmm..... das sieht schon klasse aus, was Ihr beide da geantwortet habt, bedank, bedank bedank :-)

ein prob bleibt, wo ich immo dran verzweifel:
das mit der gültigkeitsliste bekomm ich nicht hin, könntet Ihr mir dazu noch n tip geben ?

thx im voraus
Gruss Klaus


Bild


Betrifft: Daten - Gültigkeit von: Kl@us-M.
Geschrieben am: 03.03.2005 17:14:32

Hi Klaus,
Daten - Gültigkeit ist garnicht soooo schwer: Markiere eine Zelle, klick auf Daten - Gültigkeit - Zulassen - Liste. Als Quelle trägst Du ein: G;H;X;Y
Nun legst Du noch (falls Bedarf) Eingabe- und Fehlermeldung fest und fertig.
Markiere mal die Zelle und klick auf den Pfeil rechts daneben ...
Du kannst als Quelle ebenso einen (gefüllten) Zellbereich des gleichen Tabellenblatt angeben: =A1:A25
Etwas (aber nur etwas) komplizierter wird's, wenn Deine "Gültigkeitszellen" auf 'nem anderen TabBlatt zu finden sind: Dann musst Du diesen Zellen einen Namen vergeben (Einfügen - Name - Definieren - Name im Tabellenblatt [Dein_vergebener_Name]) und bei Daten - Gültigkeit - Zulassen - Liste - Quelle auf eben diesen Namen referenzieren (=Dein_vergebener_Name)

H T H

Gruss aus dem wilden Hunsrück
Klaus-Martin



Bild


Betrifft: AW: Daten - Gültigkeit von: Klaus
Geschrieben am: 04.03.2005 09:24:57

jo, klasse :-)

nu klappt das auch mit der nachbarin, achnee, das war was anderes.

Vielen Dank für die schnelle Hilfe.
Ihr habt mir wirklich geholfen :-)

Ein schönes WE an alle
Gruss Klaus


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zelle mit Rahmen aber nicht drucken"