Excel rechnet falsch

Bild

Betrifft: Excel rechnet falsch von: Theo
Geschrieben am: 11.03.2005 20:21:13

Hallo,

ich habe folgendes Rechenproblem:

Werte: A1 = 4.985,10
A3 = 16.472,31
A6 = 2.541,00

Formeln: C2 = A1/A3
A6 * C$2

Alle Zellen sind formatiert als Zahl mit 2 Dezimalstellen


C2 ergibt 0,30
A6*C$2 ergibt 769,00, was falsch ist.
Richtig wäre 762,30.

Was muß ich ändern, damit Excel richtig rechnet?

Gruß
theo


Das Beispiel findet ihr hier:
https://www.herber.de/bbs/user/19534.xls

Bild


Betrifft: AW: Excel rechnet falsch von: =Peter=
Geschrieben am: 11.03.2005 20:26:23

Hallo Theo,

zwei Möglichkeiten: In C2 die Formel =Runden(A1/A3;2) oder unter Extras - Optionen - Berechnung - Haken bei 'Genauigkeit wie angezeigt'.

A1/A3 ergibt nicht 0,30 sondern 0,30263515 und Excel rechnet eben mit den Nachkommastellen weiter.


HTH
Gruss
Peter


Bild


Betrifft: AW: ergänzend bleibt nur zu bemerken, dass... von: Luc :-?
Geschrieben am: 11.03.2005 20:35:57

Excel zwar wirklich gelegentlich Fehler bei Divisionen macht, aber idR erst in der letzten möglichen Dezimalstelle (das ist nur für wissenschaftliche Berechnungen relevant). Außerdem funktionieren manche Funktionen nicht wie erwartet, z.B. REST und GANZZAHL bei negativen Werten. Aber hier bist du nur in die Rundungsfehlerfalle getappt, Theo.
Gruß an dich und =Peter=
Luc :-?


Bild


Betrifft: AW: Excel rechnet falsch von: Sonnenpeter
Geschrieben am: 11.03.2005 20:30:53

Tabelle1
 ABCDEFG
14.985,10      
2 =0,302635 0,30762,30 
316.472,31      
4       
5       
62.541,00x0,302635=769,00falsch!769,00
7       
8    769,00richtig! 
9       
Formeln der Tabelle
C2 : =A1/A3
E2 : =RUNDEN(C2;1)
F2 : =A6*E2
C6 : =C$2
D6 : =B2
E6 : =A6*C6
G6 : =A6*C6
E8 : =2541*0,302635
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Excel rechnet doch richtig :-))))


Gruß aus Mainz / Sonnenpeter


Bild


Betrifft: AW: Excel rechnet falsch von: theo
Geschrieben am: 11.03.2005 20:40:56

Danke an Peter und Sonnenpeter.
Es lag wohl am RUNDEN - jetzt klappts!!!

Gruß
theo


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Excel rechnet falsch"