Matrix von WVERWEIS auf 2 Blätter erweitern?

Bild

Betrifft: Matrix von WVERWEIS auf 2 Blätter erweitern? von: strehler
Geschrieben am: 13.03.2005 23:22:12

Hallo, ich suche eine Formel, die mir einen vorgegebenen Zellwert in bestimmten Bereichen aus 2 Blättern sucht.
Soweit funktioniert das Ganze mit einem Registerblatt:

=WVERWEIS(A1;BlattA!$G$2:$BE$316;315;FALSCH)

Da Excel beschränkt in den Spalten ist, benötige ich 2 Registerblätter, die im Prinzip gleich aufgebaut sind, quasi BlattA und BlattB

mein Zellwert A1 befindet sich nun entweder im BlattA, Zeile 2 Spalte G bis BE
oder in BlattB, ebenfalls Zeile 2 Spalte G bis BE.

Die Suche sollte also folgendermaßen ablaufen, wenn angenommen wird, dass in den Zellen laufende Zahlen von 1 bis 150 stehen und die gesuchte Zahl A1= 99 ist:

Matrix in BlattA abgrasen, dort sind aber nur die Zahlen 1 bis 75, folglich die Matrix in BlattB abgrasen und schließlich den Wert 99 finden und schließlich den entsprechenden Ausgabewert ausgeben


Danke für Vorschäge!

Marcus

Wie kann ich das in Excel realisieren, wenn ich nicht auf die verdrehung von Spalten und Zeilen ausweichen kann

Bild


Betrifft: AW: Matrix von WVERWEIS auf 2 Blätter erweitern? von: Boris
Geschrieben am: 13.03.2005 23:26:56

Hi Marcus,

=WVERWEIS(A1;WENN(ZÄHLENWENN(BlattA!G2:BE2;A1);BlattA!G2:BE316;BlattB!G2:BE316);2;0)

Grüße Boris


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Matrix von WVERWEIS auf 2 Blätter erweitern?"