Zeitberechnung

Bild

Betrifft: Zeitberechnung von: reimar
Geschrieben am: 14.03.2005 02:56:29

Da wir 4 Verschiedene Arbeits zeiten haben suche ich eine Wenn-Formel mit der ich z.b.
Früh, Zelle A1=05:50, A2=14:00. A3=Wenn A2 größer A1 dann A2-A1.
Spät, Zelle A1=13:50, A2=22:00. A3=Wenn A2 größer A1 dann A2-A1.
NACHT,Zelle A1=21:50, A2=06:00. A3=Wenn A1 größer A2 Dann A2+24:00-A1.
Tag, Zelle A1=07:00, A2=15:12. A3=Wenn A1=07:00 dann A2-0:30-A1.
Diese 4 Wenn Funktionen müssen alle auf einmal in die Zelle A3 geschrieben
werden, da an beliebigem Datum jeder der 4 Fälle eintreten kann.
Zum zweiten ist es mir nicht gelungen mit der Wenn Funktion
die Uhrzeit ( Wenn A1=07:00 ) zu vergleichen. Doch ich brauche dies um die (Pause 0:30 ) die nur im Tagesdienst anfällt, abzuziehen.

Für Vorschläge oder Lösungen wäre ich sehr dankbar.

mfg Reimar

Bild


Betrifft: AW: Zeitberechnung von: Jörg Gradert
Geschrieben am: 14.03.2005 06:54:31

Hallo Reimar,
Uhrzeit ist eine Formatierung innerhalb der Zelle, als Nachkommateil des Datumformats.
Datum,Uhrzeit
Gib mal eine Uhrzeit in eine Zelle ein und formatiere diese danach im Menü Format, Zellen Zahlen, auf Standard zurück, dann wird es klar.
1 Tag hat 24 Stunden 24:00=0:00=1
12:00=0,5 07:00=7/24 21:50=1310/60/24=131/6/24 'hier muss in Minuten umgerechnet werden, da Minuten im Spiel sind.
Eine weitere Möglichkeit ist es =WERT("07:00") oder WERT("21:50") zu schreiben, um den Zahlenwert zu erhalten.

Deine Formel braucht nur 2 WENN(), da die Berechnung für Früh und Spät gleich ist, habe ich diesen Teil als sonst für alles was nicht Tag oder Nacht ist gesetzt.
Ich hab mal einen Mix gemacht, was die Uhrzeiten angeht.

=WENN(A1=7/24;A2-A1-1/48;WENN(A1=WERT("21:50");A2+1-A1;A2-A1))

Ich hoffe es stimmt so.

Gruß Jörg


Bild


Betrifft: AW: Zeitberechnung von: reimar
Geschrieben am: 14.03.2005 22:33:40

hallo Jörg
Haut hin,
Ich bin happy
Danke


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zeitberechnung"