Formel für AutoFilter

Bild

Betrifft: Formel für AutoFilter
von: Thomas
Geschrieben am: 05.04.2005 13:39:05
Hi, habe folgendes Problem: Nach der AutoFilter-Selektion in "Daten" soll das Ergebnis in die entsprechenden Felder in "Auswertung" übertragen werden. Nach
Selection.AutoFilter Field:=2, Criteria1:="SSS"
Selection.AutoFilter Field:=3, Criteria1:="abc"
müsste also in Feld C3 von "Auswertung" eine "4" stehen usw. Die jetzige Formel leistet das leider nicht. Jemand eine Idee?
https://www.herber.de/bbs/user/20709.xls
Herzlichen dank.

Bild

Betrifft: AW: Formel für AutoFilter
von: Volker
Geschrieben am: 05.04.2005 13:45:28
Hallo Thomas,
welche Formel meinst Du ?
C3 ist jedenfalls leer.
Was soll denn da gezählt werden?
Gruß
Volker
Bild

Betrifft: AW: Formel für AutoFilter
von: Thomas
Geschrieben am: 05.04.2005 13:49:24
Im Feld C3 müsste die Formel "=TEILERGEBNIS(3;Daten!C2:C25)" stehen. Wenn ich im ersten Arbeitsblatt "Daten" über den AutoFilter erst in B die Variable "SSS", dann in C "abc" auswähle, also
Selection.AutoFilter Field:=2, Criteria1:="SSS"
Selection.AutoFilter Field:=3, Criteria1:="abc"
bekomme ich als Ergebnis "4 von 24 Datensätzen". Diese Zahl soll im Arbeitsblatt "Auswertung" im Feld C3 erscheinen. Im Moment erscheint dort eine 24.
Bild

Betrifft: AW: Formel für AutoFilter
von: Volker
Geschrieben am: 05.04.2005 13:58:02
Hallo Thomas,
Wie gesagt, C3 in Deiner Bsp.-Mappe ist leer
Wenn ich Deine Formel da eintrage, klappt es einwandfrei.
Gruß
Volker
Bild

Betrifft: AW: Formel für AutoFilter
von: Thomas
Geschrieben am: 05.04.2005 14:04:27
Jupp, hast Recht. Kann die eigenen Formeln nicht anwenden...
Bild

Betrifft: AW: Formel für AutoFilter
von: Thomas
Geschrieben am: 05.04.2005 14:13:09
Moment. Angezeigt wird das Ergebnis jeder beliebigen AutoFilter-Selektion. Gerne würde ich
in C3 das Ergebnis der Selektion SSS-abc,
in D3 das Ergebnis der Selektion SSS-def und
in E3 das Ergebnis der Selektion SSS-ghi angezeigt bekommen.
Wie kann ich die ausgewählten Variablen in die Formel einbauen oder die Formel mit dem jeweils ausgewählten Makro verbinden?
MfG
Bild

Betrifft: AW: Formel für AutoFilter
von: Volker
Geschrieben am: 05.04.2005 14:25:00
kopier folgende Formel in C3. Du mußt die Eingabe mit Ctrl + Shift + Ret abschließen.
in der Bearbeitungszeile steht die Formel dann in geschweiften Klammern als Zeichen, dass es sich um eine Matrixformel handelt.
=SUMME((Daten!$B2:$B25=$A$1)*(Daten!$C2:$C25=RECHTS(C$2;3)))
Nach rechts bis E3 ziehen fertig.
Das ganze kannst Du natürlich in den nächsten Zeilen für III und PPP auch machen.
Gruß
Volker
Bild

Betrifft: AW: Formel für AutoFilter
von: Thomas
Geschrieben am: 05.04.2005 14:32:45
Hi, erstmal herzlichen Dank. Klappt leider noch nicht ganz. Crtl ist nicht das gleiche wie Strg? Wo müsste ich denn händisch die geschweiften Klammern eintragen?
MfG, Thomas
Bild

Betrifft: Sorry, alte Gewohnheit: CTRL=STRG (o.T.)
von: Volker
Geschrieben am: 05.04.2005 14:38:46
.
Bild

Betrifft: AW: Formel für AutoFilter
von: Thomas
Geschrieben am: 05.04.2005 14:44:58
Yes. Wirklich sehr geholfen. Vielen Dank.
Bild

Betrifft: war mir ein Vergnügen
von: Volker
Geschrieben am: 05.04.2005 14:46:32
.
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formel für AutoFilter"