wenndann-fkt

Bild

Betrifft: wenndann-fkt
von: Hans
Geschrieben am: 09.04.2005 13:46:53
Hallo Excel-Gemeinde,
folgendes klappt bei mir nicht: In Tabelle1 stehen meine Rohdaten, die ich in Tabelle 2 kopiert habe. In Tabelle 2 sollen diesen Rohdaten, in diesem Fall Gesellschaftsnr, gleichzeitig die entsprechende Bezeichnung zugewiesen werden, die in Tabelle 3 aufgeführt ist. Geht so was mit einer wenndann-Fkt oder muss ich da ein Makro programmieren?
Gruß, Hans
https://www.herber.de/bbs/user/20910.xls

Bild

Betrifft: AW: wenndann-fkt
von: Ramses
Geschrieben am: 09.04.2005 13:51:42
Hallo
Ohne deine DAtei angeschaut zu haben, würde ich behaupten das ist ein klassischer Fall für SVERWEIS()
Tabelle1
 ABCDEF
1NrName  NrName
21A  1A
3    2B
4    3C
5      
Formeln der Tabelle
B2 : =SVERWEIS(A2;E2:F4;2;0)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruss Rainer
Bild

Betrifft: AW: wenndann-fkt
von: Hans
Geschrieben am: 09.04.2005 13:55:18
Und wie sähe die Formel aus, wenn, wie in diesem Fall, die Daten, die bei Dir jetzt in Sp. E und F sind, sich zwar in derselben Datei, aber in einer anderen Tabelle befinden?
Bild

Betrifft: AW: wenndann-fkt
von: Ramses
Geschrieben am: 09.04.2005 13:57:15
Hallo
Wo liegt das Problem ?
Du musst doch bloss den Bereich auf der anderen Tabelle angeben ?
Anstelle von "E2:F4" nur den Bereich auf der andren Tabelle markieren, den Rest der Formel eingeben und fertig.
Die Online-Hilfe ist dazu sehr hilfreich :-)
Gruss Rainer
Bild

Betrifft: AW: wenndann-fkt
von: Hans
Geschrieben am: 09.04.2005 14:07:48
Hm, tut mir ja leid. Habe "Kaum Excel-Kenntnisse" aber auch nicht einfach so angekreuzt. Formel funktioniert bei mir natürlich auch nicht:
=SVERWEIS(Tabelle1!A2;Tabelle3!A2;Tabelle3!B6;2;0)
Irgendwie stimmt der Spaltenindex nicht. Tabelle geht aber bis B6. Weiss nicht weiter.
Gruß, Hans
Bild

Betrifft: AW: wenndann-fkt
von: Ramses
Geschrieben am: 09.04.2005 14:09:30
Hallo
Die Formel stimmt,
Was funktioniert denn nicht ?
Gruss Rainer
Bild

Betrifft: AW: wenndann-fkt
von: Hans
Geschrieben am: 09.04.2005 14:13:38
Erst kommt der Warnhinweis "Zu viele Argumente". Dann bin ich wie verlangt auf das Gleichheitszeichen in der Formelleiste. Suchkriterium und Matrix sind OK, aber bei Spaltenindex steht #WERT! Sind ganz normale Buchstaben, die in B2-6 stehen, wie in Deinem Bsp auch.
Bild

Betrifft: AW: wenndann-fkt
von: Ramses
Geschrieben am: 09.04.2005 14:16:14
Hallo
ich erkenne das Problem nicht wirklich.
Deine Daten stehen auf Tabelle 2
Tabelle1
 ABC
1NrName 
21A 
3   
Formeln der Tabelle
B2 : =SVERWEIS(A2;Tabelle2!A2:B6;2;0)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruss Rainer
Bild

Betrifft: AW: wenndann-fkt
von: Reinhard
Geschrieben am: 09.04.2005 14:14:04
Hallo Hans,
probiers mal so
=SVERWEIS(Tabelle1!A2;Tabelle3!A2:B6;2;0)
Viele Grüße
Reinhard
Bild

Betrifft: AW: wenndann-fkt
von: Hans
Geschrieben am: 09.04.2005 14:27:32
Ja, jetzt klappt es. Mußte nur einige Dollarzeichen einfügen.
=SVERWEIS(Tabelle1!A2;Tabelle3!$A$2:$B$6;2;0)
Herzlichen Dank, Reinhard! Den S-Verweis werde ich mir merken.
VG, Hans
 Bild

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS: Ausgabe von mehreren Spaltne"