Hyperlink in Wenn-Bedingung

Bild

Betrifft: Hyperlink in Wenn-Bedingung
von: Andi
Geschrieben am: 13.04.2005 11:52:40
Hallo an aller Excel-Experten,
ich brauch dringend Euere Unterstützung!!!
Bitte, bitte,...
Habe folgendes Problem:
Es besteht eine Excel-Datei mit mehreren Vorlageblätter (Tabellenblätter).
Wird ein Eintrag im Übersichtenblatt geschrieben so wird aus der Vorlage ein neues Blatt erzeugt und ein Hyperlink hinzugefügt (via Makro). Das funktioniert.
Allerdings benötige ich eine Information (ein "ja") als Bedingung aus dem neu erzeugten Blatt, um eine Wenn-Bedingung auszuführen.
Frage: Wie binde ich den Link in die Wenn-Bedingung ein?
PS: die neu eingefügten Blätter haben immer unteschiedliche Namen
Wenn Ihr mehr Infos braucht, dann lasst es mich wissen...
Wenn-Bedingung (=wenn("hier Hyperlink zum neu-erzeugten Blatt" !H2="ja";"x";"")
Bitte wenn Ihr ´ne Idee habt, dann wäre ich echt glücklich....

Bild

Betrifft: AW: Hyperlink in Wenn-Bedingung
von: Herbert
Geschrieben am: 15.04.2005 16:34:53
von Boris:
Einfügen - Name - Definieren, Name: x
Bezieht sich auf:
=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())
Schreibe in dein Übersichtsblatt in irgendeine Zelle diese Formel und kopier sie weit genug runter:
=WENN(ZEILE(A1)>ANZAHL2(x);"";HYPERLINK("#'"&INDEX(x;ZEILE(A1))&"'!A1";TEIL(INDEX(x;ZEILE(A1));FINDEN("]";INDEX(x;ZEILE(A1)))+1;31)))
Somit listest du alle Blätter auf und verlinkst sie gleichzeitig auf A1.
Alternativ kannst du in einem separaten Bereich alle Blätter (ohne gleichzeitige Verlinkung) auflisten, um dann mittels Gültigkeitsliste darauf zurückzugreifen.
Vorgehensweise:
Zunächst den Namen "x" vergeben (wie bereits beschrieben).
Dein Übersichtsblatt nenn ich mal "Übersicht".
Schreibe in H1:
=TEIL(INDEX(x;ZEILE(A1));FINDEN("]";INDEX(x;ZEILE(A1)))+1;31)
und kopier das soweit runter, bis #BEZUG! erscheint.
Anschließend definiere einen weiteren Namen, Name: y
Bezieht sich auf:
=INDIREKT("Übersicht!H1:H"&ANZAHL2(Übersicht!$H:$H)-ZÄHLENWENN(Übersicht!$H:$H;Übersicht!#BEZUG!))
Jetzt selektiere eine Zelle für die Gültigkeit - sagen wir C1.
Dann Daten-Gültigkeit-Liste-Quelle: =y
Und jetzt selektiere noch eine Zelle für den Hyperlink - sagen wir E1.
Dort muss dann diese Formel rein:
Wechsel zu Blatt 
Im Ergebnis wird in E1 immer ein Hyperlink erstellt, der auf das Blatt verlinkt, welches mittels der Gültigkeitsliste in C1 ausgewählt wurde.

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Hyperlink in Wenn-Bedingung"