Herbers Excel-Forum - das Archiv

Zahl kategorisieren

Bild

Betrifft: Zahl kategorisieren
von: Eisbaer

Geschrieben am: 18.12.2006 18:17:17
Liebe Leute vom Fach,
ich habe in Spalte A ein Geburtsdatum eingetragen (22.07.1963),
Excel errechnet mir in Spalte B per bedingter Formatierung das Alter in Jahren (in diesem Fall 43)und jetzt folgen 5 Spalten:
unter 25 Jahre
26-40 Jahre
41-50 Jahre
51-60 Jahre
über 60 Jahre
Wie muss ich (ohne VBA-Kenntnisse) tun, damit Excel mir eine "1" in die richtige Spalte schreibt?
Viele Grüße und Dank im Voraus!
Bild

Betrifft: AW: Zahl kategorisieren
von: Matthias G

Geschrieben am: 18.12.2006 18:24:04
Hallo Eisbaer,
mit WENN() und UND():
Tabelle1
 BCDEFG
1Alterunter 2626-4041-5051-60>60
243  1  
Formeln der Tabelle
C2 : =WENN(B2<26;1;"")
D2 : =WENN(UND(B2>25;B2<41);1;"")
E2 : =WENN(UND(B2>40;B2<51);1;"")
F2 : =WENN(UND(B2>50;B2<61);1;"")
G2 : =WENN(B2>60;1;"")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Allerding war zwischen "unter 25" und "26-40" eine Lücke, nämlich genau 25.
Gruß Matthias
Bild

Betrifft: AW: Zahl kategorisieren
von: Ulf M

Geschrieben am: 18.12.2006 18:29:17
Hallo Eisbaer
Mache es doch mit Formel
unter 25 =WENN($B2<25;1;"")
26-40 Jahre =WENN(UND($B2>25;$B2<41);1;"")
41-50 Jahre =WENN(UND($B2>40;$B2<51);1;"")
51-60 Jahre =WENN(UND($B2>50;$B2<61);1;"")
über 60 Jahre =WENN($B2>60;1;"")
mfg Ulf
Bild

Betrifft: AW: Zahl kategorisieren
von: HermannZ

Geschrieben am: 18.12.2006 18:49:01
Hallo Eisbär;
oder mit einer Formel;
Beispiel;
Leer
 ABCDEF
7 unter 25 Jahre26-40 Jahre41-50 Jahre51-60 Jahreüber 60 Jahre
822.07.1963  1  
920.01.1949   1 
10      
11 Formel nach rechts    
12 und nach unten    
13 kopieren    
Formeln der Tabelle
B8 : =WENN(VERGLEICH(DATEDIF($A8;HEUTE();"Y");{25.26.41.51.60};1)=SPALTE(A1);1;"")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß HermannZ
Bild

Betrifft: AW: Zahl kategorisieren
von: Eisbaer

Geschrieben am: 18.12.2006 19:48:06
Zunächst danke an Euch 3,
ich habe mal mit der ersten Variante von Matthias G. angefangen, das funktioniert fast. Danke übrigens für den Hinweis mit der 26:). In den ersten Altersspalten funktioniert es wunderbar. Lediglich in der Rentnerzeile "über 60" habe ich ein Problem eingebaut, weiß aber nicht welches: Wenn ich die Formel eingebe und bestätige, zeigt mir Excel immer die Formel in der Zelle, statt sie leer zu lassen. Was hab ich da falsch formatiert?
Viele Grüße vom Eisbaer.
Bild

Betrifft: AW: Zahl kategorisieren
von: Ulf M
Geschrieben am: 18.12.2006 20:49:34
Hallo
Deine zelle ist bestimmt als text formatiert.
formatiere sie als standart.
mfg Ulf
 Bild