Microsoft Excel

Herbers Excel/VBA-Archiv

TAGE360 | Herbers Excel-Forum


Betrifft: TAGE360 von: Roger Berchtold
Geschrieben am: 07.01.2010 19:30:11

Hallo zusammen

Ich habe in Zelle A1 das Anfangsdatum 27.10.2008 in Zelle A2 das Enddatum 08.01.2010.
In den Zellen A4 01.01.2005 und B4 31.12.2009
In den Zellen A5 01.01.2010 und B5 31.12.2020

Ich habe folgende Formel zum berechen:

=WENN(UND($A$1<B4;$A$2>B4);TAGE360($A$1;B4);WENN(UND($A$1<B4;$A$2<A5);TAGE360($A$2;B4);0) )

Diese Formel gebe ich in C4-C5 ein.
In C4 rechnet es mir richtig 424 Tage aber in C5 nur 0 Tage anstatt richtig 8 Tage
Was muss ich an der Formel abändern damit es klappt?
Danke und Gruss
Roger

  

Betrifft: AW: TAGE360 von: Frank H.
Geschrieben am: 07.01.2010 20:11:25

Hallo!

Lade doch einmal 'ne Beispieldatei hoch!!!

gruß Frank H.


  

Betrifft: AW: TAGE360 von: Roger Berchtold
Geschrieben am: 07.01.2010 20:34:04

Hallo Frank
hier mal die Datei
https://www.herber.de/bbs/user/67060.xlsx

Gruss
roger


  

Betrifft: AW: TAGE360 von: Frank H.
Geschrieben am: 07.01.2010 20:43:34

Hallo!

Hilft mir nicht, da ich mit 2003 arbeite!!!

Gruß!


  

Betrifft: AW: TAGE360 von: Roger Berchtold
Geschrieben am: 07.01.2010 20:49:15

Sorry
versuchs mal hiermit
https://www.herber.de/bbs/user/67061.xls

ich muss normalerweise auch mit 2003 arbeiten hab nur zu hause das neuste.
Gruss
Roger


  

Betrifft: wieso soll dies 8 ergeben? von: Tino
Geschrieben am: 07.01.2010 21:18:33

Hallo,
die zweite Bedingung ist erfüllt also.

TAGE360($A$2;B5) = TAGE360(08.01.2010;31.12.2020)

Gruß Tino


  

Betrifft: AW: wieso soll dies 8 ergeben? von: Roger Berchtold
Geschrieben am: 07.01.2010 21:25:38

Hallo

Ja es muss 8 ergeben weil ja das Enddatum der 08.01.2010 ist.
Es soll mir ja zuerst die Tage vom 27.10.08 bis ende 2009 rechnen dann noch ab 01.01.2010.

In den verschiedenen zeitrümen hab ich ja auch verschiedene Zinssätze.

Gruss
Roger


  

Betrifft: Bedingung nicht erfüllt von: Tino
Geschrieben am: 07.01.2010 20:14:24

Hallo,
weil in der zweiten Wenn die zweite Und Bedingung nicht erfüllt ist.



Gruß Tino


  

Betrifft: AW: Bedingung nicht erfüllt von: Roger Berchtold
Geschrieben am: 07.01.2010 20:35:41

Hallo Tino
hab mal in Zelle A6 auch ein Datum eingetragen und zwar den 01.01.2021, trotzdem wird nichts ausgegeben.
Gruss
Roger


  

Betrifft: AW: Bedingung nicht erfüllt von: BoskoBiati
Geschrieben am: 07.01.2010 21:47:33

Hallo Roger,

und was ist das:

Tabelle2

 ABC
127.10.2008  
208.01.2010  
3   
401.01.200531.12.2009424
501.01.201031.12.202043561
601.01.2021  

Formeln der Tabelle
ZelleFormel
C4=WENN(UND($A$1<B4;$A$2>B4); TAGE360($A$1;B4); WENN(UND($A$1<B4;$A$2<A5); TAGE360(A2;B4); 0))
C5=WENN(UND($A$1<B5;$A$2>B5); TAGE360($A$1;B5); WENN(UND($A$1<B5;$A$2<A6); TAGE360(A3;B5); 0))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß

Bosko


  

Betrifft: AW: Bedingung nicht erfüllt von: Roger Berchtold
Geschrieben am: 07.01.2010 21:52:24

Hallo Bosko

Leider auch nicht. Es muss in C5 die Zahl 8 rauskommen. Denn Total sollen es ja 431 Tage sein.
Gruss
Roger


  

Betrifft: AW: Bedingung nicht erfüllt von: BoskoBiati
Geschrieben am: 07.01.2010 23:54:12

Hallo Roger,

mir ging es nur um diesen Satz:

hab mal in Zelle A6 auch ein Datum eingetragen und zwar den 01.01.2021, trotzdem wird nichts ausgegeben.
Das ist laut meiner Tabelle falsch. Ansonsten denke ich, dass Deine Formel falsch ist. Du solltest Dir Deine Bedingungen ansehen.
=WENN(UND($A$1B4); TAGE360($A$1;B4); WENN(UND($A$1 k B4;$A$2 k A5); TAGE360(A4;$A$2)+1; 0)) 


Setze anstelle der k einfach "<" ein. Die Forumssoftware verschluckt sonst die halbe Formel.


  

Betrifft: AW: Bedingung nicht erfüllt von: Roger
Geschrieben am: 08.01.2010 07:37:22

Hallo Bosko

Leider geht deine Formel auch nicht. Es kommt der Fehler #WERT!.

Hab es jetzt mal so gelöst. in Feld C1 die Formel

=WENN(UND($A$1<B4;$A$2>B4);TAGE360($A$1;B4);WENN(UND($A$1<B4;$A$2<A5);TAGE360($A$2;B4);0) )

Dann in Feld F4 diese Formel
=TAGE360(A1;A2;WAHR)
Dann in Feld C5 =F4-C4


Damit erhalte ich die richtige Anzahl Tage meine ich. Muss es aber noch ausgiebig testen.
Falls du eine andere Lösung hast wäre ich dir dankbar.

Besten Dank für die Hilfe
Gruss
Roger