Feiertage holen+eintragen



Excel-Version: 97
nach unten

Betrifft: Feiertage holen+eintragen
von: MikeS
Geschrieben am: 06.05.2002 - 16:17:07

Hallo Leute,

ich habe zwei Tabellen mit Daten:

Tabelle Feiertage
Datum-----Feiertag
01.05.02--Maifeiertag
09.05.02--Himmelfahrt
usw.


Tabelle Arbeitszeitberechnung


MS Excel von MikeS
 ABC
1DatumZuBesuchendesProjekt 
2Mi-01.05.02Maifeiertag
3Do-02.05.02Köln
4Fr-03.05.02München 
5Mo-06.05.02Hamburg 
6Di-07.05.02Mainz 
7Mi-08.05.02Köln 
8Do-09.05.02Himmelfahrt 
9Fr-10.05.02Hamburg 
10usw. 


In "C4" (Tabelle Arbeitszeitberechnung) wird mittels Kombi-Feld immer der 1. jeden Monats reingeschrieben und dann mit MMMM-JJJJ formatiert.

Ändert sich der Wert in "C4" soll ab "A8" abwärts geprüft werden, ob es sich um einen Feiertag (s.Tabelle Feiertage) handelt.

Ist das der Fall, soll der jeweilige Feiertag in die rechte Nachbarzelle geschreiben werden (s.obige Tabelle "Feiertage").

Vielleicht hat ja jemand eine Idee.

Vielen Dank
MikeS








nach oben   nach unten

Re: Feiertage holen+eintragen
von: Hajo
Geschrieben am: 06.05.2002 - 16:33:29

Hallo Mike

so ganz ist mir das nicht klar , aber vielleicht hilft folgendes.
Gebe dem Bereich (A2:B9) den Namen Feiertag. Steht Dein Datum in B10 dann folgende Formel
=WENN(ISTFEHLER(SVERWEIS(B10;Feiertage;2;0));"";SVERWEIS(B10;Feiertage;2;0))

Gruß Hajo

nach oben   nach unten

nochmal eine Erklärung
von: MikeS
Geschrieben am: 06.05.2002 - 16:50:15

Hallo Hajo,

in Tabelle Feiertage stehen z.B.:

A1=Datum B1=Feiertage
A2=01.05.02 B2=Maifeiertag
A3=09.05.02 B3=Himmelfahrt

In Tabelle Arbeitszeitberechnung soll, wenn der Wert in C4 geändert wird, von A2:A8 geprüft werden, ob ein Feiertag (s.Tabelle Feiertage) dabei ist.

Wenn das der Fall ist, soll in der Nachbarzelle (rechts neben der Fundzelle) der gefundene Feiertag (z.B. Maifeiertag) eingetragen werden.

Alles klar???

Danke MikeS

nach oben   nach unten

Re: nochmal eine Erklärung
von: Hajo
Geschrieben am: 06.05.2002 - 16:51:46

Hallo Mike

hast Du meinen Vorschlag getestet??? Ich sehe noch keine andere Fragestellung??

Gruß Hajo


nach oben   nach unten

Re: nochmal eine Erklärung
von: MikeS
Geschrieben am: 06.05.2002 - 16:54:28

Hallo Hajo,

ich habs probiert, komme aber mit der Formel nicht klar.

Ciao Mike


nach oben   nach unten

Re: nochmal eine Erklärung
von: Hajo
Geschrieben am: 06.05.2002 - 17:02:47

Hallo Mike

wo liegt das Problem.

Hast Du dem Bereich einen Namen gegeben???

Gebe dem Bereich (A2:B9) den Namen Feiertag. Steht Dein Datum in B10 dann folgende Formel
=WENN(ISTFEHLER(SVERWEIS(B10;Feiertage;2;0));"";SVERWEIS(B10;Feiertage;2;0))


Auf dem Bereich wird in der Formel bezug genommen. Wird deer Tag nicht gefunden (istFehler) erscheint "" ansonsten der Wert neben dem Datum im Bereich Feiertag.

Gruß Hajo

nach oben   nach unten

Re: nochmal eine Erklärung
von: MikeS
Geschrieben am: 06.05.2002 - 17:10:33

Hallo Hajo,

das Problem ist, daß in A2:A9 Formeln stehen, die mir die Werktage (ohne Sa/So) in die Zellen schreiben.

In A2 steht: =WENN(WOCHENTAG(C4;2)>=6;C4+8-WOCHENTAG(C4;2);C4)

in A3 steht: =WENN(A7<>"";WENN(WOCHENTAG(A7;2)=5;WENN(MONAT(A7+3)=MONAT(A7);A7+3;"");WENN(MONAT(A7+1)=MONAT(A7);A7+1;""));"")
usw.

Wo soll ich Deine Formel reinschreiben???

Danke Dir.
Ciao MikeS

nach oben   nach unten

Re: nochmal eine Erklärung
von: Hajo
Geschrieben am: 06.05.2002 - 17:21:32

Hallo Mike

irgendwas ist jetzt untergegangen
in A2 bis Axx steht Dein Datum und in B2 bis Bxx soll das Wort Feiertag falls das Datum einer ist???

Gruß Hajo


nach oben   nach unten

Info an Hajo
von: MikeS
Geschrieben am: 06.05.2002 - 19:48:10

Hallo Hajo,

Du hast das richtig verstanden.

In A2 bis Axx steht mein Datum und in B2 bis Bxx soll der jeweilige Feiertag (z.B. Maifeiertag, Himmelfahrt)
und nicht nur der Text "Feiertag" stehen, falls das Datum einer ist.

Vielen Dank für Deine Mühe.

Ciao Mike



nach oben   nach unten

Re: Info
von: Hajo
Geschrieben am: 06.05.2002 - 20:01:17

Hallo Mike

da kann ich nur wieder Fragen ob Du dich an mein Anleitung gehalten hast, wenn in Deiner Ausgangsliste für die Feiertage nicht Feiertag steht sonder z.b. Neujahr dann wird dieser Wert auch eingetragen.

Gruß Hajo


nach oben   nach unten

Re: Info
von: MikeS
Geschrieben am: 06.05.2002 - 20:25:26

Hallo Hajo,

Deine Formel habe ich noch nicht ausprobiert, weil ich
in SpalteB keine Formel reinschreiben möchte (verwirrt meine Kollegen) und
auch manuelle Einträge möglich sein sollen, falls kein Feiertag.

Deine Formel müßte ich ja dann nach unten kopieren und schützen...
Dann ist aber kein überschreiben mehr möglich, ohne den Schutz aufzuheben.

Die Lösung meines Problems ist wahrscheinlich nur mit VBA möglich?

Trotzdem danke Hajo



nach oben   nach unten

Re: Info
von: Hajo
Geschrieben am: 06.05.2002 - 20:28:00

Hallo Mike

ich mach jetzt Schluß, nach so vielen Beiträgen fällt Dir ein das es keine Formel sein soll.

Ist schon eine Leistung.

Gruß Hajo


nach oben   nach unten

Sorry
von: MikeS
Geschrieben am: 07.05.2002 - 08:05:27

Hallo Hajo,

das war doch keine böse Absicht von mir!!!
Ich konnte aber vorher nicht ahnen, daß mit einer Formel wahrscheinlich mein Problem nicht zu lösen ist.

Ich bin eben noch nicht so routiniert in Sachen Excel/VBA.
Du bist ein "Vielbeantworter" im Forum und ich weiß das echt zu schätzen.

Sorry nochmal, ciao MikeS

Aus diesem Grund möchte ich mich nochmal für Deine Mühe bedanken.


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Feiertage holen+eintragen"