Zellwert bei Dubletten-Vorkommen auf Null stellen

Bild

Betrifft: Zellwert bei Dubletten-Vorkommen auf Null stellen
von: diso_de
Geschrieben am: 14.02.2005 20:28:35
Guten Abend zusammen,
es wäre nett wenn mir jemand helfen und aufzeigen könnte, wie ich das nachstehende Problem lösen kann.
Ein herzliches Dankeschön schon mal vorab!
Gruß
Dieter

Hier die Ausgangssituation:
Ich habe ein Excel-File (zsdr0035). Darin befindet sich unter anderem ein Tabellenblatt mit dem Namen (Kontrakte gesamt).
Die Daten im Tabellenblatt (Kontrakte gesamt) sollen nach der Kundennummer (Spalte A) aufsteigend sortiert werden. – 1te Gruppenstufe
Dann soll die SAP Materialnummer (Spalte C) innerhalb der Kundennummer (Spalte A) aufsteigend sortiert werden. – 2te Gruppenstufe
Bis dahin mit dem Makro-Recorder kein Problem, aber jetzt kommts:
Wenn die gleiche SAP Materialnummer (Spalte C) innerhalb der Kundennummer doppelt oder mehrfach vorkommt, und der Materialstatus (Spalte B) nicht (01, 02, 03, 04 oder 05) ist, soll der Lagerwert (Spalte D) bei den Folgesätzen auf Null gesetzt werden.
Zur Veranschaulichung habe ich das mal bildlich dargestellt, und die Zellen grau hinterlegt, die auf Null zu setzen wären.
Userbild

Bild

Betrifft: AW: Zellwert bei Dubletten-Vorkommen auf Null stellen
von: Ute
Geschrieben am: 14.02.2005 20:48:51
Können auch mehrere gleichartige Einträge vorkommen?
Am besten, du lädst mal eine Beispieltabelle hoch.
mfg Ute
Bild

Betrifft: AW: Zellwert bei Dubletten-Vorkommen auf Null stellen
von: diso_de
Geschrieben am: 14.02.2005 21:12:52
Hallo Ute,
die SAP Materialnummer (Spalte C) kann innerhalb der Kundennummer (Spalte A) theoretisch von 1 bis unendlich mal vorkommen.
Die Datei habe ich hochgeladen.
Gruß
Dieter
https://www.herber.de/bbs/user/18079.xls
Bild

Betrifft: AW: Zellwert bei Dubletten-Vorkommen auf Null stellen
von: Ute
Geschrieben am: 14.02.2005 22:01:50
Ich kann dir da nicht helfen.
mfg Ute
Bild

Betrifft: AW: Zellwert bei Dubletten-Vorkommen auf Null stellen
von: Hübi
Geschrieben am: 14.02.2005 22:14:18
Hi Dieter,
diese Formel in D1 und runterziehen
=WENN(ZÄHLENWENN(C$2:C2;C2)>1;0;WENN(ODER(B2="01";B2="02";B2="04");MIN((P2-T2);R2)*N2;R2*N2))
Gruß Hübi
Bild

Betrifft: AW: Zellwert bei Dubletten-Vorkommen auf Null stellen
von: Ute
Geschrieben am: 14.02.2005 23:08:12
Hi,
tolle Lösung!
mfg Ute
Bild

Betrifft: @ Ute
von: Hübi
Geschrieben am: 15.02.2005 16:52:09
Hi Ute,
ich habe doch gerade mal WENN(ZÄHLENWENN(C$2:C2;C2)>1;0; vor und eine Klammer hinter seine Formel gesetzt.
War also nicht gerade viel Aufwand.
Das hättest du auch geschafft - hast aber aufgegeben ;-(
Gruß Hübi
Bild

Betrifft: AW: @ Hübi
von: Ute
Geschrieben am: 15.02.2005 18:31:38
Hi,
hab erst anhand der Mappe gecheckt, dass es eine kommerzielle Anwendung ist,
daher hab ich gewollt aufgegeben.
mfg Ute
Bild

Betrifft: alles klar ...
von: Hübi
Geschrieben am: 15.02.2005 19:24:27
Hi Ute,
... aber hier im Forum gibt es sehr viele Beispiele für kommerzielle Anwendungen.
Bei größeren Sachen halte ich mich da auch zurück - z. B. wenn es heißt Ich hätte gern... und habe selbst keinen Plan, gaaaaaaaaaaaaanz dringend etc.
Gruß Hübi
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zellwert bei Dubletten-Vorkommen auf Null stellen"