Benötige Hilfe zum Spezialfilter

Bild

Betrifft: Benötige Hilfe zum Spezialfilter
von: Hubert Hanscher
Geschrieben am: 26.04.2005 01:02:58
Hallo liebe Excelgemeinde
Trotz mehrerer Versuche aus der Recherche oder Beispiedateien bzw. FAQ bin ich nicht in der Lage einen Spezialfilter zu erstellen. Ich versuche nun seit 2 Wochen eine eigentlich einfache Abfrage zu gestalten bzw. eine kleine Suchmaschine für meine Artikeldatenbank zu erstellen , um meiner Frau es einfacher bei der Artikelsuche zu machen. Leider bin ich bis heute kläglich gescheitert. In meiner Beispiedatei habe ich alles komplett aufgeführt , nur es passiert nichts, egal wie ich es anstelle. Bitte schaut euch doch meine Datei mal an. Für euch bestimmt ein leichtes. Ich musste allerdings meine Artikelliste kürzen da ansonsten die Datei zum hochladen zu groß war. Artikelliste umfasst 20000 Artikeleinträge . Gruß und Danke im Vorraus, Hubert
https://www.herber.de/bbs/user/21707.xls

Bild

Betrifft: liest Du eigentlich Deine alten postings??
von: th.heinrich
Geschrieben am: 26.04.2005 01:29:01
hallo Hubert,
https://www.herber.de/forum/archiv/600to604/t602715.htm#602733
gruss thomas
Bild

Betrifft: AW: Benötige Hilfe zum Spezialfilter
von: Hubert Hanscher
Geschrieben am: 26.04.2005 02:18:34
Hallo nochmals
Ich habe es ja mit mehreren Lösungen versucht , und auch meine Tabelle etwas umgestellt aber zum Erfolg bin ich immer noch nicht gekommen. Wenn dein Lösungsvorschlag zum Erfolg geführt hätte würde ich mir wohl kaum die Arbeit machen und nochmals um eine Lösung zu bitten. Wenn es für dich so einfach ist , dann stell doch bitte meine xls Datei so ein das es funktioniert. Vielleicht begreife ich es ja dann. Gruß Hubert

Bild

Betrifft: AW: Benötige Hilfe zum Spezialfilter
von: th.heinrich
Geschrieben am: 26.04.2005 11:23:28
hallo Hubert,
Du haettest ja wenigstens im 1. thread antworten koennen, dann bleibt die uebersicht erhalten was umgestellt wurde.
gehe genauso vor wie ich es dort beschrieben habe und trage in den Kriterienbereich unter bezeichnung K* ein
gruss thomas
Bild

Betrifft: AW: Benötige Hilfe zum Spezialfilter
von: Hajo_Zi
Geschrieben am: 26.04.2005 07:22:51
Hallo Hubert,
füge in Deiner Tabelle "Artikel 5 Leerzeilen ein (Zeile 1 bis 5) Kopiere aus Tabelle "Artikelsuche" Zeile 1 und 2 in Tabelle "Artikel", wähle Zelle A12 oder irgend eine Zelle in Deiner Tabelle. Daten, Filter, Spezialfilter, Wähle Kriterienbereich und markiere E1:E2, ok und sichtbare Zellen kopieren.

Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.



"Wer Rechtschreibfehler findet, darf sie behalten!" Dies gilt auch für Bert.
Bild

Betrifft: AW: Benötige Hilfe zum Spezialfilter
von: Hubert Hanscher
Geschrieben am: 26.04.2005 12:23:46
Hallo nochmals
Mein Problem ist leider immer noch nicht gelöst. In beiden Lösungsvorschlägen erhalte ich bei der letzten Eingabe im Spezialfilter die Fehlermeldung " Nur gefilterte Daten können in das aktive Blatt kopiert werden " .Ich habe auch diese Nacht wieder einmal versucht andere Beispieldateien auszuprobieren oder umzustellen, um dem Fehler auf die Schliche zu kommen.Immer wieder das gleiche Ergebniss. Kann es vielleicht sein das ich noch irgend etwas von der Office CD nach instalieren muss oder ein Add In benötige. Ich kann mir den Fehler ansonsten nicht erklären. Gruß Hubert
Bild

Betrifft: AW: Benötige Hilfe zum Spezialfilter
von: th.heinrich
Geschrieben am: 26.04.2005 13:06:19
hallo Hubert,
warum gehst Du nicht nach meinem 1. vorschlag vor??
ansonsten musst Du den Spezialfilter im blatt Ausgabebereich aufrufen.
gruss thomas
Bild

Betrifft: AW: Benötige Hilfe zum Spezialfilter
von: Hubert Hanscher
Geschrieben am: 26.04.2005 13:28:32
Hallo Thomas
Bin ich ja. Leider ohne Erfolg. Wie auch in letzten Posting beschrieben versuche ich alle Möglichkeiten. Mir würde es weiterhelfen wenn ihr mir meine hinterlegte Datei ( erstes Posting ) einrichtet wie ihr es mir beschrieben habt. Ansonsten finde ich meinen Fehler ja nie. Ich will es ja auch verstehen um Excel zu erlernen , aber irgendwo habe ich einen Denkfehler . So wird es wohl nie was. Gruß Hubert
Bild

Betrifft: AW: Benötige Hilfe zum Spezialfilter
von: Martin Beck
Geschrieben am: 26.04.2005 14:17:49
Hallo Hubert,
Du mußt den Spezialfilter aus dem Blatt aufrufen, in ds die Ergebnisse eingetragen werden sollen. In Deiner Beispieldatei also "Artikelsuche". Siehe auch
https://www.herber.de/forum/archiv/76to80/t78671.htm
Gruß
Martin Beck
Bild

Betrifft: besser kann ich es nicht mehr erklaeren
von: th.heinrich
Geschrieben am: 26.04.2005 15:27:01
hi Hubert,
https://www.herber.de/bbs/user/21733.xls
kopier die beschreibung vorm testen in ein anderes tab, denn es ist moeglich, dass sie durchs filtern verschwindet.
gruss thomas
ps. wie gesagt kannst Du fuer alle Bereiche wg. uebersicht auch Namen vergeben.
Bild

Betrifft: AW: besser kann ich es nicht mehr erklaeren
von: Hubert Hanscher
Geschrieben am: 26.04.2005 18:03:24
Hallo Thomas
Danke das du so lange am Ball bist und mir versuchst es plausibel zu machen. Ich bin jetzt 20 mal nach deiner Anleizung vorgegangen. Es funktioniert bei definitiv nicht. Es werden alle Artikel aufgelistet. Sobald ich versuche einen Suchbegriff ( ob mit oder Ohne * ) passiert gar nichts. Ich habe nach dem spezialfilter Datei gespeichert , geschlossen und wieder geöffnet. Nichts. Ich glaube mitlerweile noch nicht mal das ich zu dumm dazu bin , sondern das es etwas mit Excel zu tun hat. Vielleicht sollte ich mein Office mal de und wieder neu instalieren ? Ich versuche jetzt nochmals den Vorschlag aus dem letzten Posting, sollte dieses auch fehlschlagen , gebe ich auf.
Gruß Hubert
Bild

Betrifft: besser kann ich es nicht mehr erklaeren od. doch?
von: th.heinrich
Geschrieben am: 26.04.2005 19:25:14
hi Hubert,
hab das mal als makro aufgezeichnet, sieh hier.
https://www.herber.de/bbs/user/21742.xls
gruss thomas
Bild

Betrifft: AW: besser kann ich es nicht mehr erklaeren od. do
von: Hubert Hanscher
Geschrieben am: 26.04.2005 20:07:10
Hallo Thomas
Vor lauter grübeln über diesen blöden Spezialfilter habe ich den Makrorekorder vergessen. Habe das Problem mittels diesem selber gelöst. Danke nochmals und noch einen schönen Abend, Hubert
Bild

Betrifft: freut mich geholfen zu haben :-) mt.
von: th.heinrich
Geschrieben am: 26.04.2005 20:54:12
sers Hubert,
wie gesagt macht das makro nichts anderes als meine beschreibung ;-)
gruss thomas
Bild

Betrifft: AW: freut mich geholfen zu haben :-) mt.
von: Hubert Hanscher
Geschrieben am: 26.04.2005 21:46:23
Nochmals Hallo
Ja, dein Makro macht nichts anderes . Alles für mich logisch und nachvollziehbar. Allerdings macht mein Spezialfilter nicht das was es soll. Ich habe mir eben auch noch andere Spezialfilter Dateien runtergeladen , die nichts mit meinem Problem zu tun haben, die laufen bei mir ebenso wenig. Warum ? Keine Ahnung. Gruß und schönen Abend Hubert
Bild

Betrifft: mein Vorschlag:
von: Günther Oppold
Geschrieben am: 26.04.2005 12:33:15
Hallo Hubert,
mein Vorschlag mit Formeln:
in Spalte G ist eine ARRAY-Formel: die geschweifte Klammer nicht eingeben, sondern die Formeleingabe abschließen mit Strg+Umsch+Enter
Artikelsuche
 ABCDEFG
1NummerArtikelgruppeArtikelnummerGebindegroesseBezeichnungGebinde 
2    k <-- Auswahl
3       
4       
5Ergebnisse sollen schon ab dem 1. Buchstaben in " Bezeichnung " gelistet werden 
6       
7NummerArtikelgruppeArtikelnummerGebindegroesseBezeichnungGebinde 
8101100101100100Kontur SchwarzStück2
9101100101101100kraut, sauer-Stück3
10101100101102100Kontur BleiStück4
11101100101103100Kontur GoldStück5
12101100101110100Kontur RotStück6
13101100101111100Kontur OrangeStück7
14101100101114100KupferStück9
15      #ZAHL!
16      #ZAHL!
17      #ZAHL!
18      #ZAHL!
19      #ZAHL!
20      #ZAHL!
21      #ZAHL!
22      #ZAHL!
Formeln der Tabelle
A8 : =WENN(ISTFEHLER(INDIREKT(ADRESSE($G8;SPALTE();;;"Artikel")));"";INDIREKT(ADRESSE($G8;SPALTE();;;"Artikel")))
B8 : =WENN(ISTFEHLER(INDIREKT(ADRESSE($G8;SPALTE();;;"Artikel")));"";INDIREKT(ADRESSE($G8;SPALTE();;;"Artikel")))
C8 : =WENN(ISTFEHLER(INDIREKT(ADRESSE($G8;SPALTE();;;"Artikel")));"";INDIREKT(ADRESSE($G8;SPALTE();;;"Artikel")))
D8 : =WENN(ISTFEHLER(INDIREKT(ADRESSE($G8;SPALTE();;;"Artikel")));"";INDIREKT(ADRESSE($G8;SPALTE();;;"Artikel")))
E8 : =WENN(ISTFEHLER(INDIREKT(ADRESSE($G8;SPALTE();;;"Artikel")));"";INDIREKT(ADRESSE($G8;SPALTE();;;"Artikel")))
F8 : =WENN(ISTFEHLER(INDIREKT(ADRESSE($G8;SPALTE();;;"Artikel")));"";INDIREKT(ADRESSE($G8;SPALTE();;;"Artikel")))
G8 : {=KKLEINSTE(WENN(LINKS(Artikel!E$2:E$19;LÄNGE(Artikelsuche!E$2))=Artikelsuche!$E$2;ZEILE(E$2:E$19));ZEILE()-7)}
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
Günther
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Kilometerabrechnung mal anders die Zweite"