Microsoft Excel

Herbers Excel/VBA-Archiv

Platzhalter für beliebige Zahl

Betrifft: Platzhalter für beliebige Zahl von: Gallanz
Geschrieben am: 29.10.2012 22:49:35

Hallo,

ich verwende eine Wenn Formel um Werte nach bestimmten Zellinhalten zu summieren:

...(A1=B1)*(C1=D1)...

Jedoch benötige ich nicht immer beide Auswahlkriterien. Gibt es eine Möglichkeit z.B. den Wert in D1 so zu wählen, dass alle Werte in C1 die Bedingung erfüllen?

Ich habe in Spalte C die Werte 0&1, möchte diese in einem Fall jedoch ignorieren und dafür nicht die Formel extra umstellen.

PS: ich habe es mit * versucht, funktioniert aber nicht.

Gallanz

  

Betrifft: AW: Platzhalter für beliebige Zahl von: Uwe (:o)
Geschrieben am: 29.10.2012 23:36:07

Hallo Gallanz,
so ganz steige ich noch nicht dahinter.
Zeige mal die ganze Formel, und am Besten lade auch noch eine Beispielmappe hoch.

Gruß
Uwe
(:o)


  

Betrifft: Ist das logisch? von: Erich G.
Geschrieben am: 29.10.2012 23:40:12

Hi,
das hat IMHO nichts mit einem "Platzhalter für eine beliebige Zahl" zu tun.
Wenn alle Werte von C1 die Bedingung (C1=D1) erfüllen, kann man sie weglassen.

"Ich habe in Spalte C die Werte 0&1, möchte diese in einem Fall jedoch ignorieren"
In welchem Fall soll die Bedingung ignoriert werden, in welchem nicht?
Woher soll Excel das wissen? Es soll doch die Formel auswerten - immer...

Schreib doch mal deine Formel (den hier relevanten Teil, aber formal vollständig mit Dann- und Sonst-Zweig) hier auf
und ein paar konkrete Beispiele, an denen klar wird, was bei welchen Werten von A1,B1,C1,D1 herauskommen soll.

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: Ist das logisch? von: Gallanz
Geschrieben am: 30.10.2012 14:29:56

Ok, scheinbar habe ich mich nicht deutlich genug ausgedrückt.

Im Prinzip versuche ich 3 Fälle zu unterscheiden:

1. in Spalte C sollen nur Zeilen berücksichtigt werden, wenn eine 0 vorkommt
2. " " 1 vorkommt
3. egal was vorkommt

Für Fall 3 muss ich die Werte in Spalte D also so wählen, dass sowohl 0 als auch 1 berücksichtigt werden, jedoch ohne die Formel selbst zu ändern.


  

Betrifft: nicht scheinbar von: Erich G.
Geschrieben am: 30.10.2012 16:49:52

Hi,
du hast dich nicht scheinbar, sondern anscheinend, sogar tatsächlich nicht deutlich genug ausgedrückt.

A) Poste mal bitte deine Formel(n).

B) Was bedeutet "in Spalte C sollen nur Zeilen berücksichtigt werden"?
Wie, wobei, wodurch werden Zeilen "berücksichtigt"?

C) Was bedeutet "wenn eine 0 vorkommt"? Wo kann eine 0 vorkommen oder nicht?

D) Was bedeutet "vorkommen" hier? Z. B. kommt eine 0 in diesem Text vor: A00.

E) Ingesamt ist unklar, worin dein Problem eigentlioch besteht?
Geht es darum, dass du
- eine Formel in eine Zelle schreiben willst, aber die richtige Formulierung nicht findest?
- viele Formeln in einer Spalte unter einander schreiben willst?

Zitat:

Schreib doch mal deine Formel (den hier relevanten Teil, aber formal vollständig 
mit Dann- und Sonst-Zweig) hier auf und ein paar konkrete Beispiele, an denen klar wird, 
was bei welchen Werten von A1,B1,C1,D1 herauskommen soll.
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: Ist das logisch? von: Gallanz
Geschrieben am: 30.10.2012 17:51:55

Hier ein vereinfachte Version

Die Formeln sind Spalte N zu finden
Spalte O zeigt nur wie die Ergebnisse eigentlich aussehen sollten, wenn die Bedingung 2 immer wahr wäre.

https://www.herber.de/bbs/user/82395.xlsx


  

Betrifft: Trivial, aber eine Lösung von: Erich G.
Geschrieben am: 30.10.2012 18:58:29

Hi,
sollte das vielleicht so aussehen?

 ABCMNO
25Bedingung 1Bedingung 2  Formel 
261a  1515
271a  FALSCHFALSCH
281b  6565
291a  FALSCHFALSCH
301ba  115115
311b  FALSCHFALSCH
321a  165165
331b  FALSCHFALSCH
341a  215215

Formeln der Tabelle
ZelleFormel
B26=F26
N26=WENN(($A26=$E26)*($B26=$F26); SUMME(G26:K26))
O26=WENN(A26=E26;SUMME(G26:K26))
B27=F27
N27=WENN(($A27=$E27)*($B27=$F27); SUMME(G27:K27))
O27=WENN(A27=E27;SUMME(G27:K27))

Wenn du die Werte in Sp. B nicht gleich denen in Sp. F setzen willst/kannst - dann bleibt weiterhin unklar,
was du willst.

Wie soll Excel wissen, wann du das Ergebnis nach der Formel in N26 und wann nach der in O26 haben willst?
Du wirst das irgendwo angeben müssen, ob B und F eine Rolle spielen sollen oder nicht.
Aber vielleicht (s)passt ja mein Vorschlag für Spalte B...

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: Trivial, aber eine Lösung von: Gallanz
Geschrieben am: 30.10.2012 21:02:25

Hallo,

ich kann deinen Vorschlag nicht übernehmen, da ich mit einem großen Datensatz arbeite und deswegen keine Übersicht mehr hätte und die weitere Arbeit mit dem Datensatz erschwert werden würde.

Es muss doch eine Lösung geben.
Im Prinzip sollen in Spalte B nur 3 Werte eingetragen werden:

0, 1 oder ein Platzhalter (wie * ~ )


  

Betrifft: AW: Trivial, aber eine Lösung von: Gallanz
Geschrieben am: 30.10.2012 23:31:18

Ich habe selbst eine Lösung gefunden.
Dazu habe ich in Spalte C die gleichen Werte wie in Spalte B eingefügt und in die Formel eine Oder() Funktion eingebaut. Wenn ich also nur nach 1 in Spalte F gesucht habe, wurde in B&C die 1 eingetragen. Das Gleiche für 0.

Wenn ich aber nicht zwischen 1&0 unterschieden wollte, habe ich in Spalte B nur 1 eingetragen und in Spalte C nur 0. Somit bleibt die Formel anwendbar für große Datensätze und nur die Werte in den Spalten B&C müssen geändert werden.

Gallanz


 

Beiträge aus den Excel-Beispielen zum Thema "Platzhalter für beliebige Zahl"