Min (Datum) mit Bedingung



Excel-Version: XP
nach unten

Betrifft: Min (Datum) mit Bedingung
von: Wolfgang Küsters
Geschrieben am: 25.06.2002 - 10:48:33

Hallo und guten Tag,

könnt ihr mir einen Tipp zur folgenden Situation geben?
Spalte A1:A2000 enthält Datumsangaben, sowie Leerzellen.
Spalte B1:B2000 enthält ebenfalls Datumsangaben und Leerzellen.
In Zelle $C$1 steht der Suchbegriff (Datum).
Beispiel:
Spalte A Spalte B Zelle C1
23.05.2002 01.06.2002 01.06.2002
25.05.2002 01.06.2002
25.05.2002 01.06.2002
02.06.2002 01.06.2002
03.06.2002 01.06.2002
Leerzeile
05.06.2002 01.07.2002
06.06.2002 01.07.2002
07.06.2002 01.07.2002
usw

Ich suche nun unter Verwendung der Zelle C1 das niedrigste Datum aus der Spalte A. Muß in diesem Fall der 23.05.2002 sein! Mit WENN als Bedingung für die Spalte B und dann MIN für die Spalte A klappt es leider nicht.

Vielen Dank im voraus.
Wolfgang



nach oben   nach unten

Re: Min (Datum) mit Bedingung
von: Heinz
Geschrieben am: 25.06.2002 - 11:04:30

Hallo Wolfgang,

Wiesoll die Wenn aussehen?

Gib einmal die Bedingung an, damit ich weitermachen kann.

Gruß Heinz


nach oben   nach unten

Re: Min (Datum) mit Bedingung
von: Wolfgang Küsters
Geschrieben am: 25.06.2002 - 11:08:17

Hallo Heinz,

WENN $C$1 = B1:B2000 Dann MIN A1:A2000

Wolfgang

nach oben   nach unten

Re: Min (Datum) mit Bedingung
von: Heinz
Geschrieben am: 25.06.2002 - 11:58:33

Hallo Wolfgang,

in C1 steht das Vergleichsdatum z. B. 01.06.2002. Die Formel

=WENN(VERGLEICH(C1;B1:B2000);MIN(A1:A2000);0)

vergleicht den Eintrag in C1 mit den Einträgen in B und gibt das Minimum aus A zurück.

Ich weiß nicht was due willst. Wenn das Datum in C1 geändert wird egal in welches, immer wird der 23.05.2002 (min) zurückgegeben.

Wenn es das ist was du willst OK, ansonsten melde dich wieder mit genauerer Beschreibung.

Gruß Heinz

nach oben   nach unten

Re: Min (Datum) mit Bedingung
von: Wolfgang Küsters
Geschrieben am: 25.06.2002 - 12:20:05

Hallo Heinz,

genau darum geht es, ich erhalte immer nur das kleinste Datum aus A egal was in C steht.
Ich möchte aber das kleinste Datum aus A analog der Bedingung das sich C ändert.
Siehe meine Tabelle: Wenn ich in C jetzt 01.07.2002 hätte, muß aus A der 05.06.2002 zurückgegeben werden.
Bei Deiner Formel erhalte ich aber den 23.05.2002.

Du verstehst?

Gruß Wolfgang

nach oben   nach unten

Re: Min (Datum) mit Bedingung
von: Heinz
Geschrieben am: 25.06.2002 - 12:43:24

Hallo Wolfgang,

jetzt ist mir dein Problem ganz klar, ich versuche eine Lösung.

Gruß Heinz


nach oben   nach unten

Re: Min (Datum) mit Bedingung
von: Heinz
Geschrieben am: 25.06.2002 - 12:52:26

Hallo Wolfgang,

Lösungsvorschlag (schneller als gedacht)

Füge eine Hilfsspalte ein, (später ausgeblendet) bei mir C.

in c1 die Formel
=WENN(MONAT(B1)=MONAT($D$1);A1;"")

Und die Abfrage für das kleinste Datum in E1 auf diese Hilfsspalte

=WENN(VERGLEICH(D1;B1:B2000);MIN(C1:C2000);0)

Jetzt bekomme ich den gewünschten Wert
für
01.06.2002 23.05.2002
01.07.2002 05.06.2002

Reicht dir das?

Gruß Heinz

nach oben   nach unten

Re: Min (Datum) mit Bedingung
von: Wolfgang Küsters
Geschrieben am: 25.06.2002 - 13:17:28

Hallo Heinz,

werde es später versuchen, werde jetzt erst mal schauen nach welcher Formel die WM 2002 weitergeht!?
Bis dahin schon mal vielen Dank.

Gruß Wolfgang


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Min (Datum) mit Bedingung"