Microsoft Excel

Herbers Excel/VBA-Archiv

Autofüllen Excel nach A1:C1 mit D1:F1 weiter

Betrifft: Autofüllen Excel nach A1:C1 mit D1:F1 weiter von: DerBurch
Geschrieben am: 24.07.2014 15:01:21

Hallo Allerseits,

was kann ich machen, damit die Autofüllaktion nach =Mittelwert(A2:C2) in der 2. Zelle mit =Mittelwert(D2:F2) weitermacht?
In meiner Tabelle sind werte von C3 bis ZZ3 und da möchte ich den Mittelwert pro Quartal auslesen und dann vom mächsten usw...
Wenn es nur per VBA geht auch egal!!!

Danke schonmal im Vorraus

MfG DerBu

  

Betrifft: mit INDEX() ... von: der neopa
Geschrieben am: 24.07.2014 15:08:04

Hallo,

... entweder:
=MITTELWERT(INDEX(1:1;(SPALTE(A1)-1)*3+1):INDEX(1:1;(SPALTE(A1)*3)))
und Formel nach rechts kopieren oder

=MITTELWERT(INDEX($1:$1;(ZEILE(A1)-1)*3+1):INDEX(1:1;(ZEILE(A1)*3)))
und Formel nach unten kopieren.

Gruß Werner
.. , - ...


  

Betrifft: AW: mit INDEX() ... von: DerBurch
Geschrieben am: 24.07.2014 15:30:34

Hallo Werner,
danke für die schnelle Antwort.
Was muss ich machen, wenn meine Werte in Zelle D2 beginnen?
Wenn ich in deiner Formel aus A1 D2 mache, dann kommt da eine viel zu große Zahl heraus, die ich nicht zuordnen kann.
LG DerBurch


  

Betrifft: nur noch etwas dazu addieren ... von: der neopa
Geschrieben am: 24.07.2014 15:42:00

Hallo,

...
=MITTELWERT(INDEX(2:2;(SPALTE(A1)-1)*3+4):INDEX(2:2;(SPALTE(A1)*3)+3)) bzw.
=MITTELWERT(INDEX($2:$2;(ZEILE(A1)-1)*3+4):INDEX($2:$2;(ZEILE(A1)*3+3)))

Gruß Werner
.. , - ...


  

Betrifft: AW: nur noch etwas dazu addieren ... von: DerBurch
Geschrieben am: 24.07.2014 15:53:58

Werner!!! Hab 1000 Dank!!!


 

Beiträge aus den Excel-Beispielen zum Thema "Autofüllen Excel nach A1:C1 mit D1:F1 weiter"