Vertikal nach Element suchen, Summe horizontal

Bild

Betrifft: Vertikal nach Element suchen, Summe horizontal
von: Pinus Radiata
Geschrieben am: 24.09.2015 13:39:41

Moin moin,
ich habe folgende Frage an einen Crack unter Euch:
In der Beispieldatei seht Ihr folgendes Szenario:
Ich habe versch. Mitarbeiter, die in einer oder mehrerer Abteilungen arbeiten können. Jedem Mitarbeiter ist pro Kalenderwoche ein Aufwand zugeordnet.
Nun möchte ich die Summe pro Abteilung haben (s. rote Felder in der Datei). Wenn ein Mitarbeiter jedoch in mehreren Abteilungen arbeitet, soll die Summe durch die Anzahl der Abteilungen dividiert werden.
In der Zusammenfassung bedeutet dies, z.B. für die Spalte B:
- Prüfen ob in der Spalte B ein oder mehrere X stehen.
- Wenn dort ein X steht, die Summe von U5:AB5 / Anzahl der X in Zeile 5 + die identische Prüfung für Zeile 11, weil hier nochmal ein X steht.
Ich hoffe mein Wunsch ist verständlich. Ich bin mir sicher, dass dies eine recht simple summewenn bzw. summenprodukt ist, jedoch habe ich keine funktionierende Lösung gefunden.
Vielen Dank für Eure Hilfe.
Userbild

Bild

Betrifft: Wohl eher Frage für einen Wahrsager, ...
von: Luc:-?
Geschrieben am: 24.09.2015 15:36:45
…Pinus,
denn …
1. viele MA arbeiten für mehrere Abteilungen!
2. was bedeuten die gelben Felder?
3. wo/was ist Zeile 11?
Ansonsten dürfte das nicht sonderlich schwer sein und noch leichter, wenn jedes X-Feld pro MA die Gesamt­Anzahl der Abteilungen, für die er arbeitet, enthalten würde (das kann man per benutzer­definierter Formatierung auch als X darstellen). Dann könnte die Fml (für Spalte A) nämlich so lauten (abgesehen mal von der ominösen Zeile 11):
=SUMMENPRODUKT(MA_Aufwand_T2:Tn/A2:An)
Dabei gehe ich davon aus, dass dieser MA_Aufwand pro KW je MA und KW unterschiedlich sein kann und deshalb hier auch nur eine KW gemeint ist.
Anderenfalls müsste die Anzahl der X pro Zeile erst noch ermittelt wdn, was eine zeilenweise ANZAHL-Berechnung einer Matrix voraussetzt. Darauf sind diese alten Standard-Xl-Fktt nicht ausgelegt (Hilfsspalte!). Du solltest das aber mit neueren, in deiner Version ggf auch mit AGGREGAT, ohne Hilfsspalte lösen können.
Übrigens, wenn du eine exakt passende Lösung erhalten willst und nicht nur Lösungstipps, solltest du eine BspDatei, nicht nur ein Bild hochladen. Die Wenigsten haben Lust, das Bild nachzubauen, um die Fml auch testen zu können.
Gruß, Luc :-?

Besser informiert mit …

Bild

Betrifft: AW: Vertikal nach Element suchen, Summe horizontal
von: matthias
Geschrieben am: 24.09.2015 15:48:50
Hallo Pinus,
nutze doch eine Hilfsspalte in der die Anzahl der Kreuzchen für einen Mitarbeiter gezählt werden:
AC2: "=Anzahl2(B2:S2)"
In der Spalte dann eine einfache Rechnung:
B18: "{=SUMME((ISTLEER(B2:A16)=FALSCH)/$AC2:$AC16)}"
lg Matthias

Bild

Betrifft: AW: Vertikal nach Element suchen, Summe horizontal
von: matthias
Geschrieben am: 24.09.2015 15:53:09
Ändere noch bitte in der Hilfsspalte:
WENN(ANZAHL2(B2:S2)=0;-1;ANZAHL2(B2:S2))
Damit wird eine Division durch Null ausgeschlossen. Die -1 wird eh nicht berücksichtigt, da in der Zeile keine Kreuzchen sind.
lg Matthias

Bild

Betrifft: AW: Vertikal nach Element suchen, Summe horizontal
von: matthias
Geschrieben am: 24.09.2015 15:56:11
B18: "{=SUMME((ISTLEER(B2:B16)=FALSCH)/$AC2:$AC16)}"

Bild

Betrifft: Siehe auch hier:
von: Luc:-?
Geschrieben am: 24.09.2015 19:12:52
http://www.office-loesung.de/p/viewtopic.php?f=166&t=703032
Luc :-?

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Vertikal nach Element suchen, Summe horizontal "