Microsoft Excel

Herbers Excel/VBA-Archiv

Werte ab bestimmten Monat summieren

Betrifft: Werte ab bestimmten Monat summieren von: Frederic
Geschrieben am: 16.10.2020 10:58:08

Hallo zusammen,

folgendes Problem: Ich habe ein Feld, wo ein Datum drin steht (z.B. 01.09.2020). Nun möchte ich ab diesem Datum bis Ende meiner Zeitreihe alles summieren..

https://www.herber.de/bbs/user/140906.xlsx

also Stichtag ist der 01.09.2020 und alles ab Stichtag bis Ende (hier: 01.06.2021) soll summiert werden.
Der Punkt ist, dass es dynamisch sein soll, da sich der Stichtag natürlich nächsten Monat ändert auf Oktober und dann alles ab November summiert werden muss.

Beste Grüße
Frederic

Betrifft: AW: Werte ab bestimmten Monat summieren
von: SF
Geschrieben am: 16.10.2020 11:01:37

Hola,

nimm Summewenn().

Gruß,
steve1da

Betrifft: AW: Werte ab bestimmten Monat summieren
von: Frederic
Geschrieben am: 16.10.2020 11:15:59

Hey ;)

das hilft mir nicht wirklich weiter leider.. da ich es mit Summewenn versucht habe.. es dynamisch hinzubekommen, mit Monat größer Monat(Stichtag) oder so.. ich weiß nicht wie ich es lösen kann.. stehe vllt auch auf dem Schlauch..

Beste Grüße
Frederic

Betrifft: AW: Werte ab bestimmten Monat summieren
von: SF
Geschrieben am: 16.10.2020 11:22:34

Hola,

das Suchkriterium wäre
">"&D8
Gruß,
steve1da

Betrifft: AW: Werte ab bestimmten Monat summieren
von: Frederic
Geschrieben am: 16.10.2020 11:31:11

aaaah stimmt mit ">"&D8

Danke!

Betrifft: AW: Werte ab bestimmten Monat summieren
von: Frederic
Geschrieben am: 16.10.2020 11:43:23

sry ich muss nochmal aufmachen ..
habe das Jahr noch als Kriterium mit eingefügt

=SUMMEWENNS(B4:Y4;B3:Y3;">"&D8;B1:Y1;"2021")
aber das spuckt der mir auch den gleichen Wert aus..
im letzten Schritt würde ich nämlich auch noch Quartal hinzunehmen :)

Beste Grüße
Frederic

Betrifft: AW: Werte ab bestimmten Monat summieren
von: SF
Geschrieben am: 16.10.2020 11:46:51

Hola,

da alle Werte im Jahr 2021 vorliegen, wieso erwartest du bei 2021 als Suchkriterium ein anderes Ergebnis?
Außerdem suchst du nach dem TEXT 2021, nicht nach der ZAHL.

Gruß,
steve1da

Betrifft: AW: Werte ab bestimmten Monat summieren
von: Frederic
Geschrieben am: 16.10.2020 11:51:19

Hallo Steve,

ganz oben steht ja 2020 und 2021. Auch wenn ich anstelle des Datums nur den Monat nehme und das Jahr in eine Zelle schreibe und darauf verweise geht es nicht.. der müsste ja 0 anzeigen oder bin ich grade doof? :D
=SUMMEWENNS(B4:Y4;B3:Y3;">"&MONAT(D8);B1:Y1;D7)

Beste Grüße
Frederic

Betrifft: AW: Werte ab bestimmten Monat summieren
von: SF
Geschrieben am: 16.10.2020 11:54:38

Hola,

Monat(D8) ergibt die Zahl 9, das Datum ist eine fortlaufende Zahl beginnend am 01.01.1900 mit der Zahl 1. Der 01.09.2021 ist somit die Zahl 44075. Das kann nicht funktionieren.
Aber nochmal: du hast nur Werte im Jahr 2021 stehen die du mit der ersten Summewenn() Formel auch richtig ermittelt hast. Wenn du jetzt nur auf das Jahr 2021 abstellst, wie soll denn da eine andere Summe herauskommen?

Gegenfrage: was erwartest du denn in deiner Beispieldatei als Ergebnis für 2021?

Gruß,
steve1da

Betrifft: AW: Werte ab bestimmten Monat summieren
von: Frederic
Geschrieben am: 16.10.2020 13:27:44

Hallo Steve,

also in Zeile 1 steht 2020 und 2021 drin. Das sind die beiden Geschäftsjahre. Ich möchte das er vom Monat 9 und 2021 (Zeile1) alles summiert, was ca. 282000 ergibt. Demzufolge Monat 9 und 2020(Zeile1) wäre 0

Beste Grüße
Frederic

Betrifft: AW: Werte ab bestimmten Monat summieren
von: SF
Geschrieben am: 16.10.2020 13:33:28

Hola,

und genau das macht doch deine Formel die du gepostest hast.
=SUMMEWENNS(B4:Y4;B3:Y3;">"&D8;B1:Y1;2021)

Gruß,
steve1da

Betrifft: AW: Werte ab bestimmten Monat summieren
von: Frederic
Geschrieben am: 16.10.2020 14:13:41

habs :)

Betrifft: AW: Werte ab bestimmten Monat summieren
von: Frederic
Geschrieben am: 16.10.2020 11:16:00

Hey ;)

das hilft mir nicht wirklich weiter leider.. da ich es mit Summewenn versucht habe.. es dynamisch hinzubekommen, mit Monat größer Monat(Stichtag) oder so.. ich weiß nicht wie ich es lösen kann.. stehe vllt auch auf dem Schlauch..

Beste Grüße
Frederic