Addition von Werten gleicher Wochentage

Bild

Betrifft: Addition von Werten gleicher Wochentage von: Klaus
Geschrieben am: 08.02.2005 17:20:43

Hallo,

mache Thread wg. unklar formulierter Problemstellung meinerseits noch mal auf:

Ich möchte Werte addieren, die zu Datumsangaben zurückliegender, gleicher Wochentage gehören und sie separat ausgeben.

https://www.herber.de/bbs/user/17645.xls

Bild


Betrifft: AW: Addition von Werten gleicher Wochentage von: Josef Ehrensberger
Geschrieben am: 08.02.2005 17:31:45

Hallo Klaus!

Meinst du so?
Tabelle1
 ABCDEFG
1DatumFiskalmonatWochentag  Anzahl 
2       
324.07.2004JulSat  12 
425.07.2004JulSun  2 
526.07.2004JulMon  3 
627.07.2004JulTue  3 
728.07.2004JulWed  3 
829.07.2004JulThu  3 
930.07.2004JulFri  3 
10   29 
1131.07.2004JulSat  3 
1201.08.2004AugSun  3 
1302.08.2004AugMon  3 
1403.08.2004AugTue  3 
1504.08.2004AugWed  3 
1605.08.2004AugThu  0 
1706.08.2004AugFri  3 
1807.08.2004AugSat  315
1908.08.2004AugSun  35
2009.08.2004AugMon  36
2110.08.2004AugTue  36
2211.08.2004AugWed  36
2312.08.2004AugThu  03
2413.08.2004AugFri  36
Formeln der Tabelle
F10 : =SUMME(F3:F9)
G18 : =SUMMENPRODUKT((WOCHENTAG($A$3:$A$17;2)=6)*($A$3:$A$17<>"")*($F$3:$F$17))
G19 : =SUMMENPRODUKT((WOCHENTAG($A$3:$A$17;2)=7)*($A$3:$A$17<>"")*($F$3:$F$17))
G20 : =SUMMENPRODUKT((WOCHENTAG($A$3:$A$17;1)=4)*($A$3:$A$17<>"")*($F$3:$F$17))
G21 : =SUMMENPRODUKT((WOCHENTAG($A$3:$A$17;2)=2)*($A$3:$A$17<>"")*($F$3:$F$17))
G22 : =SUMMENPRODUKT((WOCHENTAG($A$3:$A$17;2)=3)*($A$3:$A$17<>"")*($F$3:$F$17))
G23 : =SUMMENPRODUKT((WOCHENTAG($A$3:$A$17;2)=4)*($A$3:$A$17<>"")*($F$3:$F$17))
G24 : =SUMMENPRODUKT((WOCHENTAG($A$3:$A$17;2)=5)*($A$3:$A$17<>"")*($F$3:$F$17))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  




Gruß Sepp

P.S.: Rückmeldung nicht vergessen!


Bild


Betrifft: AW: Addition von Werten gleicher Wochentage von: Klaus
Geschrieben am: 08.02.2005 17:56:03

Hallo Sepp,

vielen Dank. Total Klasse. Was bedeuten einmal((WOCHENTAG($A$3:$A$17;2)=2 und zum anderen ((WOCHENTAG($A$3:$A$17;1)=4) und jeweils *($A$3:$A$17<>"")*($F$3:$F$17)) nach dem Wochentag-Ausdruck? Das ganze sollte dann noch dynamisch sein, d.h. es sollen bei fortschreitendem Jahr (also von Tag zu Tag) ab dem 12.08. immer die letzten 2 gleichen Wochentage der jeweiligen Vorwochen addiert werden. Ist das machbar?

Gruß,
Klaus


Bild


Betrifft: AW: Addition von Werten gleicher Wochentage von: Josef Ehrensberger
Geschrieben am: 08.02.2005 19:14:58

Hallo Klaus!

Das ist sicher machbar, aber dazu sollte man den aufbau der Tabelle kennen!

Der Aufbau deines Beispieles ist ein bischen unglücklich(verbundene Zellen)!

Deshalb auch "*($A$3:$A$17<>"")" .

"(WOCHENTAG($A$3:$A$17;2)=6)" bedeutet in diesem Fall - Wochentag = 1, also Montag, -
2 = Dienstag, usw.!




Gruß Sepp

P.S.: Rückmeldung nicht vergessen!


Bild


Betrifft: AW: Addition von Werten gleicher Wochentage von: Klaus
Geschrieben am: 09.02.2005 11:05:36

Hallo,

macht es Sinn, wenn ich die komplette Tabelle (bisher nur ein Ausschnitt) noch einmal in "sauberer" Form zur Verfügung stelle?

Gruß,
Klaus


Bild


Betrifft: AW: Addition von Werten gleicher Wochentage von: Klaus
Geschrieben am: 09.02.2005 15:56:07

Schließe Thread und eröffne neuen mit optimierter Beispieldatei.


Bild


Betrifft: AW: Addition von Werten gleicher Wochentage von: UweN
Geschrieben am: 08.02.2005 17:31:48

Hallo Klaus,

schreibe in G23 folgendes rein:
=SUMMENPRODUKT((C3:C23="Thu")*F3:F23)

G24:
=SUMMENPRODUKT((C3:C23="Fri")*F3:F23)

etc...


Viele Grüße
Uwe


Bild


Betrifft: AW: Addition von Werten gleicher Wochentage von: Klaus
Geschrieben am: 08.02.2005 17:57:58

Hallo Uwe,

vielen Dank. Siehe meine Antwort an Josef. Ähnelt Deiner Lösung.

Gruß,
Klaus


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Addition von Werten gleicher Wochentage"