Mit einer Zahl die Anzahl Spalten bestimmen

Bild

Betrifft: Mit einer Zahl die Anzahl Spalten bestimmen von: Erich M.
Geschrieben am: 27.02.2005 15:09:26

Hallo EXCEL-Freunde,

ich möchte eine Summenbildung ab der Spalte C nach rechts variabel gestalten,
indem ich durch eine Zahl bestimme wieviele Spalten summiert werden sollen:

Ergebnis
 ABCDEFGHIJKL
1Spalten:10 <---- = variabel         
2Summe:012345678910
3            
4            
5Spalten:9 <---- = variabel         
6Summe:0123456789 
Formeln der Tabelle
B2 : =SUMME($C2:L2)
B6 : =SUMME($C6:K6)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Besten Dank für eine Hilfe!

mfg
Erich
http://www.toolex.de
EXCEL-Shareware und Freeware
Bild


Betrifft: AW: Mit einer Zahl die Anzahl Spalten bestimmen von: Reinhard
Geschrieben am: 27.02.2005 15:23:57

Hi Erich,
bis jmd kommt der Formeln kann, versuchs mal so:
Tabellenblattname: Tabelle1
   A  | B  | C | D  | 
1|  3 | 64 |   |    | 
2| 45 | 12 | 7 | 32 | 
Benutzte Formeln:
B1:  =SUMME(INDIREKT("Z(1)S(-1):Z(1)S"&A1;))
Gruß
Reinhard
Tabelle wurde eingefügt mit Code von https://www.herber.de/forum/technik/messages/1226.html 



Bild


Betrifft: AW: Mit einer Zahl die Anzahl Spalten bestimmen von: Hübi
Geschrieben am: 27.02.2005 15:24:03

Hi Erich,

wie immer, warte ich mit einer langen Formel auf
Tabelle1
 ABCDEFGHI
1Spalten5       
2Summe151234567
Formeln der Tabelle
B2 : =SUMME(INDIREKT("C2:"&ADRESSE(ZEILE();B1+2)))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hübi


Bild


Betrifft: AW: Mit einer Zahl die Anzahl Spalten bestimmen von: Erich M.
Geschrieben am: 27.02.2005 15:40:39

Hallo Hübi,

wenn ich die Formel nach unten kopieren will:
- wie muss ich "C2:" ändern?
- bei B1 muss ich wohl mit B$1 arbeiten?

Und was bedeutet +2 ??

Besten Dank nochmal!

mfg
Erich
http://www.toolex.de
EXCEL-Shareware und Freeware


Bild


Betrifft: AW: Mit einer Zahl die Anzahl Spalten bestimmen von: Hübi
Geschrieben am: 27.02.2005 16:02:38

Hi Erich,

dann so
Tabelle1
 ABCDEFGHIJ
1Spalten4        
2Summe101234567<- lange Formel
3 38891011121614 
4 10       <- kürzer
5 38        
6was ist +2 ?C2:$F$2        
7 C2:$D$2        
Formeln der Tabelle
B2 : =SUMME(INDIREKT("C"&ZEILE()&":"&ADRESSE(ZEILE();B$1+2)))
B3 : =SUMME(INDIREKT("C"&ZEILE()&":"&ADRESSE(ZEILE();B$1+2)))
B4 : =SUMME(BEREICH.VERSCHIEBEN(C2;;;1;B$1))
B5 : =SUMME(BEREICH.VERSCHIEBEN(C3;;;1;B$1))
B6 : ="C"&ZEILE(A2)&":"&ADRESSE(ZEILE(A2);B$1+2)
B7 : ="C"&ZEILE(A2)&":"&ADRESSE(ZEILE(A2);B$1)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hübi


Bild


Betrifft: Danke Hübi - perfekt! o.T. von: Erich M.
Geschrieben am: 27.02.2005 16:26:46

.


Bild


Betrifft: gern geschehen o.T. von: Hübi
Geschrieben am: 27.02.2005 18:35:01




Bild


Betrifft: oder so von: Reinhard
Geschrieben am: 27.02.2005 15:28:18

Hi Erich,
Tabellenblattname: Tabelle1
   A  | B  | C | D  | 
1|  3 | 64 |   |    | 
2| 45 | 12 | 7 | 32 | 
Benutzte Formeln:
B1:  =SUMME(BEREICH.VERSCHIEBEN(A2;0;0;1;A1))
Gruß
Reinhard
Tabelle wurde eingefügt mit Code von https://www.herber.de/forum/technik/messages/1226.html 



 Bild

Beiträge aus den Excel-Beispielen zum Thema "Mit einer Zahl die Anzahl Spalten bestimmen"