Microsoft Excel

Herbers Excel/VBA-Archiv

Bedingte Form. Anzahl pro Kalenderwoche

Betrifft: Bedingte Form. Anzahl pro Kalenderwoche von: Dominik Backhaus
Geschrieben am: 15.09.2020 11:20:05

Hallo zusammen,

ich bin auf der Suche nach einer Formel, welche ich zur bedingten Formatierung eines Spaltenkopf nutzen kann.

Ausgangssituation:

Ich habe eine Tabelle mit einer Vielzahl an Projekten.

Jedes Projekt eine Zeile.

Die Spalten stellen unter anderem die Gates der Projekte dar.

Zur Vereinfachten Darstellung möchte ich gerne das der Spaltenkopf eingefärbt wird wenn in der Spalte z.B: QS/Vermessung in einer Kalenderwoche 3 oder mehr Einträge sind.

Leider komme ich auf keine Lösung die Abfrage ob in eine Kalenderwoche eine Anzahl von 3 überschritten ist oder nicht in eine Excelformel zu transferieren.


Ich hoffe man kann einigermaßen verstehen was ich meine. Zur Veranschaulichung habe ich eine Beispiel Datei angehangen, hier habe ich das ganze manuell eingefärbt.

https://www.herber.de/bbs/user/140233.xlsx

Kann mir jemand helfen?

Gruß und Dank

Betrifft: AW: Bedingte Form. Anzahl pro Kalenderwoche
von: SF
Geschrieben am: 15.09.2020 11:23:14

Hola,
=ZÄHLENWENN($D$3:$D$18;D3)>=3

Gruß,
steve1da

Betrifft: AW: Bedingte Form. Anzahl pro Kalenderwoche
von: Dominik Backhaus
Geschrieben am: 15.09.2020 11:41:01

Hallo und danke für die prompte Beantwortung.
Das Problem löst sich hierdurch aber leider nicht.

Die Spalte mit der Kalenderwoche (=KALENDERWOCHE(B3;2)) war hier im Beispiel nur als Hilfestellung gedacht damit niemand sich noch die Mühe machen muss und die Kalenderwochen abzuleiten.

Also es soll im Beispiel nur die Zelle B2 gelb hinterlegt sein wenn in der kompletten Spalte B3:B18. 3 Termine in einer Kalenderwoche stattfinden. Bei nur 2 Terminen soll nichts passieren, Bei mehr als 3 soll sich die Zelle rot färben.

Betrifft: AW: Bedingte Form. Anzahl pro Kalenderwoche
von: Rolf
Geschrieben am: 15.09.2020 12:23:54

Hallo Dominik

das geht (für mich) nur mit Hilfsspalte, die Du ja ausblenden kannst.

mit Hilfsspalte H, in der die KW's stehen:

=MAX(ZÄHLENWENN($H$3:$H$18;$H$3:$H$18))>3
bzw.
=MAX(ZÄHLENWENN($H$3:$H$18;$H$3:$H$18))=3

als Formeln für die bed. Formatierung und entsprechend einfärben.

Gruß Rolf

Betrifft: AW: Bedingte Form. Anzahl pro Kalenderwoche
von: Dominik Backhaus
Geschrieben am: 15.09.2020 13:19:49

Hallo Rolf,
danke für Deine Lösung, ich denke mit der Hilfsspalte (ausgeblendet) werden sich die Nutzer arrangieren müssen und können. Andernfalls dürfen sie aber auch gerne weiterhin manuell die Liste nach 3 oder mehr einträgen pro KW durchforsten ;)

Auch an steve1da, nochmals danke! Ich glaube Dein Vorschlag zielte in die selbe Richtung, das habe ich aber verkannt. Entschuldigung.

Jetzt kommen für mich gerade noch zwei weitere Fragen auf, evtl. gibt es hierzu ja auch noch eine Idee.

1. Wie kann ich mit leeren Zellen umgehen, also Projektnummer angelegt, aber noch nicht terminiert. Die Hilfsspalte (D) zeigt ohne Eingabe 1 für die KW an oder bei Füllung wie "nicht terminiert" #WERT! an.
Habe ich 3 solcher Projekte egal ob 3 ohne Termin (1) oder 3 gefüllt mit beliebigen Text (#WERT!) färbt sich die Zelle natürlich wunschgemäß leider auch.

2. gibt es ggf. eine einfach Möglichkeit die Zellen mit zu formatieren, welche die Formatierung des Spaltenkopfes B2 auslösen? Das wäre natürlich Champions League

Gruß und Dank

Betrifft: AW: Bedingte Form. Anzahl pro Kalenderwoche
von: Rolf
Geschrieben am: 15.09.2020 16:31:09

Hallo Dominik

für den ersten Punkt hab ich im Moment auch keine Idee,

zum Markieren der "Auslöser"
als bed. Formatierung für D3:D18:

=KALENDERWOCHE(D3;21)=INDEX($H$3:$H$18;VERGLEICH(MAX(ZÄHLENWENN($H$3:$H$18;$H$3:$H$18)); ZÄHLENWENN($H$3:$H$18;$H$3:$H$18);0))

Gruß Rolf

Betrifft: AW: Bedingte Form. Anzahl pro Kalenderwoche
von: Rolf
Geschrieben am: 15.09.2020 16:54:45

Hallo Dominik

habe gerade gesehen die Formel, die ich Dir geschickt habe, zeigt nur den ersten Treffer an.
Wenn Du alle Auslöser haben willst, nimm diese:

=ZÄHLENWENN($H$3:$H$18;H3)=MAX(ZÄHLENWENN($H$3:$H$18;$H$3:$H$18))

Gruß Rolf

Beiträge aus dem Excel-Forum zum Thema "Bedingte Form. Anzahl pro Kalenderwoche"