Microsoft Excel

Herbers Excel/VBA-Archiv

EXCEL-Datei packen / WinZip

Betrifft: EXCEL-Datei packen / WinZip von: Erich M.
Geschrieben am: 05.09.2004 08:52:19

Hallo EXCEL-Freunde,

ich habe zwei Dateien, die ich mit dem TotalCommander packe - die Ergebnisse
verstehe ich aber nicht:
1. Datei mit 993KB; nach packen: 743KB; diese Datei ist mit einem Kennwort
für die Datei und mit einem Kennwort für das VBA-Projekt geschützt.

2. Datei: 3.487KB; nach packen: nur 668KB (??); diese Datei hat keine
Kennwörter; die Inhalte der Dateien sind ähnlich, die 2. Datei hat nur
wesentlich mehr Berechnungen und Codes, deshalb größer.

Kann es sein, dass durch die Kennwörter die 1.Datei beim packen nicht so
klein werden kann??

Besten Dank für eine Info!

mfg
Erich

  


Betrifft: AW: EXCEL-Datei packen / WinZip von: Ramses
Geschrieben am: 05.09.2004 09:51:31

Hallo

Warum es in diesem Fall so ist, kann ich dir auch nicht erklären.
Grundsätzlich suchen Packprogrammen nach Abfolgen gleicher Zahlen und stellen diese anders dar.

Z.B. kann aus "0000000000" die Zeichenfolge "10x0" werden, ... 6 Zeichen gespart.

Dadurch können EXE-Dateien oder JPG-Dateien z.B. kaum noch komprimiert werden, während BMP Dateien bis zum Faktor 20 oder 30 komprimiert werden können.

In deinem Fall kann es nun sein, ganz banal ausgedrückt, dass z.B. eine Formel wie "=SVERWEIS(A1;B1:C15;2;0)" tausendmal auftaucht, dann schreibt das Packprogramm halt die entsprechende Information *1000 rein, und die gepackte Dateigrösse verringert sich entsprechend.

Der Algorithmus und wie das Programm vorgeht, ist schwierig zu beurteilen.

Gruss Rainer


  


Betrifft: Danke für die Info - Rainer; o.T. von: Erich M.
Geschrieben am: 05.09.2004 10:44:06

.


 

Beiträge aus den Excel-Beispielen zum Thema "EXCEL-Datei packen / WinZip"