Ausgabe eines Namens mittels Zufallsgenerator

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
Bild

Betrifft: Ausgabe eines Namens mittels Zufallsgenerator von: stephan r.
Geschrieben am: 11.02.2005 15:42:14

Hallo,
ihr seit meine letzte Hoffnung.
Ich müßte aus einer Tabelle mit Adressdaten mittels Zufallsgenerator einen Namen ausfiltern und diesen mittels Messagebox anzeigen lassen!!
Könnte mir jemand helfen???? BITTE BITTE

Wäre es auch möglich den Zufallsgenerator laufen zu lassen, aber dann sollte ein vorher definierter Namen in der Messagebox ausgegeben werden?????

DANKE FÜR EURE HILFE,
Stephan

Bild


Betrifft: AW: Ausgabe eines Namens mittels Zufallsgenerator von: UweD
Geschrieben am: 11.02.2005 15:52:43

Hallo


auf die schnelle noch eins.


Sub Zufallsname()
    Dim Zufall%
    Zufall = Int((6 * Rnd) + 1)  'aus "A1:A6"
    MsgBox Cells(Zufall, 1)
End Sub


https://www.herber.de/bbs/user/17859.xls


Gruß UweD


Bild


Betrifft: AW: Ausgabe eines Namens mittels Zufallsgenerator von: stephan r.
Geschrieben am: 11.02.2005 16:01:47

Danke für die superschnelle Antwort.
Wenn ich aber folgendes möchte:
- Es sollte offensichtlich sein, daß der ausgegebene Namen mittels Zufallsgenerator ausgewählt wurde. Dazu könnte man z.Bsp. mittels MsgBox die Namen durchlaufen sehen.
- Erst anschließend soll der Namen ausgegeben werden.

Danke,
Stephan


Bild


Betrifft: AW: Ausgabe eines Namens mittels Zufallsgenerator von: UweD
Geschrieben am: 11.02.2005 16:10:38

so??

https://www.herber.de/bbs/user/17861.xls
Gruß Uwe


Bild


Betrifft: AW: Ausgabe eines Namens mittels Zufallsgenerator von: stephan r.
Geschrieben am: 11.02.2005 16:16:09

Hallo uwe,
super. das klappt wunderbar.
kann ich auch irgendwie über das makro machen, daß die zelle C1 nach ausgabe des Namens über die msgbox gelöscht wird???

danke,
stepan


Bild


Betrifft: AW: Ausgabe eines Namens mittels Zufallsgenerator von: Udo
Geschrieben am: 11.02.2005 16:21:24

https://www.herber.de/bbs/user/17866.xls

Udo


Bild


Betrifft: AW: Ausgabe eines Namens mittels Zufallsgenerator von: stephan r.
Geschrieben am: 11.02.2005 16:23:51

Super, vielen Dank für die prompte Hilfe.
stephan


Bild


Betrifft: als ansatz von: th.heinrich
Geschrieben am: 11.02.2005 16:01:01

hallo Stephan,

siehe funktion Zufallsbereich in kombination mit SVERWEIS an.

Tabelle2
 ABC
11eins3
22nullvier
33vier 
44sechs 
Formeln der Tabelle
C1 : =ZUFALLSBEREICH($A$2;$A$4)
C2 : =SVERWEIS($C$1;$A$1:$B$4;2;WAHR)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


gruss thomas


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Ausgabe eines Namens mittels Zufallsgenerator"