Microsoft Excel

Herbers Excel/VBA-Archiv

Fehlermeldungen bei Arrayformel abschalten | Herbers Excel-Forum


Betrifft: Fehlermeldungen bei Arrayformel abschalten von: Frank Selleng
Geschrieben am: 04.02.2010 13:21:07

Hallo Leute,

hab mal wieder ein Problemchen welches für Euch sicher keine Hürde darstellt.

Ich möchte das Anzeigen von Werten wie #NV, oder "0" nach der Berechnung mit einer Arrayformel (wenn keine Werte vorhanden sind) unterdrücken.

Bei ner normalen Formel geht's ja über die "wenn" funktion das krieg ich hin aber wie geht's bei der folgenden Arrayformel?
( Die Formel hab ich hier im Archiv gefunden und nur noch angepasst, insofern habt Ihr mir ja schon geholfen, jetzt halt noch Feintuning ;-))

{=INDEX(Eingabe!$D$3:$D$200;VERGLEICH($A$2&$B$2;Eingabe!$B3:$B$200&Eingabe!$C$3:$C$200;))}

Danke im Voraus für Eure Hilfe

Gruß Frank

  

Betrifft: AW: Fehlermeldungen bei Arrayformel abschalten von: Ramses
Geschrieben am: 04.02.2010 13:41:04

Hallo

"...Bei ner normalen Formel geht's ja über die "wenn" funktion..."

Hier auch, ... immer erst mal ausprobieren

Die einfachste Variante

{=WENN(Istfehler(INDEX(Eingabe!$D$3:$D$200;VERGLEICH($A$2&$B$2; Eingabe!$B3:$B$200&Eingabe!$C$3:$C$200;)));"";INDEX(Eingabe!$D$3:$D$200;VERGLEICH($A$2&$B$2; Eingabe!$B3:$B$200&Eingabe!$C$3:$C$200;))) }

Die detaillierte Variante,... weil der Fehler ja nur hier auftritt

{=Wenn(Istfehler(VERGLEICH($A$2&$B$2;Eingabe!$B3:$B$200&Eingabe!$C$3:$C$200;));""; INDEX(Eingabe!$D$3:$D$200;VERGLEICH($A$2&$B$2;Eingabe!$B3:$B$200&Eingabe!$C$3:$C$200;))) }

Gruss Rainer


  

Betrifft: SUPER schneller und besser geht nicht Danke von: Frank Selleng
Geschrieben am: 04.02.2010 13:56:26

Hallo Rainer,

Danke für die schnelle Antwort, funktioniert natürlich bestens.

Gruß Frank


Beiträge aus den Excel-Beispielen zum Thema "Fehlermeldungen bei Arrayformel abschalten"