Microsoft Excel

Herbers Excel/VBA-Archiv

Alternative zu Arrayformel

Betrifft: Alternative zu Arrayformel von: Arthur
Geschrieben am: 23.11.2012 13:35:14

Hallo zusammen

Hubert hier im Forum hat mir schon sehr toll mit zwei herunterziehbaren Formeln geholfen. Ich bin echt happy mit der Lösung und kann so sehr viel Zeit einsparen. Nochmals vielen Dank!

Die eine Formel ist aber eine Arrayformel und die macht manchmal Probleme, wenn zum Beispiel mit dem Autofilter Zeilen rausgelöscht werden.

Gibt es anstelle der Arrayformel (siehe Excel) noch eine andere Formel, die ich runterziehen kann?

https://www.herber.de/bbs/user/82746.xlsx

Vielen herzlichen Dank für eure Hilfe und Gruss
Arthur

  

Betrifft: AW: Alternative zu Arrayformel von: Harald
Geschrieben am: 23.11.2012 13:52:00

Wenn Du Summewenns verwendest funktioniert es auch ohne array

=WENN(B2="";"";G2/(+SUMMEWENNS(D:D;B:B;B2)))


Harald


  

Betrifft: AW: Alternative zu Arrayformel von: Arthur
Geschrieben am: 23.11.2012 14:18:47

Oh supertrouper! So funktionierts auch, vielen Dank!!


  

Betrifft: AW: Alternative zu Arrayformel von: Harald
Geschrieben am: 23.11.2012 14:35:48

Freut mich!

Noch ein schönes Wochenende

LG

Harald


 

Beiträge aus den Excel-Beispielen zum Thema "Alternative zu Arrayformel"